Jump to content

BUSCADOR NO FUNCIONA


Recommended Posts

  • 3 weeks later...

¿Alguna idea sobre el funcionamiento de la búsqueda?. Tengo la versión de prestashop 1.7.6.8 la plantilla es Exactly Versión 3.0.0 Diseñada por Webiarch, y da igual con la Classic o la Minimal -variante de classic css-  (para los amantes de usar sólo aquello que es oficial) ocurre lo mismo aunque en estas dos no tengo la opción de botón mostrar todos y la imagen3 es también el resultado para cuando cansado de esperar que muestre resultados pulso intro. Otro dato, estoy cansado también de indexar las búsquedas cada cambio que hago en algún dato relevante o supuestamente relevante como el peso de aparición que parece que se lo pasa por el forro de la entrepierna.

En la búsqueda pone un orden que no obedece al peso ya que tengo más peso en las categorías que en las descripciones, por motivos de origen de los productos, y me saca antes la descripciones que la categoría (imagen1). Dice que encuentra 222 elementos. 

Tengo la santa paciencia de bajar hasta el final (poniéndoselo fácil al usuario -modo ironia off-) y veo que hay productos que quiero pulso el botón  "mostrar todos" (imagen2) y me dice que no encuentra ningún resultado (imagen3).

Esto es de locos macho. No se si actualizar a la versión 1.7.6.9 o virgencita que me quede como estoy porque va uno saltando (con perdón de la expresión) de cagada en cagada e igual funciona bien la búsqueda y dejan de funcionar bien 30 cosas, ya que por desgracia así vamos.

Si alguno más le ha pasado, ya que veo poco movimiento en este post y mucho ruido sobre este tema en los buscadores, y, pocas nueces (soluciones al respecto), por favor me orientara con la forma de solucionarlo, ya que me lleva loco. Si no, pues nos encomendamos a la providencia para cuando los señores de prestashop decidan revisar bien el software antes de su lanzamiento. Sufri con la 1.5, 1.6 y ahora también con la 1.7, no se que narices hago, igual soy masoca. Macho es que esto de prestashop a veces no tiene nombre.

Un saludo.

Ramiro.

 

Image1.jpg

Image2.png

Image3.jpg

Share this post


Link to post
Share on other sites

Bueno. Desgraciadamente no puedo darte luz en esto, pero si recomendarte alternativas profesionales.

Bajo mi experiencia  creo que le debes de pegar un ojo a doofinder, siempre que puedas y estés dispuesto a pasar por caja de forma mensual. Es una herramienta brutal indispensable para según que negocios. Que por cierto soy partner y si te interesa Mándame un mp. 

Otra alternativa que he probado y con resultados satisfactorios es un módulo que se llama jolisearch, un único pago y si no tienes muchas referencias, está muy bien.

Siento no poder darte otro tipo de respuesta.

Un saludo

Share this post


Link to post
Share on other sites
12 hours ago, Pixefora D said:

Bueno. Desgraciadamente no puedo darte luz en esto, pero si recomendarte alternativas profesionales.

Bajo mi experiencia  creo que le debes de pegar un ojo a doofinder, siempre que puedas y estés dispuesto a pasar por caja de forma mensual. Es una herramienta brutal indispensable para según que negocios. Que por cierto soy partner y si te interesa Mándame un mp. 

Otra alternativa que he probado y con resultados satisfactorios es un módulo que se llama jolisearch, un único pago y si no tienes muchas referencias, está muy bien.

Siento no poder darte otro tipo de respuesta.

Un saludo

A ver, sinceramente, agradezco tu respuesta y tu consejo, pero antes de pagar 29 lereles por un módulo para que prestashop haga bien su trabajo (que es una lástima que no lo haga), migro la tienda a Shopify que por el mismo precio (29 lereles) tengo un sistema que funciona, evitando este tipo de errores y con el mismo precio que vale un solo módulo prestashop.

Estoy bastante quemado con este tema, y cualquier cosa que quieres hacer con prestashop vale un pastizal, es decir, que es gratuito pero para que todo este en condiciones te tienes que gastar una pasta. ¿Esto que es?

Y que será lo próximo el menú que lo quiero vertical y mas funcional? pues toma gástate 70 lereles más. No digo que prestashop tenga que dar más opciones, pero las que da por lo menos que funcionen correctamente.

Un saludo,

 

 

Share this post


Link to post
Share on other sites

Pues no te lo pienses y Go a Shopify.

Personalmente estoy contento con PrestaShop y lo que comentas del buscador a mi no me pasa o me ha pasado. Lo de pasar por caja ya depende de que quieras para tu tienda o necesites, con lo que trae de base puedes vender.

Si quieres un menú vertical dependes del theme que tengas, no de PrestaShop, pero que esto es igual que en WordPress y WooCommerce... no hay un botón de PONME EL MENÚ EN VERTICAL!! para todos los wordpress, sino que depende del theme.

 

Un saludo y mucha suerte con Shopify, sin duda también es una buena opción para tu tienda.

 

 

Share this post


Link to post
Share on other sites

Hombre, bonitas palabras, llevo sufriendo con prestashop desde la 1.5 ¿y que me encuentro? que alguien partner de un modulo me aconseja que no siga peleando y que no me lo piense, que me vaya a Shopify ( que ya he probado), es decir, que en lugar de encontrar la ayuda que necesito me intentan clavar un módulo de 29 pavos.

Buena ayuda tambien.

Estupendo!!

Share this post


Link to post
Share on other sites

Para encontrar  ayuda de calidad es muy importante la forma de pedirla. Pero este no es el sitio ni el lugar para entrar en disputas sin sentido.

Si quieres arreglar tu problema con el buscador, primero actualiza prestashop y los modulos correspondientes.

Si sigue sin funcionar, léete algún manual:

https://victor-rodenas.com/configuracion-del-buscador-en-prestashop-1-7/

Si no lo consigues, seguramente no te quedará mas remedio que contacta con un profesional para que estudie tu caso individual, ya que esto solo te pasa a ti y no es un bug extendido.

 

Un saludo y suerte.

Share this post


Link to post
Share on other sites

Bien, no se de que forma hay que pedir ayuda de calidad, para que no intenten venderte un módulo, a lo mejor si lo hubieses intentado cuando no hubiese estado, tan enfadado, quizás hasta lo hubiese comprado, pero no me parece muy ético intentar ayudar a una persona, vendiéndole tu producto, por suerte hay otras soluciones y sin ser experto en el tema (aunque uno lleva algunos añitos en este asunto) y por supuesto, ni que decir tiene, sin desmerecer el enlace que indicas, ya que esa persona creo que es un tío excelente (sin conocerlo personalmente) y con mucho conocimiento sobre prestashop, y, lo más importante ayuda a la gente "desinteresadamente".

Pero bueno sin entrar en disputas sin sentido como bien has dicho, y, después de toda la semana peleando con esto, desde que el lunes un cliente me advirtiera sobre el problema. Este se encontraba en dos tablas: ps_product_atribute_shop y ps_image_shop que les faltaba el índice id_product. ¿Cómo puede ser esto? Pues lo desconozco, pero así era.

Tras poner la tienda en debug, ver el error, e investigarlo y ver algún post sobre el mismo problema pero en inglés (tan sólo con la primera tabla) cree su índice id_product, volví a probar y se reprodujo el error con la segunda, cree igualmente el índice id_product, y asunto arreglado. La búsqueda al pulsar buscar o mostrar todos, muestra todos los productos encontrados por el término introducido.

¿Cómo es posible que falten índices? pues la verdad no lo sé. Si será un bug, y, si estará extendido o no. Lo cierto y verdad que al crearlos (y que no lo tenía que haber hecho yo manualmente entrando en la phpmyadmin), todo funciona correctamente. Si el software tuviese una revisión de integridad de sus tablas, esto no me habría pasado, ni a mí, ni a Dios sabe cuantos.

Por cierto antes de todo esto de la 1.7.6.8 actualice a la 1.7.6.9, con un miedo que no se si esta noche podré dormir. Y el problema continuaba ahí después de actualizar.

Un saludo, y la próxima vez será 😉 Creo que esta solución al problema, no es sólo más barata, sino la correcta.

Procuraré no volver a molestarte con mis problemas de prestashop.

Share this post


Link to post
Share on other sites

Nadie te ha intentado vender nada. Después de muchos años programando bajo prestashop, y después de dar soporte a muchas tiendas, se que ese software es bueno para plataformas con grandes referencias y que ayudan a la conversión.

No es con ánimo de venderte nada, sino de aconsejar algo que se que funciona sabiendo que vendes componentes de ordenador y que el buscador es un pilar fundamental en tu tienda y que además tienes problemas con el módulo nativo.

Pero parece que llevas el mal genio por bandera, y cuando escribes de forma agresiva no esperes que te contesten de otra forma.

Gracias por compartir la solución  y si eres tan amable, marca el post como solucionado.

Share this post


Link to post
Share on other sites

Si el software sabes que es bueno, pero también tiene fallos, y hay que buscar soluciones. Creo que la solución como te he dicho no es poner un módulo, menos con coste y mucho menos que lo ofrezca el propio partner. Lo suyo, es buscar el origen del problema, que seguro lo hay (las cosas no pasan por que si) y ponerle solución para cuando otro se lo encuentre, que lo pueda solucionar fácilmente y de esta forma seguir haciendo grande el software, del cual eres entusiasta.

Lo primero es lucro personal, lo segundo ayudar a la gente engrandeciendo un software. Y no es el primer post que veo que ofreces el módulo y ya te he dicho que no lo considero ni ayuda, ni ético.

Lo siento pero el post no es originalmente mío. no creo que pueda modificar su título.

Adjunto la imagen del error que se generaba ps_product_attribute_shop, en ps_image_shop era el mismo.

Image4.jpg

Share this post


Link to post
Share on other sites

Esa tabla se crea así:

CREATE TABLE `PREFIX_product_attribute_shop` (
  `id_product` int(10) unsigned NOT NULL,
  `id_product_attribute` int(10) unsigned NOT NULL,
  `id_shop` int(10) unsigned NOT NULL,
  `wholesale_price` decimal(20, 6) NOT NULL DEFAULT '0.000000',
  `price` decimal(20, 6) NOT NULL DEFAULT '0.000000',
  `ecotax` decimal(17, 6) NOT NULL DEFAULT '0.00',
  `weight` DECIMAL(20, 6) NOT NULL DEFAULT '0',
  `unit_price_impact` DECIMAL(20, 6) NOT NULL DEFAULT '0.00',
  `default_on` tinyint(1) unsigned NULL DEFAULT NULL,
  `minimal_quantity` int(10) unsigned NOT NULL DEFAULT '1',
  `low_stock_threshold` int(10) NULL DEFAULT NULL,
  `low_stock_alert` TINYINT(1) NOT NULL DEFAULT 0,
  `available_date` date DEFAULT NULL,
  PRIMARY KEY (
    `id_product_attribute`, `id_shop`
  ),
  UNIQUE KEY `id_product` (
    `id_product`, `id_shop`, `default_on`
  )
)

No me ha quedado claro si el error te daba con esta definición o es que por alguna razón te faltaba esa key en tu instalación.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More