Jump to content

No se carga el estado de la orden luego de pagar con Webpay


Daniel Añez
 Share

Recommended Posts

Tengo instalación de Prestashop 1.7.6.8 y estoy presentando problemas con el modulo Transbank, cuando realizo las pruebas de integración funciona correctamente el modulo y me devuelve a la pagina web de resumen del pedido finalizando correctamente la compra de pruebas.

Pero cuando cambio las credenciales productivas y realizo una compra de pruebas por cualquier valor, luego de ingresar mis datos de tarjetas reales y procesar el pago, al momento de volver a la pagina de resumen me entrega un error 500 la pagina web y cuando lo coloco en modo depuración para revisar el error me indica lo siguiente:

[PrestaShopException]
Can't load Order status
at line 243 in file classes/PaymentModule.php

Adjunto archivo ampliado de este error.

 

Luego de este error, y revisar los carros en mi pagina este pedido queda como carrito abandonado.
Cuando devuelvo el modulo a pruebas de integración me funciona el pago de pruebas.

Realizo los test de comunicación del ambiente productivo y todos los test pasan sin problemas.

Cabe destacar que el modulo estaba operando sin problemas y de un momento a otro comencé a tener estos problemas en la web.

Versiones de sistemas:
Prestashop 1.7.6.8
Webpay: 3.2.0
PHP: 7.1.33

Espero puedan ayudarme con este problema.

Saludos a toda la comunidad.

validate.pdf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More