Jump to content
Littlepants

Product combinations

Recommended Posts

Version 1.7.6.8. I;m very new to this and f-green having had 1.6. before and am totally bemused by this.

New products - combinations. I'm trying to set up a new product with combinations. I've set up the basic stuff, go to combinations. I set and generate the combinations. When I try to save it I get a message every time

The CSRF token is invalid. Please try to resubmit the form.

Basic settings

Combinations

Shipping

Pricing

SEO

Options

 

I also get this 

The value of the PHP.ini setting "max_input_vars" must be increased to 3000 in order to be able to submit the product form.

The value of the PHP.ini setting "max_input_vars" must be increased to 3000 in order to be able to submit the product form.

The value of the PHP.ini setting "max_input_vars" must be increased to 3000 in order to be able to submit the product form.

What the ***** does that mean? 

 

Can anyone tell me what I'm doing wrong please?  I;ve been trying for 24 hours  almost non stop and I'm getting soooooo frustrated

Share this post


Link to post
Share on other sites
On 10/16/2020 at 3:31 PM, Littlepants said:

The value of the PHP.ini setting "max_input_vars" must be increased to 3000 in order to be able to submit the product form.

There are about a million websites that discuss this, so Google is your friend. It is not a Prestashop issue but a general php issue. Ask your hosting provider when you can't find the file.

Share this post


Link to post
Share on other sites

Thanks for this. I've contacted my hosting provider so hopefully this will be sorted,. I wonder if you can help me with another issue on combinations though. In my previous version of prestashop (1.6.1.20) when I made new combinations the combinations generator allowed me to add specific weight and price increases for each attribute value, and then came up with a list, showing  each new combination and the increase in weight and price for each one. This made it very easy to add several attribute and values, with the correct adjustments, but also to spot errors, and edit specific combinations. In the new shop (1.7.8.6) allI get is the combinations generated, but not configured, and I have to edit each one separately. As sometimes the total number of  configurations for a single product can be large this is not only time consuming but I have to work out  the end price for each item individually as well and it takes HOURS! Have I missed something? 

I'm attaching screen shots of what happens in both versions - the new shop is pretty useless to be honest!

 

New shop combination generator.jpg

old shop combination generatorjpg.jpg

Share this post


Link to post
Share on other sites
10 hours ago, Littlepants said:

Thanks for this. I've contacted my hosting provider so hopefully this will be sorted,. I wonder if you can help me with another issue on combinations though. In my previous version of prestashop (1.6.1.20) when I made new combinations the combinations generator allowed me to add specific weight and price increases for each attribute value, and then came up with a list, showing  each new combination and the increase in weight and price for each one. This made it very easy to add several attribute and values, with the correct adjustments, but also to spot errors, and edit specific combinations. In the new shop (1.7.8.6) allI get is the combinations generated, but not configured, and I have to edit each one separately. As sometimes the total number of  configurations for a single product can be large this is not only time consuming but I have to work out  the end price for each item individually as well and it takes HOURS! Have I missed something? 

I'm attaching screen shots of what happens in both versions - the new shop is pretty useless to be honest!

I have added a function that does do exactly this in Prestools in Combination Edit.

Share this post


Link to post
Share on other sites

Sorry I;m probably being dippy here. I've created an account at Prestools but I can;t find combination edit

Share this post


Link to post
Share on other sites

When I log in there aren't those menus at the top.  I get Home, Prestools, Copy Shopdata, Services. None of these takes me to a page with those menus

Share this post


Link to post
Share on other sites

I don't get a menu bar at the top like that.  I get 'Home', 'Prestools' , 'Copy Shopdata' and 'Services' 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More