Jump to content

Petit problème de redirection apres la connexion.


Recommended Posts

Bonjour, 

Ca fait un moment que nous rencontrons un petit problème avec l'un de nos site. Quand une personne se connecte, le site de redirige vers une page Error 404 au lieu de la page mon compte. Il y aurait-il une solution a se sujet svp? Voici l'url du site : https://www.telroi.re et un compte demo si jamais vous voulez voir le probleme : demo@gmail.com/demo1125

Merci,

Emmanuel

telroi-erreur.jpg

Share this post


Link to post
Share on other sites

L'url de ta capture écran suffit à voir le problème. controller=0

Soit un problème de thème, soit un problème de réglage SEO&URL, soit une règle .htaccess boiteuse

  • Like 2

Share this post


Link to post
Share on other sites

Request URL: https://www.telroi.re/connexion

Request Method: POST

Status Code: 302

Remote Address: [2606:4700:3036::681f:587c]:443

Referrer Policy: strict-origin-when-cross-origin

Response Headers

cf-cache-status: DYNAMIC

cf-ray: 5dad1bc51832cdaf-CDG

cf-request-id: 05800faf310000cdafedb6d200000001

content-type: text/html; charset=utf-8

date: Wed, 30 Sep 2020 10:02:28 GMT

expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"

host-header: 5d77dd967d63c3104bced1db0cace49c

location: http://www.telroi.re/index.php?controller=0

nel: {"report_to":"cf-nel","max_age":604800}

report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report?lkg-colo=19&lkg-time=1601460148"}],"group":"cf-nel","max_age":604800}

server: cloudflare

set-cookie: PrestaShop-215572522b17fcd3f550fc9ec3cb01de=uJmQETNrWiRHIBvUGppSK9ymdsoNLtO09c3XODyjkLZk8sf6L1IifnSWIDwplkQd%2BZJTxvd5xnxgvugONVbPcsA5dKS8TwTZ6gv4u2nV2kZv4Mf%2BApkdIS0258uRvetz4A1xxdRBnR5BJc1WcsHAOZYrWBcGVoKXJCHDNHJ2WsKjOAz9SlpggTvCs0xewsVKtj4YIYm7MVn%2BnIvtbfkuY7tJZL73fRn7V3uQNJbylw%2BUyFnyhCgRPJNHcIUmVg2ZFqsEafBIpclAN7AKgfdN1KrmjZ3fRJ83B9icmANs8Xip1Kv%2Bt2Ddo0xDSXYn9rFC%2FNOV79TCwNXqWkEIm1BJ2SO1Ulykgbg32Wy53czKkpvE30PtpBf2NY5TcJC2S0uFyuUKmr%2Bhy4M69Zl8NY7rXQ%3D%3D000297; expires=Tue, 20-Oct-2020 10:02:28 GMT; Max-Age=1728000; path=/; domain=www.telroi.re; secure; HttpOnly

set-cookie: PrestaShop-215572522b17fcd3f550fc9ec3cb01de=uJmQETNrWiRHIBvUGppSK9ymdsoNLtO09c3XODyjkLZk8sf6L1IifnSWIDwplkQd%2BZJTxvd5xnxgvugONVbPcgXNuyTvrlXlIZKIW5EJb1m%2FhaofFE%2FJiE4KbOU6LcxHUyWFq6lWqbICwpFv%2Fa2zoRiMhpQkoGi95phEmJWIzps%2BcTPL8TwttCMYu%2FowlPzYE9UNHxnGNMjMsbfZ0WlwtXoA0o3UO7XKL5DJpu9F4skrOvfUudF0Cz9P%2FCtIuPRqQmKne5ZAH9n%2FO6ZdhPXV5tY%2Blc4%2BHMNnEfpl9yx7gBfPeO19djsA8tRMqhfv0MQKshNyEImkhznJI4e82xSISvvdTJw2ozkxBcZ2Xu4z2e8kphYz%2Bbz6KaesP7mDNUK8lw0zLYQzM5uftGNeRCMHDA%3D%3D000297; expires=Tue, 20-Oct-2020 10:02:28 GMT; Max-Age=1728000; path=/; domain=www.telroi.re; secure; HttpOnly

status: 302

x-powered-by: PHP/7.1.33

 

Déjà, 2 cookies pour un utilisateur ce n'est pas normal

Ensuite, effectivement, votre site redirige en 302 (Mauvais réglage, devrait être 301) vers cette url moisie en http puis redirige en https et le paramètre back=my-account a disparu donc Prestashop est incapable de trouver le bon controleur

  • Like 1

Share this post


Link to post
Share on other sites

Merci beaucoup pour votre aide, effectivement il me semble que le problème provient du thème car quand je mets celui par defaut, tout se passe correctement. Je vais essaye de voir si j'ai une solution a ce problème par rapport a vos réponses.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More