Jump to content

Recommended Posts

Mon prestashop est actuellement en 1.6.1.23 et lorsqu'un client passe une commande, après avoir payé il se retrouve sur une page blanche.

J'ai activé l'affichage des erreurs et cela me retourne ceci :

Warning: include_once(/tools/swift/Swift.php): failed to open stream: No such file or directory in override/classes/Mail.php on line 18

Warning: include_once(): Failed opening '/tools/swift/Swift.php' for inclusion (include_path='/tools/htmlpurifier/standalone:.:/usr/share/php') 
in /override/classes/Mail.php on line 18

Warning: include_once(/tools/swift/Swift/Connection/SMTP.php): failed to open stream: No such file or directory 
in /override/classes/Mail.php on line 19

Warning: include_once(): Failed opening '/tools/swift/Swift/Connection/SMTP.php' for 
inclusion (include_path='/tools/htmlpurifier/standalone:.:/usr/share/php') in /override/classes/Mail.php on line 19

Warning: include_once(/tools/swift/Swift/Connection/NativeMail.php): 
failed to open stream: No such file or directory in /override/classes/Mail.php on line 20

Warning: include_once(): Failed opening '/tools/swift/Swift/Connection/NativeMail.php' 
for inclusion (include_path='/tools/htmlpurifier/standalone:.:/usr/share/php') in /override/classes/Mail.php on line 20

Warning: include_once(/tools/swift/Swift/Plugin/Decorator.php): failed to open stream: 
No such file or directory in /override/classes/Mail.php on line 21

Warning: include_once(): Failed opening '/tools/swift/Swift/Plugin/Decorator.php' 
for inclusion (include_path='/tools/htmlpurifier/standalone:.:/usr/share/php') in /override/classes/Mail.php on line 21

Fatal error: Uncaught Table 'ddc.ps_ps_socolissimo_delivery_info' doesn't exist<br /><br /><pre>
DELETE FROM `ps_ps_socolissimo_delivery_info` WHERE `id_cart` = 4415156</pre> thrown in /classes/db/Db.php on line 791

Un peu d'aide serait le bienvenue ^^'

Share this post


Link to post
Share on other sites

Ben vous avez mis à jour votre shop en 1.6.1.23 mais vous avez un override de la classe Mail qui n'est plus à jour du coup^^

Trouvez le module responsable et mettez-le à jour

Share this post


Link to post
Share on other sites
12 hours ago, Eolia said:

Ben vous avez mis à jour votre shop en 1.6.1.23 mais vous avez un override de la classe Mail qui n'est plus à jour du coup^^

Trouvez le module responsable et mettez-le à jour

Justement le problème est que je n'ai rien mis a jour du tout :(

La seul chose qui a été faite est avec le module ContactForm de Aretmic qui a été désinstallé puis réinstallé alors je suppose que c'est à cause de celui-ci 😕

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More