Jump to content
House Music

Aperçu rapide ne fonctionne plus sur Prestashop 1.7.6.5

Recommended Posts

Bonjour,

J'ai un souci sur mon site internet Prestashop 1.7.6.5, l'aperçu rapide ne fonctionne plus avec mon thème, alors qu'avant il fonctionnait normalement.

J'ai contacté le développeur, il m'a dit que ça venait de mon serveur, car il a testé sur d'autres sites avec son thème et sa fonctionne. 

Voici l'erreur que ça affiche quand j'inspecte https://prnt.sc/sj28f3

Cela me le fait sur mes deux sites internet en fait, sur un j'ai réglé le problème en supprimant le quickview, mais l'autre c'est très dérangeant.

Merci pour vos réponses !

 

PS : j'ai demandé sur le groupe Prestashop facebook France, ils m'ont dit de débugguer avec mode debug, mais après je ne sais pas comment faire, je ne suis pas développeur !

Share this post


Link to post
Share on other sites

- Allo ?

- Bonjour monsieur, que puis-je faire pour vous ?

- Je cherche une aide pour mon problème

- Désolé monsieur, vous êtes sur le forum Prestashop France...

 

Alors toujours personne 😂 ?

Share this post


Link to post
Share on other sites

Hello, à tout hasard, est-ce que tu as testé avec le thème par défaut de Prestashop ?

Share this post


Link to post
Share on other sites

Bonjour, merci pour votre réponse ! 🙏

Je viens de tester avec le thème classique de Prestashop, donc le thème par défaut. L'aperçu rapide fonctionne, donc ça vient du thème que j'utilisais avant ?

Le développeur m'a dit qu'il y avait un problème avec mon serveur.

Share this post


Link to post
Share on other sites

Du coup à priori oui cela vient bien de ton thème.

Tu peux toujours essayer de réactiver le thème en question et de bien vider tous les caches de ta boutique (section Paramètres avancés >> Performances du back-office) afin de voir si cela fonctionne de nouveau mais si ce n'est pas le cas et que le problème n'est pas présent avec le thème par défaut de Prestashop, alors cela signifie soit que le souci vient du thème que tu utilises, soit qu'il vient d'un module tiers que tu aurais ajouté et qui provoque un conflit avec le thème concerné.

Share this post


Link to post
Share on other sites

J'ai réinstaller mon thème. J'ai désactivé tous les modules tiers que j'ai pu installer depuis mai 2020 (date à laquelle j'ai installé le thème), mais quand ça ne fonctionne toujours pas... J'ai bien vidé tous les caches pourtant.

Share this post


Link to post
Share on other sites

Eh bien si l'erreur n'est pas présente sur le thème Classic de Prestashop, alors le souci vient bien de ton thème. Il faut insister auprès du développeur du thème en lui précisant bien que le souci est absent sur le thème par défaut et qu'à priori aucun module tiers ne crée de conflit.

Share this post


Link to post
Share on other sites

Bonjour,

Moi, j'ai le même problème avec la version 1.7.6.7.

Sans avoir modifié le thème, subitement plus d'aperçu rapide, serait-ce les mystères de Prestashop ?

Le seul module que j'ai installé est un module de Click & Collect que j'ai rapidement retiré car il ne sert à rien dans mon cas.

Cordialement.

l'adresse du site : https://www.torrefactiondunoise.fr

Share this post


Link to post
Share on other sites
On 11/4/2020 at 6:08 PM, Iciailleurs said:

Bonjour,

Moi, j'ai le même problème avec la version 1.7.6.7.

Sans avoir modifié le thème, subitement plus d'aperçu rapide, serait-ce les mystères de Prestashop ?

Le seul module que j'ai installé est un module de Click & Collect que j'ai rapidement retiré car il ne sert à rien dans mon cas.

Cordialement.

l'adresse du site : https://www.torrefactiondunoise.fr

Bonjour,

J'ai le mème soucis d'aperçu rapide non fonctionnel sous la 1.7.6.8. Comment as tu résolu le problème, vu que l’aperçu rapide de ton site fonctionne maintenant ?

Share this post


Link to post
Share on other sites

Simple, j'ai réinstallé le fichier de base de Prestashop. Ce qui fait que je retrouve les erreurs dans Google.

Share this post


Link to post
Share on other sites

Merci Iciailleurs, mais cette solution n,'était pas envisageable pour moi :P

j'ai essayé de voir d'où venait le problème. en activant le debug mode et en collant direct mes modifs dans les tpl du thème parent, les erreurs apparaissent (les tpl enfant n'étant juste pas du tout interprétés si ils contiennent des erreurs, difficile de localiser le problème donc)

Pour les fouineurs de solutions qui ont ajoutés les balises SEO de Webbax dans product-prices.tpl, il y a une erreur de variable Smarty dans son code (le code fourni par Germain n'étant pas fait pour coller à la 1.7 avec le preview d'article (lui, l'a développé sans s'en soucier, et ça engendre un bug).

 

Donc, dans son code, il faut remplacer :

content=getProductLink($smarty.get.id_product)|escape:’htmlall’:’UTF-8′}

par :

content={$product.url}

Pour mon cas, ce bout de code bancal, empêchait l'application de tous mes templates modifiés (aucune de mes modifs n'étaient plus appliquées, même en dehors de product-prices.tpl) !

La modif permet la bonne interprétation des tpl enfants et des balise SEO ajoutées ;)

Edited by Bfshoot (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Merci beaucoup,

J'ai fait la modif, cela semble fonctionner. Je vais vérifier dans quelques jours sur la Console Google si les erreurs ont diminué.

Cordialement.

Share this post


Link to post
Share on other sites

On recommence avec "Il faut indiquer "offers", "review", ou "aggregateRating" les balises SEO de Webbax ne fonctionnent pas.

Je recherche un e autre solution car apparemment, je ne suis pas le seul à avoir ces problème avec Google. Il suffit de taper la phrase sur un moteur de recherche pour le constater.

Bonne soirée.

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, Iciailleurs said:

On recommence avec "Il faut indiquer "offers", "review", ou "aggregateRating" les balises SEO de Webbax ne fonctionnent pas.

Je recherche un e autre solution car apparemment, je ne suis pas le seul à avoir ces problème avec Google. Il suffit de taper la phrase sur un moteur de recherche pour le constater.

Bonne soirée.

Tu utilises quel thème ? En "child" ou modification directes des tpl dans le thème parent ?

Share this post


Link to post
Share on other sites
1 minute ago, Iciailleurs said:

Modification directe des TPL

Ouille 😕

Cette méthode est à éviter. En cas de mise à jour du thème, toutes les modifications de templates (templates de mails client compris) sont écrasées et il faut tout refaire de zéro 😕

Quel thème utilises-tu ? Le Classic de base ou un thème acheté ?

Dans le premier cas, je peux te fournir tous les tpl modifiés pour le SEO (version 1.7.6.9 de presta). Mais si tu fais la maj vers la 1.7.7.0, avec ta méthode de modification, tu perdras fatalement tes modifs si les tpl du thèmes sont présents dans la mise à jour (je ne l'ai pas faite encore, c'est pour cette nuit).
Si tu utilises un thème payant, il faut voir avec le vendeur, qu'il fasse les modifs pour coller aux attentes de Google en matière de balisage.

Et, au lieu d'attendre que Google repasse par tes pages pour les valider, tu peux faire tes tests en direct dès les modifications. Ça permet de vérifier la validité sans attendre.

Dans tous les cas, je te conseille de générer un thème enfant de ton thème actuel. Et d'utiliser ce thème enfant. Ça simplifie pas mal le suivi des modifs en cas de mise à jour et laisse le temps de les faire. Par contre, il faut vérifier que le thème parent n'a pas subi de modifications sur les tpl que tu auras modifié dans l'enfant (dans le thème enfant, on ne met que les fichiers sur lesquels on fait des modifications, ça simplifie grandement la gestion ;) )

Share this post


Link to post
Share on other sites
1 minute ago, Bfshoot said:

Dans tous les cas, je te conseille de générer un thème enfant de ton thème actuel.

En repartant des fichiers originaux, pas de ceux modifié bien sûr ;)

Share this post


Link to post
Share on other sites

Pour créer un thème enfant, c'est très simple (et c'est la première chose à faire quand on installe un thème !).

Tout est expliqué avec détails ici, va directement à "Créer un thème enfant" dans la page (le reste avant explique comment fonctionne le moteur de Prestashop pour l'interprétation des thèmes)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More