Jump to content
Caroline Solo

Problème d'affichage sous menu responsive

Recommended Posts

Posted (edited)

Bonjour,

J'ai un problème d'affichage du sous menu quand on se trouve sur une tablette, le menu ne s'affiche pas en mode version mobile ce qui est normal, mais du coup le sous menu apparaît au clic et pas au hover, mais n'apparaît pas correctement. J'ai remarqué que le sous menu se cale automatiquement lors d'un hover (top automatique) mais là du coup il n'y a pas de hover. Je ne sais pas trop comment corrigé ça.

Merci d'avance

bug-tablette-sous-menu.PNG

sous-menu-ok.jpg

Edited by Caroline Solo (see edit history)

Share this post


Link to post
Share on other sites

Pouvez-vous préciser le problème. Est-ce par rapport à sa position en hauteur ?

Share this post


Link to post
Share on other sites
4 minutes ago, alama said:

Pouvez-vous préciser le problème. Est-ce par rapport à sa position en hauteur ?

Oui c'est sa position en hauteur. Le sous menu monte sur le header, car le top ne se crée pas vu qu'il n'y a pas de hover

Merci !

Share this post


Link to post
Share on other sites

C'est donc un problème du thème. Soit c'est un thème acheté et vous pouvez le signaler au support, soit c'est un thème maison, alors voir dans le thème par défaut si le fonctionnement est correct pour vous en inspirer. Sans lien on ne peut pas vous en dire plus.

 

Alternativement vous pouvez déclencher le menu hamburger mobile plus tôt dans les paliers du thème.

 

Cdt,

 

AM 

Share this post


Link to post
Share on other sites
34 minutes ago, alama said:

C'est donc un problème du thème. Soit c'est un thème acheté et vous pouvez le signaler au support, soit c'est un thème maison, alors voir dans le thème par défaut si le fonctionnement est correct pour vous en inspirer. Sans lien on ne peut pas vous en dire plus.

 

Alternativement vous pouvez déclencher le menu hamburger mobile plus tôt dans les paliers du thème.

 

Cdt,

 

AM 

J'ai pris le thème classic de Prestashop et j'ai créé un thème enfant que j'ai personnalisé. Après je mets le menu dans le hook displayNavFullWidth

Share this post


Link to post
Share on other sites
41 minutes ago, alama said:

C'est donc un problème du thème. Soit c'est un thème acheté et vous pouvez le signaler au support, soit c'est un thème maison, alors voir dans le thème par défaut si le fonctionnement est correct pour vous en inspirer. Sans lien on ne peut pas vous en dire plus.

 

Alternativement vous pouvez déclencher le menu hamburger mobile plus tôt dans les paliers du thème.

 

Cdt,

 

AM 

C'est bien mon thème en effet! ... j'ai plus qu'à trouver comment corriger. Merci encore !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More