Jump to content

Visitors Online Not Working


ttimmy2005
 Share

Recommended Posts

Hello all.

I have a problem that I am hoping somebody could help me with. Basicly, I am seeing a number of Visitors online, but when I try to view the stats for this, it sows nothing. I have included some screenshots that may help.

I am currently running prestashop v1.7.6.7

I have tried resetting the various modules (Data mining for statistics, visitors online etc...)

I have made sure that "save page views for each customer" is turned on

I have tried moving the Data Mining For Statistics to the displayFooter hook, but was unable to do this (see screenshot).

I am really don't know how to get this working. Could somebody help?

 

Attached are some screenshots.

online_views_1.jpg shows 5 visitors online

online_views_2.jpg shows no info despite there being 5 visitors online

online_views_3.jpg shows that there is no "displayFooter" hook available for me to transplant Data Mining For Statistics onto

 

 

 

 

online_views_1.jpg

online_views_2.jpg

online_views_3.jpg

Share this post


Link to post
Share on other sites

Ok, so I have worked out how to get the online visitors section working. Might be a little overkill, but it worked.

 

I am running v1.7.6.7, but only after I used the 1 click upgrade. This got me thinking that perhaps some of the files didnt get upgraded with ones from the newer version. So...

 

I downloaded a fresh copy of 1.7.6.7 and compared the file modules/statslive/statslive.php with the one that I was currently using on the website. It paid off because I noticed that they were slightly different.

In the end I just replaced the entire statslive dir with the newer one, and all is working like a charm!! I hope that this might help others who might be having the same issue.

  • Like 1

Share this post


Link to post
Share on other sites

  • 2 years later...

To anyone watching here is how i fixed it.

1) Go to module catalog search for visitors - Then install visitors online

2) From an older prestashop folders - go to root> modules> statsorigin folder. Create a zip file of it and then upload it via modules.

Works like a charm now.

Dont know why prestashop removed it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More