Jump to content

[Résolu] Install réussie, impossible d’accéder à l’admin


Recommended Posts

Bonjour à tous,

 

Je viens d'installer Prestashop en local (Mac Leopard + Mamp), qui s'est bien déroulée.

La boutique fonctionne, en revanche impossible d'accéder à l'admin : après saisie de l'email et du mot de passe (qui sont les bons) la même page se recharge en vidant les champs d'identification.

 

Cete boutique à l'air sympa, ça serait dommage de coincer si près du but. :-

 

D'avance merci pour vos éclaircissements.

Share this post


Link to post
Share on other sites

Pour info je viens de tester l'installation en ligne, ce qui donne le même résultat : impossible de se logger à l'admin.

Le même problème se répète dans la boutique lorsqu'un utilisateur tente de se connecter..

 

Est-ce un problème de cookies ?

 

Quelqu'un aurait-il un début de solution à me proposer ? Je cale....

Share this post


Link to post
Share on other sites

Je suis tout nouveau ...

TEST réalisé sous léopard

MAMP1.7

 

L'install se passe correctement.

 

Persiste uniquement un problème d'accès à l'admin

 

Après validation du login et password

on revient à ce même écran avec des champs vierges.

 

ceci avec Safari 3.0.4 ou Firefox 2.0.0.8

 

Que faire

Share this post


Link to post
Share on other sites

Bonjour,

 

- Est-ce que vous pouvez vérifier dans votre base de données, si la table "employee" comporte bien un enregistrement ?

 

- Est-ce que vous avez activé l'affichage des erreurs PHP ?

 

- Pouvez-vous me confirmer que vous accédez au site par 'localhost' ? ou bien par une IP ?

 

Cordialement,

Bruno Lévêque

Share this post


Link to post
Share on other sites

Salut,

 

Après quelques test, je reviens à la charge (ça ne marche toujours pas ???).

 

Pour répondre à tes questions Bruno :

- la table employee comporte un enregistrement (et le bon)

- j'ai activé l'affichage des erreurs PHP dans php.ini, toujours rien à signaler

- en local j'acède au site par "http://localhost:8888" (MAMP), je ne pense pas que ça vienne de là vu que le problème se pose également en ligne.

 

Après quelques tests, j'ai constaté qu'il pouvait éventuellement y avoir un problème dans le fichier "login.php", lors de la redirection :

 

/* Redirect to admin panel */
		if (isset($_GET['redirect']))
			$url = strval ($_GET['redirect']);
		else
			$url = dirname ($_SERVER['PHP_SELF']).'/index.php';
		Tools::redirect($url, '');

 

itarget, tu rencontre le visiblement le même problème sur Mac mais je ne pense pas que ça soit spécifique à la plateforme, j'ai effectué les mêmes tests sur Windows XP (IE6, IE7, Firefox).

J'ai pas essayé Opera ou Camino mais je me doute du résultat... :-

 

Bruno, Thibaud, qu'en pensez-vous ?

Share this post


Link to post
Share on other sites

Bonjour

 

le probleme vient du domaine specifique a MAMP (localhost:8888)

 

un petit quick fix : remplace la ligne 58 de la classe Cookie par :

 

$this->_domain = (substr($_SERVER['HTTP_HOST'],0,9) == 'localhost') ? false : (is_numeric($_SERVER['HTTP_HOST']{0}) ? ereg_replace('^([[:digit:]]{1,3}).([[:digit:]]{1,3}).([[:digit:]]{1,3}).([[:digit:]]{1,3})(.*)$', '1.2.3.4', $_SERVER['HTTP_HOST']) : ereg_replace('^[^.]*.([^.]*).(.*)$', '1.2', $_SERVER['HTTP_HOST']));

 

Share this post


Link to post
Share on other sites

Bravo Sylvain,  ça marche en local, j'avais oublié de décommenter une ligne.

Il faut donc effectivement, pour que Prestashop tourne en local sur Mac avec Mamp rajouter le petit quick fix dans le fichier 'classes/Cokkie.php'

 

En revanche ça ne marche toujours pas en ligne...késako ?

(Pour rappel du pb : installation nickel, mais impossible de se logger à l'admin avec les bons identifiants)

Share this post


Link to post
Share on other sites

itarget,

- ouvrir le fichier "Cookie.php" situé dans le dossier "classes" (racine du site)

- repérer la ligne suivante (ligne 58) :

$this->update();

- entre cette ligne et l'accolade de fermeture (}) coller le code suivant :

$this->_domain = (substr($_SERVER['HTTP_HOST'],0,9) == 'localhost') ? false : (is_numeric($_SERVER['HTTP_HOST']{0}) ? ereg_replace('^([[:digit:]]{1,3}).([[:digit:]]{1,3}).([[:digit:]]{1,3}).([[:digit:]]{1,3})(.*)$', '1.2.3.4', $_SERVER['HTTP_HOST']) : ereg_replace('^[^.]*.([^.]*).(.*)$', '1.2', $_SERVER['HTTP_HOST']));

 

Dis-moi si ça marche comme ça.

Share this post


Link to post
Share on other sites

hello,

 

I have the same problem, but still not working with the modification. Attached is the modified cookie.php.

The site is tested on a remote free hosting (not local): MySQL 4.1.11-Debian_4sarge5-log running on mysql1.100ws.com.

 

used IE 7.0 and Firefox 2.0.0.9 on Windows XP SP2.

 

thank you fpr support.

Cookie.php

Share this post


Link to post
Share on other sites

Please check your settings.inc.php file and particulary the __PS_BASE_URI__ var.

Check if this is the good one !

 

I've got the problem this morning and have searched for hours... before found that my settings was bad.

 

Give me back about that !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More