Jump to content

[SOLVED] PS 1.7.6.7 not working when Dev Mode is OFF


Recommended Posts

 

Hello

Here is what I've done-

I have moved my PS to another server, keeping the domain.

I moved all the files.

I downloaded the database from the old server and imported to  the new one, keeping the same database name

I edited the file for user, password and host for the database.

I changed  the DNS for the domain to the new server

I changed the php version on my server to 7.2

At first there was only a blank white page on both front office and back office.  I turned Dev Mode on by editing the file.  Then i got the error on the screen that told me one of the modules that came with the template was not working. I disabled that module and both front and back office came up as it should.  Still with Dev mode on.  But when I turn the Dev Mode OFF, I just get blank white screen again. Turn Dev Mode ON and the pages are back again.

What could this be ?

 

Regards

Petter

 

Edited by Petter Enge
SOLVED (see edit history)

Share this post


Link to post
Share on other sites

Hi i have exactly the same issue

Here is what i get if debug mode is turned on  i have hidden some info with xxxx

atal error: Uncaught PrestaShop\PrestaShop\Core\Localization\Exception\LocalizationException: No decimal pattern found for numbering system: in /home/xxxxx/public_html/src/Core/Localization/CLDR/Locale.php:219 Stack trace: #0 /home/xxxxxx/public_html/src/Core/Localization/Specification/Factory.php(60): PrestaShop\PrestaShop\Core\Localization\CLDR\Locale->getDecimalPattern() #1 /home/xxxxx/public_html/src/Core/Localization/Locale/Repository.php(182): PrestaShop\PrestaShop\Core\Localization\Specification\Factory->buildNumberSpecification(Object(PrestaShop\PrestaShop\Core\Localization\CLDR\Locale), 3, true) #2 /home/xxxxx/public_html/src/Core/Localization/Locale/Repository.php(149): PrestaShop\PrestaShop\Core\Localization\Locale\Repository->getNumberSpecification('en-US') #3 /home/xxxxxx/public_html/classes/controller/Controller.php(189): PrestaShop\PrestaShop\Core\Localization\Locale\Repository->getLocale('en-US') #4 /home/xxxxx/public_html/classes/controller/FrontController.php(271): ControllerCore->init( in /home/xxxx/public_html/src/Core/Localization/CLDR/Locale.php on line 219

 

 

Share this post


Link to post
Share on other sites

I found the solution in another posting.

It has to do with cache located under /var/cache

Delete /dev and /prod folders.

That work for me me.

See the post:

https://www.prestashop.com/forums/topic/636734-disabling-debug-mode-gives-error/

 

Share this post


Link to post
Share on other sites
  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More