Jump to content

Error en IVA carrito, facturas, frontoffice...


Recommended Posts

Buenos días.

Estabamos a punto de lanzar la web y hemos localizado que algo está ocurriendo a nivel programación con el tema del IVA. Ya que por mucho que todas las opciones de IVA e impuestos y visualización de carrito están activados no se muestra ni procesa correctamente.

Nos urge mucho y he leído un montón de posts acerca de que puede ser un fallo general del core, o nose si a nivel de plantilla puede haber algo mal.
La versión prestashop es 1.7.6.1 y la plantilla: https://themeforest.net/item/newyork-responsive-prestashop-theme/11785941

Os explico la situación , tengo todo configurado como decía
IVA activado, reglas de impuestos activadas y todo como podéis ver en la imágen correcto.
Desde todos sus correspondientes apartados
Pedidos > facturas
Internacional > impuestos
Todo activado....
 

356599987_PastedFile.thumb.png.6901fa707181bdb0551965019be8655d.png

 

 

He localizado varios fallos que necesitamos solventar:

1ºEl precio no se muestra correctamente, por ejemplo a pesar de que es imp. incl al verlo desde la web sale erróneo el precio , 4,76 iva inc desde el backoffice1182360296_PastedFile2.thumb.png.3380a4a8fb9d8505cba12c5560481636.png

En cambio en el front 3,44 iva inc.

1774024679_PastedFile3.png.d009e88445b892ea6d86d33a54883213.png

2º En el carrito de compra no hace el desglose correctamente, sale el precio sin iva pero luego el IVA ni lo añade, lo deja en cero.

826501597_PastedFile4.png.538bc26e37313572820814816fed1c61.png

3º Por último la factura generada la genera erroneamente, sin añadir iva ni mostrarlo.

1473514467_PastedFile5.png.01088e53535cb75b0815b698158e864a.png



Agradecería mucho una ayuda gracias!

Share this post


Link to post
Share on other sites

Sí que es cierto que últimamente mucha gente escribe con problemas similares de este tipo. Sin embargo, la versión de PS que tienes instalada (1.7.6.1) no es de las más recientes, por lo que dudo que sea algo del Core de PS. ¿Qué versión de PHP ejecuta el servidor donde tienes la web?

Share this post


Link to post
Share on other sites

2 minutes ago, Prestafan33 said:

Sí que es cierto que últimamente mucha gente escribe con problemas similares de este tipo. Sin embargo, la versión de PS que tienes instalada (1.7.6.1) no es de las más recientes, por lo que dudo que sea algo del Core de PS. ¿Qué versión de PHP ejecuta el servidor donde tienes la web?

Versión del software del servidor: Apache

Versión PHP: 7.2.32

Límite de memoria: 4096M

Tiempo máx. de ejecución: 300

Tamaño máx. para la subida de archivos: 20M

Share this post


Link to post
Share on other sites

  • 2 weeks later...
15 hours ago, juanrojas said:

hola

parece como cosa de tu plantilla, pero imposible saberlo porque ellos han considerando como buena idea no poner iva a la demo

Ideal para liar aun más a la mayoria de clientes...

Con la plantilla default, sucede los mismo, (por lo menos a nosotros).

Share this post


Link to post
Share on other sites

  • 10 months later...

A mi me pasa lo mismo, no soy capaz que se muestren los precios con IVA, cambiando cosas al final aparecen en el frontend pero al registrarme como comprador, automaticamente le quita el IVA. Increible, llevo con prestashop varios años y nunca he tenido un problema tan raro y estoy impotente para resolverlo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More