Jump to content

Recommended Posts

Olá amigos, fiz a migração da loja de um servidor para outro (kinghost para hostgator) e aparentemente estava tudo indo "bem", só que não :D.

Ao fazer um cadastro (liberei o modo debug para ver), estou recebendo o seguinte erro:

(1/1) ContextErrorException

Notice: Undefined index: my_account_url

in 06cbde24734828cfcf71dc555a30bd7acdd76e39_2.file.login_myaccount_header.tpl.php line 28

at content_5f1fe702a36682_80348114(object(SmartyCustomTemplate))in smarty_template_resource_base.php line 123

at Smarty_Template_Resource_Base->getRenderedTemplateCode(object(SmartyCustomTemplate))in smarty_template_compiled.php line 114

at Smarty_Template_Compiled->render(object(SmartyCustomTemplate))in smarty_internal_template.php line 216

at Smarty_Internal_Template->render()in smarty_internal_template.php line 385

at Smarty_Internal_Template->_subTemplateRender('file:./login_myaccount_header.tpl', null, 'layouts/layout-full-width.tpl', 0, 3600, array(), 0, false)in a2ccb2f1d7271973b60735a43e2526d04ecd6211_2.file.header-v2.tpl.php line 44

at Block_8871322865f1fe7029f3ef3_72437424->callBlock(object(SmartyCustomTemplate))in smarty_internal_runtime_inheritance.php line 248

at Smarty_Internal_Runtime_Inheritance->callBlock(object(Block_8871322865f1fe7029f3ef3_72437424), object(SmartyCustomTemplate))in smarty_internal_runtime_inheritance.php line 184

at Smarty_Internal_Runtime_Inheritance->process(object(SmartyCustomTemplate), object(Block_8871322865f1fe7029f3ef3_72437424))in smarty_internal_runtime_inheritance.php line 156

at Smarty_Internal_Runtime_Inheritance->instanceBlock(object(SmartyCustomTemplate), 'Block_88713228...

Vou por em anexo  o erro completo.

Alguém pode me ajudar? O domínio da hospedagem é o mesmo, nada mudou neste sentido. Apenas a empresa que hospeda.

Meu prestashop é o 1.7.6.7 e a página bugiganga.pt

Preciso resolver isso urgente. :( .. Obrigado a ajuda de todos.

Vou deixar o Debug ligado para quem puder ajudar, dar uma verificada. O erro acontece ao fazer login (o cadastro é feito com sucesso, mas quando redireciona a página entra o erro).

 

screencapture-bugiganga-pt-2020-07-28-09_53_53.pdf

Share this post


Link to post
Share on other sites

Bom dia,

Esse log informado não deixaria a sua loja fora do ar, pois trata-se apenas de um warning. Esse tipo de erro só trava a loja com o modo de debug ativado. Se a sua loja está realmente fora do ar você deve procurar por erros do tipo Fatal Error no log de erros do seu servidor.

Caso já tenha limpado o cache da loja, excluindo os arquivos em /var/cache (relativos á raiz da instalação do PrestaShop), uma outra tentativa seria conferir o arquivo .htaccess ou verificar se a sua hospedagem possui todos os requisitos da plataforma através de um arquivo phpinfo.

Share this post


Link to post
Share on other sites

Obrigado agti, desativei e ficou bem. A minha questão é que quando estou com o debug desativado, não consigo entrar no admin. :( Enquanto não descubro o problema, tenho que ficar colocando no modo debug pelo ftp.

Vou procurar os logs com Fatal Error para trazer aqui.

Muito obrigado pelo ajuda.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More