Jump to content
Acxel

BO 1.7.6.5 product view - Déclinaisons mélangées entre elles

Recommended Posts

Posted (edited)

BO 1.7.6.5 product view - Quand je suis sur la page déclinaison, je devrais avoir taille couleur et pointure mais les couleurs et les tailles se retrouve mélangés dans couleur. Pointure s'affiche bien.

Quelqu'un aurait-il une idée du problème ?

Contexte multiboutique

Screenshot from 2020-07-10 13-28-55.png

Edited by Acxel (see edit history)

Share this post


Link to post
Share on other sites

Salut,

Vérifie la corrélation des id dans la base de données.

Tu as déjà importé / exporté depuis phpmyadmin?

Share this post


Link to post
Share on other sites

Merci HeineFR !

J'ai en effet importé des produits (avec migration pro), j'ai vérifié les tables ps_attibute_xxx mais je n'ai rien vu d'anormal...

Share this post


Link to post
Share on other sites

Salut,

Tu dois avoir une corrélation logique et précise entre l'id du produit et les id des nom et valeur des attributs.

Si tu vas dans Catalogue -> Attrib & caract -> Attributs, tu dois voir les valeurs bien liées au nom de l'attribut quand tu cliques sur afficher.

Est-ce bien le cas?

Share this post


Link to post
Share on other sites

Merci HeineFR, j'ai fini par trouver avec l'aide d'un pote expert prestashop.

Toutes mes valeurs sont bonnes en BDD, la seule valeur que je n'avais pas pensé à regarder est la position... Et oui, les attribut sont triés par position quand on veut créer un produit ! Et j'avais la même postion pour Taille et Couleur... 

Donc j'ai changé la position d'un des deux et maintenant tout marche nickel !

Merci encore pour ton aide, et j'espère que cela aidera quelqu'un d'autre.

  • Thanks 1

Share this post


Link to post
Share on other sites

Impec! ravi d'apprendre que tu as solutionné ton problème ;)

Share this post


Link to post
Share on other sites
Il y a 2 heures, Acxel a dit :

Merci HeineFR, j'ai fini par trouver avec l'aide d'un pote expert prestashop.

Toutes mes valeurs sont bonnes en BDD, la seule valeur que je n'avais pas pensé à regarder est la position... Et oui, les attribut sont triés par position quand on veut créer un produit ! Et j'avais la même postion pour Taille et Couleur... 

Donc j'ai changé la position d'un des deux et maintenant tout marche nickel !

Merci encore pour ton aide, et j'espère que cela aidera quelqu'un d'autre.

Merci d'avoir pris le temps de venir partager avec la communauté la solution à votre souci.

Share this post


Link to post
Share on other sites
On 7/24/2020 at 5:35 PM, Acxel said:

Merci encore pour ton aide, et j'espère que cela aidera quelqu'un d'autre.

Clairement... Merci pour le partage !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More