Jump to content
  • 0

Block Facettennavigation Drop-DownListe


Question

PrestaVersion1.6.1.10

 

Hallo,

ich habe in der Facettennavigation die Darstellung "Drop-Down-Liste" gewählt. Diese wird auch korrekt angezeigt, hat aber leider das Problem, sobald ich auf den "Pfeil" der DropDwonliste klicke öffnet sich kurz die mögliche Auswahlliste und dann wird sofort wieder die aktuelle Seite neu geladen mit "keine Filter".

D.h. ich kann die Auswahl nicht öffnen und nutzen, da bei klick auf den Pfeil sofort die Seite mit "keine Filter" neu geladen wird.

Hat jemand einen Lösungsansatz??

Danke & Grüße

 

Es handelt sich um die blocklayered.tpl mit dem Abschnitt:
<select class="select form-control" {if $filter.filter_show_limit > 1}multiple="multiple" size="{$filter.filter_show_limit}"{/if}>
                                            <option value="">{l s='No filters' mod='blocklayered'}</option>
                                            {foreach from=$filter.values key=id_value item=value}
                                            {if $value.nbr || !$hide_0_values}
                                                <option style="color: {if isset($value.color)}{$value.color}{/if}" id="layered_{$filter.type_lite}{if $id_value || $filter.type == 'quantity'}_{$id_value}{/if}" value="{$id_value}_{$filter.id_key}" {if isset($value.checked) && $value.checked}selected="selected"{/if} {if !$value.nbr}disabled="disabled"{/if}>
                                                    {$value.name|escape:'html':'UTF-8'}{if $layered_show_qties}<span> ({$value.nbr})</span>{/if}
                                                </option>
                                            {/if}
                                            {/foreach}
                                        </select>

Edited by Twilli (see edit history)

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Schau mal ob da nicht ein Javascript auf eine Änderung reagiert, denn von allein macht so eine Liste eigentlich nichts. Kannst auch hier einen Link zu deinem Shop posten dass wir uns das mal direkt anschauen können.

Share this post


Link to post
Share on other sites
  • 0
On 7/6/2020 at 6:08 PM, Twilli said:

Das Java wäre > siehe Anhang

Aber ich sehe den Fehler nicht.

Du musst deine Auswahlliste mit der Inspekt Funktion deines Browsers untersuchen, dort siehst du dann ob und welches Javascript auf Aktionen dieses Elementes reagiert. Von dort kannst du dann weiter schauen warum...
Falls du dich damit nicht auskennst kannst du auch hier einen Link auf deine Seite posten.

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, SliderFlash said:

nscheinend gibt es nicht für alle eine Lösung

https://github.com/PrestaShop/PrestaShop/issues/14575

das einzige was hilft ist Facettennavigation deaktivieren dann funktuniert es

Das bezieht sich doch auf ein ganz anderes Problem, andere Prestashop Version und damit auch anderes Modul!

Wie gesagt liegt das Problem in der alten Javascript des Moduls von Twilli und sollte mit einem Upgrade dieses Moduls behoben sein.

Share this post


Link to post
Share on other sites
  • 0

Vielen Dank für eure Hilfe

Version: Block Facettennavigation v2.2.1 - von PrestaShop

PHP-Version 7.0.33

Ich habe bereits deaktiviert, aktiviert, cache gelöscht.... Datein von facettenmodul ersetzt . .  . alles was man so machen kann ohne direkt im code zu "wursteln".

 

Grüße

Share this post


Link to post
Share on other sites
  • 0
16 minutes ago, Twilli said:

Version: Block Facettennavigation v2.2.1 - von PrestaShop

Das ist wie gesagt seltsam da dort die JS anders ist - entweder du ersetzt mal nur die Datei oder installierst das Modul neu. Links der neue Code, Rechts deine Website, Gelb markiert dein Problem.

grafik.thumb.png.1b2f0d86430fb07feb9695a57adf8236.png

Hier der Link zur einzelnen Datei:

https://github.com/PrestaShop/blocklayered/blob/master/blocklayered.js

Share this post


Link to post
Share on other sites
  • 0

Ok - vielen Dank !

Leider gabs eine Fehlinfo. Im Theme-Ordner/Module selbst ist das Modul auch noch mal enthalten und hier sind wirklick die alten .js drin

alte Dateien: 2007-2015 PrestaShop
neue Dateien: 2007-2016 PrestaShop

Ich habe zum Test die aktuellere .js hochgeladen. Damit ist dann der Fehler leider nicht behoben, und/aber die komplette Facettennavigation funktioniert dann nicht mehr und die Navigation im Head wird nicht mehr korrekt dargestellt.

Grüße

Share this post


Link to post
Share on other sites
  • 0
32 minutes ago, Twilli said:

Leider gabs eine Fehlinfo. Im Theme-Ordner/Module selbst ist das Modul auch noch mal enthalten und hier sind wirklick die alten .js drin

alte Dateien: 2007-2015 PrestaShop
neue Dateien: 2007-2016 PrestaShop

Du solltest vorher den alten Modulordner umbennen, dann das Modul neu installieren

 

33 minutes ago, Twilli said:

Ich habe zum Test die aktuellere .js hochgeladen. Damit ist dann der Fehler leider nicht behoben, und/aber die komplette Facettennavigation funktioniert dann nicht mehr und die Navigation im Head wird nicht mehr korrekt dargestellt.

Kann natürlich sein dass ist der neuen Version noch mehr geändert wurde und dass dann nicht mehr kompatibel ist - hilft wohl nur das ganze Modul zu erneuern

Share this post


Link to post
Share on other sites
  • 0

Hallo und vielen Dank.

Wenn ich die Facettennavigation deaktiviere habe ich auch keine Facettennaviagtion (Filter) mehr. Diese soll bestehen bleiben . .

Aber ich habe eine Lösung gefunden:
Die akteullen blocklayered.tpl Dateien verwenden.
Die alte blocklayered.js wie folgt ändern:

ca. in/ab Zeile 45 u. 125
Diesen code:

$(document).on('click', '#layered_form .select, #layered_form input[type=checkbox], #layered_form input[type=radio]', function(e) {

        reloadContent(true);
    });

 

mit folgendem ersetzen:

$(document).on('change', '#layered_form .select', function(e)
    {
        reloadContent();
    });
    
    $(document).on('change', '#layered_form input[type=checkbox]', function(e)
    {
        reloadContent(true);
    });

 

Und bei mir ist das Problem behoben. Ich muss nun nur noch ein paar optische Anpassungen durchführen.

Vielen Dank an alle Beteiligten!!!!

Gelöst! (wie setzt man den Beiträg auf gelöst?)

Grüße

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More