Jump to content

Recommended Posts

Na de update naar versie 1.7.6.6 kom ik niet meer in mijn backoffice. Doordat de update (1-click upgrade module) erg lang duurde ben ik even weggelopen en toen zag ik aan het einde van de samenvatting iets van een melding over de database. Maar heb toen per ongeluk op refresh geklikt en was toen de melding kwijt. Bij het inloggen in de backoffice kan ik de gebruikersnaam en wachtwoord invullen alleen dan verdwijnt dit blokje en zie je dus alleen de backoffice login staan zonder de velden waar je je gebruikersnaam en ww in kan vullen.

Natuurlijk ook geen backup gemaakt i.v.m. ik dacht dat is een kleine update van prestashop 1.7 naar 1.7....:(

Iemand een idee hoe ik dit kan oplossen? Het is een nieuwe versie van de huidige website (oude zit nog op 1.6), dus geen ramp, maar hopelijk ben ik niet alles kwijt.

Alvast bedankt.

Groeten,

Patrick

Share this post


Link to post
Share on other sites

Zelfde probleem hier. Na de update geen enkele mogelijkheid om meer in te loggen in de backoffice. Cache legen (zowel in ftp als op laptop) werkt niet, andere plek, ander wachtwoord, andere werknemer. Niks.

De site wel weer aan de praat gekregen in de database, dus kan de verkoop doorgaan. De frontend lijkt dan ook niet beschadigd.

Wie o wie heeft de oplossing om weer in de backoffice te komen?

Alvast bedankt,

Sabine (joyenco.nl)

Share this post


Link to post
Share on other sites

Heeft iemand het al gevonden wat het probleem is/was want ik loop ook tegen de zelfde probleem aan

Share this post


Link to post
Share on other sites

Nee, helaas, nog geen oplossing.

Share this post


Link to post
Share on other sites

Gevonden
De hoofdoorzaak dat ik niet kan inloggen, is omdat SQL-tabellen ps_customer_session en ps_employee_session ontbreken in de database

Share this post


Link to post
Share on other sites

Hai Hanswolf,

Ja, idd, dat vertelde ook mijn ingehuurde sitemaken😀.

Ik kan weer in de BackOffice. Maar voor de volgende keer: waar haal ik die stukjes database vandaan? Ik begreep dat deze 2 stukjes nieuw zijn.

Sabine

Share this post


Link to post
Share on other sites

Het werkt weer
Het was makkelijk voor mij. Exporteren in database-testomgeving en importeren in database-productieomgeving de tabellen ps_customer_session en ps_employee_session

 

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, JoyenCo said:

Hai Hanswolf,

Ja, idd, dat vertelde ook mijn ingehuurde sitemaken😀.

Ik kan weer in de BackOffice. Maar voor de volgende keer: waar haal ik die stukjes database vandaan? Ik begreep dat deze 2 stukjes nieuw zijn.

Sabine

Het makkelijkste is een testomgeving te maken. Dan heb je alles tot je beschikking
Of het bestand prestashop_1.7.6.7.zip downloaden. In dit bestand staat alles
https://github.com/PrestaShop/PrestaShop/releases

In het bestand staat het op de locatie /prestashop.zip/install/data/db_structure.sql

Zie bijlage voor de bestanden die zijn toegevoegd in de database

pr_customer_session.sql pr_employee_session.sql

Edited by Hanswolf (see edit history)

Share this post


Link to post
Share on other sites

Hai Hanswolf,

Onwijs bedankt!

Ik had idd die .zip gedownload en daarin in de strucure.sql die 2 toevoegingen gevonden.

Maar hoe krijg je dan die losse .sql's?

Sabine

Share this post


Link to post
Share on other sites
4 hours ago, JoyenCo said:

Hai Hanswolf,

Onwijs bedankt!

Ik had idd die .zip gedownload en daarin in de strucure.sql die 2 toevoegingen gevonden.

Maar hoe krijg je dan die losse .sql's?

Sabine

Dat doe je door een export te maken van een tabel in de database

Share this post


Link to post
Share on other sites

Beste Hanswolf,

Ik heb niet heel veel verstand van de database, ik heb in de twee losse bestanden geprobeerd mijn database te zetten achter "Databank:", dan maakt hij de tabellen aan bij importeren.

Dat maakte niks uit, bleef hetzelfde. Daarna ook nog geprobeerd in de code de "pr_" te vervangen voor wat bij mij ervoor stond in de database (bijvoorbeeld Po_dr_34555empolyee_session).

Ook dat maakte niks uit.

Zie ik iets over het hoofd?

Alvast bedankt voor de hulp.

Groeten,
Patrick

Share this post


Link to post
Share on other sites

Kijk hier even na. Maar doe dit niet in de productie omgeving maar testomgeving
Maak ook even een back van je testomgeving en/of database. Veel werk, maar als je dit allemaal heb gedaan kun je meer risico's nemen met testen.
P.s. Je database is het hart van je website

 

Share this post


Link to post
Share on other sites

Beste HansWolf,

 

Het importeren was wel gelukt alleen werkt het bij mij nog niet. Ik heb de bestandjes die je had gestuurd aangepast en geimporteerd.

"ps_customer_session" en "ps_employee_session"

Bij mij is de prefix alleen anders dus werd het ps_tr_4567customer_session en ps_tr_4567employee_session.

Die tabelen zijn ook zichtbaar, maar ik blijf niet in de backoffice kunnen komen. Hij blijft voor mijn gevoel wel langer laden, maar dan verdwijnt alsnog de inlognaam en wachtwoord veld en dan zie je alleen het logo van prestashop en gebeurd er niks meer...

 

Iemand een idee wat er niet goed is of een vergelijk van de databasetabel?

Alvast bedankt.

Groeten,

Patrick

 

 

Share this post


Link to post
Share on other sites

Sorry, bij mij is het uiteindelijk door een externe partij opgelost, dus ik kan je verder niks vertellen over de werking van de database.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More