Jump to content

Manche Artikel lassen sich nicht in den Warenkorb legen


Recommended Posts

Hallo allerseits, 

Mir ist gerade zufällig aufgefallen, dass sich manche Artikel nicht in den Warenkorb legen lassen (zB https://www.littlepippa.de/dekorieren/138-320-jabadabado-messlatte-aus-holz-wolke.html#/8-farbe-weiss). 

 

Habe mehrere Browser und Geräte getestet, beim Klick auf den Einkaufswagen-Button passiert gar nichts.

Ist das ein bekannter Fehler oder hat jemand eine Idee, woher das kommen kann? 

Share this post


Link to post
Share on other sites
Just now, SliderFlash said:

Es ist nur der eine Artikel, der Hakt irgendwo alle anderen Artikel gehen, den Artikel Löschen und neu Eintragen fertig

Da ich das nur durch Zufall entdeckt habe, kann ich mir da aktuell nicht sicher sein, oder? 

Dass 100 andere Artikel, die ich und kunden in den letzten Tagen in den Warenkorb gelegt haben, keine Probleme verursachen, heißt ja leider nicht, dass es nicht doch noch welche gibt.

Share this post


Link to post
Share on other sites

Leider nicht immer. Will man diesen Artikel in den Warenkorb legen, verursacht das einen leeren Warenkorb. Davon habe ich schon ein paar mal welche gesehen und denke mal nicht, dass viele Leute ihren Korb wieder ausräumen 😁 Da haben sich die Kunden wohl gedacht "Na dann halt nicht."

Share this post


Link to post
Share on other sites

Es scheint der Artikel soll eigentlich Customizable sein (siehe Fehlermeldung), aber irgendwie fehlen die entsprechenden Felder in der Produktansicht. Prüfe nochmal den Artikel im Backoffice, da stimmt was nicht

grafik.thumb.png.302abc62d7ecdabb3394525a8d4dd6e5.png

  • Thanks 1

Share this post


Link to post
Share on other sites

Interessant, danke dir. Dann schaue ich gleich mal, ob noch irgendwas in der Datenbank überlebt habt. Er war mal customizable, das habe ich aber irgendwann entfernt. 

Kannst du eine Anleitung verlinken, wie ich an diesen output komme? 

Edited by Dp. (see edit history)

Share this post


Link to post
Share on other sites
3 minutes ago, SliderFlash said:

ich würde einfach mal das Produkt neu erstellen danach nochmal probieren

Ich bin mir sicher, dass das das Symptom löst. Aber das ist langfristig der falsche Ansatz, zumindest für mich 🙂

Share this post


Link to post
Share on other sites
3 hours ago, JBW said:

Es scheint der Artikel soll eigentlich Customizable sein (siehe Fehlermeldung), aber irgendwie fehlen die entsprechenden Felder in der Produktansicht. Prüfe nochmal den Artikel im Backoffice, da stimmt was nicht

grafik.thumb.png.302abc62d7ecdabb3394525a8d4dd6e5.png

Der Hinweis hat es gelöst, danke dir!

in ps_product war der Artikel mit customizable = 0 hinterlegt (korrekt, daher auch kein Eingabefeld). in ps_customization_field gab es aber noch einen Eintrag zu dieser id_product, welcher dann wohl diesen Fehler der fehlenden Eingabe ausgelöst hat. Nach dem Löschen klappt es nun.

 

Gerne nehme ich den Namen des Tools, das du für diese JSON-Abfrage genutzt hast 🙂

Share this post


Link to post
Share on other sites
28 minutes ago, Dp. said:

Gerne nehme ich den Namen des Tools, das du für diese JSON-Abfrage genutzt hast 🙂

Firefox :) Geht aber auch mit den Entwicklerwerkzeugen in den anderen modernen Browsern - dort kannst du die Ajax/XHR Anfragen sehen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More