Jump to content

Résolu - 500 Server Error


jazz for soul
 Share

Recommended Posts

Hello !

Here I am in a critical situation, when I try to access my site, I get a 500 Server Error and when I try to access the back-end, here is what is displayed:


[PrestaShopException]
Link to database cannot be established:SQLSTATE[28000] [1045] Access denied for user 'superboy'@'localhost' (using password: YES)
at line 102 in file classes/db/DbPDO.php
97.     public function connect()
98.     {
99.         try {
100.             $this->link = $this->_getPDO($this->server, $this->user, $this->password, $this->database, 5);
101.         } catch (PDOException $e) {
102.             throw new PrestaShopException('Link to database cannot be established:'.$e->getMessage());
103.         }
104. 
105.         // UTF-8 support
106.         if ($this->link->exec('SET NAMES \'utf8\'') === false) {
107.             throw new PrestaShopException('PrestaShop Fatal error: no utf-8 support. Please check your server configuration.');
	DbPDOCore->connect - [line 319 - classes/db/Db.php]
	DbCore->__construct - [line 240 - classes/db/Db.php] - [4 Arguments]
	DbCore::getInstance - [line 66 - config/alias.php]
	pSQL - [line 329 - classes/shop/Shop.php] - [1 Arguments]
	ShopCore::initialize - [line 114 - config/config.inc.php]
	require - [line 36 - admin/index.php] - [1 Arguments]

What to do ?? My prestashop is in 1.6 and I'm at planethoster. Thank you for your help….

 

Edited by jazz for soul (see edit history)

Share this post


Link to post
Share on other sites

You have make any change with database?

Kindly check your database , database user, database password and match with file /config/settings.inc.php record

 

Example:

define('_DB_NAME_', 'prestashop');
define('_DB_USER_', 'root');
define('_DB_PASSWD_','root ');

Edited by Razi (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

Hi!

I have the exact same problem (http://charmillaboutique.nl/). 

Can you let me know where I can adjust this: 

define('_DB_NAME_', 'prestashop');
define('_DB_USER_', 'root');
define('_DB_PASSWD_','root ');

I did find the correct config/settings.inc.php record, but I dont really know where to adjust it..

Hope you can help! 

Edited by Charmilla Boutique
addiotional information (see edit history)

Share this post


Link to post
Share on other sites

In the config/settings.inc.php file you will see the database name, database user name and password.

now you need to update this file with updated information.

open your hosting panal, go in database section and get the name of database.
After this check the database user section and match the Database user name and at the end match the password.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More