Jump to content
kolorslab

Erreur téléchargement facture espace client, erreur DHL et mode DEBUG

Recommended Posts

Bonjour

J'ai une erreur "ContextErrorException" lorqu'un client souhaite générer sa facture sur son compte client après commande depuis le bouton PDF (en BO cela fonctionne parfaitement). Prestashop est en version1.7.6.3 et je n'ai pas d'erreurs sur le site de recette.

the error seem to come from PDFGeneratorCore->Header()in tcpdf.php line 3536 because the pdf generation doesn't work.

Dans le Back-Office j'ai une 2nde erreur liée semble-t-il à DHL express

Notice à la ligne 2681 du fichier /xxx/xxx/www/shop/modules/dhlexpress/dhlexpress.php [8] Undefined index: DOMESTIC

Je ne sais pas comment résoudre ce bug d'autant que le site générère une erreur 500 si il n'est pas en mode DEBUG:TRUE :(

Une personne a déjà eu ces erreurs ?

Merci pour votre retour

Cordialement

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour,

videz le cache manuellement et retirez le mode debug.

Effacez les répertoire dev et prod dans le répertoire /var/cache/

Voici une petit tutoriel expliquant la manœuvre avec surtout une astuce https://www.mediacom87.fr/faq-comment-vider-le-cache-manuellement-sur-prestashop-17/

Edited by Mediacom87 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour, merci je vais faire ce que vous préconisez

 

Ce serait juste du cache donc selon vous ?

 

Je vous tiens informé

 

Sur le site de test aucun problème c'est ça qui me dérange. Les répertoires dev & prod peuvent être vidés sans souci ? Il faut relancer l'indexation ensuite des attributs, prix ... ?

Merci :)

Share this post


Link to post
Share on other sites
il y a 1 minute, kolorslab a dit :

Ce serait juste du cache donc selon vous ?

non, mais c'ets un début

 

il y a 1 minute, kolorslab a dit :

Sur le site de test aucun problème c'est ça qui me dérange.

certainement que le mode debug n’est pas actif sur votre site de dev.

il y a 1 minute, kolorslab a dit :

Les répertoires dev & prod peuvent être vidés sans souci ?

oui

 

il y a 2 minutes, kolorslab a dit :

Il faut relancer l'indexation ensuite des attributs, prix ... ?

non, sinon je l'aurais précisé

  • Like 1

Share this post


Link to post
Share on other sites

C'est exactement ça

J'ai du installer un plugin pour le client et j'avais une erreur à chaque fois pour ça que j'ai laissé le mode debug

Je gère ça demain matin

Merci beaucoup 😉

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More