Jump to content

Recommended Posts

Bonjour, 

Sous prestashop 1.6, le logo des factures et bon de livraison apparaît avec un fond noir (problème survenu du jour au lendemain). Après plusieurs essais et recherches je ne comprends pas pourquoi notre logo a un fond noir sur les bons de livraison et facture alors qu'il devrait apparaitre sur fond blanc. Auriez-vous une idée pour résoudre ce problème ? 

 

Merci 

Share this post


Link to post
Share on other sites

Ca sent le .png transformé en .jpg ça^^ (Perte du canal Alpha/transparence)

Envoyez un jpg pour les factures.

Share this post


Link to post
Share on other sites

Vous pouvez envoyer votre jpg ici ?

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai le même souci. Du jour au lendemain. Sous version 1.6.1.18. Comprends pas

Share this post


Link to post
Share on other sites
Posted (edited)

C'est réglé. En transformant le png en jpg avec GIMP

 

Merci Eolia de m'avoir mis sur la piste. 😉

Edited by nevohteeb (see edit history)

Share this post


Link to post
Share on other sites

Exactement, comme répondu plus haut^^

Share this post


Link to post
Share on other sites

Je rejoins le club des factures avec le logo en noir et blanc si le PNG est utilisé.

Après avoir fait des essais il s'avère que tous les Prestashop 1.5 et 1.6 sont touchés, seul PS 1.7 n'a pas le souci.

Le .jpg n'est pas une option pour moi car j'ai du vert vif et du rouge dans mon logo et cela bave en .jpg

Quelqu'un aurait-il une idée de la cause de ce changement du jour au lendemain des pdf avec logos en png ?

Share this post


Link to post
Share on other sites
Posted (edited)

Pour ceux que ça intéresse, il suffit de remplacer dans tools/tcpdf la version actuelle 5.9.179 par la dernière version 5 à savoir la 5.9.209 pour que cela refonctionne et que les PNG reviennent à la couleur 😉

Cela refonctionne à partir de la version 5.6.206 dont le changelog dit :

- Bug item #754 "PNG with alpha channel becomes gray scale" was fixed.

https://sourceforge.net/projects/tcpdf/files/OldFiles/

Comme cela date du 22/02/2013 je n'ai aucune idée de pourquoi cela fonctionnait jusqu'à maintenant...

Edited by KevinNash (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More