Jump to content
altezeit

Bestellung kann nicht vollendet werden

Recommended Posts

Posted (edited)

Guten morgen, meine Presta Version: 1.7.4.2

Soeben durch einen Kunden drauf gekommen. Mein Shop lässt keine Bestellungen durch, da kommt dann die Fehlermeldung:

500 Server Error

Oops, something went wrong.

Try to refresh this page or feel free to contact us if the problem persists.

 

Soweit funktioniert alles, die Zahlungsarten alles wird angezeigt und sobald man dann auf Zahlungspflichtig bestellen klickt, kommt diese Meldung oben.

Was gemacht wurde.

1.) Ich benutze das Modul von mollie also auch den Zahlungsanbieter. Dieser hatte ein update, das ich dann auch durchgeführt habe, das war gestern morgen. Jetzt ist mir aufgefallen, dass alle Zahlungsarten die ich über mollie laufen habe, irgendwie deaktiviert waren, also habe ich alle wieder aktiviert.

2.) Hatte ich das Modul doofinder installiert, aber dann auch wieder deaktiviert, jetzt habe ich es endgültig gelöscht.

Hat da jemand eine ahnung, was ich machen kann, hatte jemand auch so ein Problem?

Anbei ein Screenshot von Erweiterte Einstellungen > Informationen

 

 

PS: Warum werden meine Beiträge erst noch geprüft bevor diese hier im Forum erscheinen? Das dauert ja Stunden. Ich möchte keine Werbung schalten!!! Ich schreibe wegen Probleme!

Unbenannt1.png

Edited by altezeit
bild hinzugefügt (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

Also ein Freund von mir hat gerade eine Testbestellung gemacht und als Zahlungsart hat er Überweisung ausgewählt. Bei ihm kam auch die Fehlermeldung, aber die Bestellbestätigung kam durch, diese hat er erhalten.

Ich habe aber von der Bestellung nichts gesehen, also im Backend wurde mir nichts angezeigt dass eine bestellung reingekommen ist!

Edited by altezeit (see edit history)

Share this post


Link to post
Share on other sites

Habe eben auch mal eine Bestellung durchgeführt und als Zahlunsart: Pay Later Klarna ausgewählt, dann kam folgendes

Error executing API call (422: Unprocessable Entity): An order created with the Orders API is required for this payment method. Field: order. Documentation: https://docs.mollie.com/guides/handling-errors. Cart Dump: { "amount": { "currency": "EUR", "value": "8.99" }, "method": "klarnapaylater", "redirectUrl": "https:\/\/www.altezeitschriften.de\/module\/mollie\/return?cart_id=656&utm_nooverride=1&rand=1591520801", "webhookUrl": "https:\/\/www.altezeitschriften.de\/module\/mollie\/webhook", "metadata": { "cart_id": 656, "order_reference": "LHBBTNWQB", "secure_key": "725f8148ae652f27fb3ae4da012b84f2" }, "description": "Pay later", "issuer": null }

Was ist das????

Share this post


Link to post
Share on other sites
1 minute ago, Claudiocool said:

Was machen die Backslashes hier?

Was ist Backslashes ?

Share this post


Link to post
Share on other sites

Habe mal in den Log Dateien nachgeschaut unter dem Reiter: Einstellungen > Erweiterte Einstellungen > Log Dateien. Da steht in der Zeile: Nachricht folgendes: PaymentModule::validateOrder - Order Status cannot be loaded

 

Vielleicht kann jemand was damit anfangen.

Share this post


Link to post
Share on other sites
3 hours ago, altezeit said:

Habe eben auch mal eine Bestellung durchgeführt und als Zahlunsart: Pay Later Klarna ausgewählt, dann kam folgendes

Error executing API call (422: Unprocessable Entity): An order created with the Orders API is required for this payment method. Field: order. Documentation: https://docs.mollie.com/guides/handling-errors. Cart Dump: { "amount": { "currency": "EUR", "value": "8.99" }, "method": "klarnapaylater", "redirectUrl": "https:\/\/www.altezeitschriften.de\/module\/mollie\/return?cart_id=656&utm_nooverride=1&rand=1591520801", "webhookUrl": "https:\/\/www.altezeitschriften.de\/module\/mollie\/webhook", "metadata": { "cart_id": 656, "order_reference": "LHBBTNWQB", "secure_key": "725f8148ae652f27fb3ae4da012b84f2" }, "description": "Pay later", "issuer": null }

Was ist das????

Ein Fehler vom Mollie Modul - am besten den Entwickler kontaktieren.

Share this post


Link to post
Share on other sites
3 hours ago, JBW said:

Ein Fehler vom Mollie Modul - am besten den Entwickler kontaktieren.

Glaube ich auch, ich habe es jetzt anders geacht und zwar habe ich das Modul resetet und somit funktioniert mollie jetzt mit der 4.0 Version, aber es geht.

Share this post


Link to post
Share on other sites
Just now, SliderFlash said:

aktuelle version 1.7.6.5

Weiß ich, habe ich schon versucht. Da war mein ganzer Shop zerschossen. Allerdings würde ich jemanden suchen der das machen kann, so dass der shop danach wieder einwandfrei läuft. Wer Interesse hat bitte melden.

Share this post


Link to post
Share on other sites

Hi,

zwischen 1.7.4.2 und 1.7.6.5 hat sich einiges getan. Ich denke da fährt man besser wenn man ein paar der Zwischenschritte als Updates mit einspielt. Also erst 1.7.5.0 dann 1.7.6.0 und dann 1.7.6.5 installieren oder so. Wichtig, immer sämtliche Caches leeren sonst versucht dein Browser oder der Shop auf eine Bekannte Seite zu zu greifen, die so vielleicht nicht mehr existiert und dann bekommst du einen Fehler obwohl der Shop selber läuft.

Und zu deinem Problem, wie JBW schon schrieb, liegt das an dem Modul. Entweder verträgt es sich nicht mit deiner Shopversion oder mit der PHP Version. Also entweder mit der alten Version weiter arbeiten oder den Entwickler anschreiben und nach Hilfe fragen.

Share this post


Link to post
Share on other sites

Ich habe jetzt das neueste Update hochgeladen und es funktioniert einwandfrei. Es ist die Version 4.0.5

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More