Jump to content

Debe aparecer código idioma en URL amigables? (/es, /en)


Recommended Posts

Hola,

En una tienda que sea multilingüe, con las URL amigables activadas y su correspondiente .htaccess, debe aparecer el código iso de los idiomas (/es, /en) en la URL del dominio? Ejemplo dominio: www.tienda.com/es

Lo digo porque he instalado la versión 1.4 final y a la hora de generar las URL amigables me ha añadido los códigos de cada idioma en la URL. Es correcto? Supongo que esto por temas de SEO.

Cómo se puede quitar el /es para el español? Entiendo que no sería necesario si es el idioma por defecto.

Gracias y un saludo.

Share this post


Link to post
Share on other sites

A mi igual, pero creio que es para mejorar el SEO , si el cliente busca en google solo un idioma, sale tu tienda en el idioma buscado, creo, no sé si llega a interferir en los resultados de los buscadores, aun estoy con la nueva version en localhost en la pc.

Share this post


Link to post
Share on other sites

Efectivamenete, como dice UniArt, no afecta para anda porque al buscar en google, apareceréis como www.midominio.com/ (sin /es), y mostrará el idioma por defecto.

Aún así si quieres quitarlo, puedes hacerlo mediante redirección en .htaccess, es decir, que todo lo que cargue como /es lo reenvíe a / añadiendo esta linea:

Redirect /es http://www.midominio.com/

Share this post


Link to post
Share on other sites

  • 4 weeks later...

Hola.

Me he encontrado con este problema y al final lo he solucionado siguiendo estos pasos.

Como evitar que en las URLs amigables aparezca el idioma (/es, /en,...) cuando solo usamos un solo idioma.

1.- Desactivar los idiomas que no se van a usar.
Herramientas > idiomas > dejar solo el idioma predeterminado.

2.- Quitar los idomas del servidor.
Preferencias > ubicación > avanzado > vaciar los datos idioma local, país local.

3.- Activar (si no estan ya activas) las URLs amigables y regenerar el archivo htaccess.
Herramientas > generadores > marcar url amigables > pulsar generar archivo htaccess

Por último quizás tengáis que borrar la cache del smarty.

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More