Jump to content
Sign in to follow this  
tresorsdargan

plus de mise en page dans le Thumb-list de la fiche produit

Recommended Posts

Bonjour à tous,

Je viens à vous car je bloque complètement sur un soucis de présentation du Thumb-list dans la page produit.

Je suis depuis peu sur PS 1.4, et ai grandement modifié le thème installé, jusqu'à ce que l'on me fasse remarquer la présentation des vignettes des photos additionnelles, ou vous constaterez que c'est un peu le bazar...je pense avoir du par erreur toucher les css, mais malgré une copie identique des fichiers au thème d'origine, le soucis persiste.

Je vous cite ce lien flagrant ci-dessous ou vous constaterez...

le globals.css :

#views_block{width:290px;margin:0 auto}
#thumbs_list{overflow:hidden;float:left;width:255px}
#thumbs_list ul{padding-left:0;list-style-type:none;margin-top:5px}
#thumbs_list li{float:left;cursor:pointer;width:80px;height:80px;margin-right:5px}
#view_scroll_left,#view_scroll_right{background:url(../img/thumbs_left.png) no-repeat center;text-indent:-3000px;width:9px;height:18px;float:left;margin-top:30px;padding-right:4px;padding-left:4px}
#view_scroll_right{background-image:url(../img/thumbs_right.png)}
span.view_scroll_spacer{float:left;width:17px;height:80px}



la partie product.tpl

        <!-- thumbnails -->

       {if isset($images) && count($images) > 3}{l s='Previous'}{/if}


               {if isset($images)}
                   {foreach from=$images item=image name=thumbnails}
                   {assign var=imageIds value="`$product->id`-`$image.id_image`"}

getImageLink($product->link_rewrite, $imageIds, 'thickbox')}" rel="other-views" class="thickbox {if $smarty.foreach.thumbnails.first}shown{/if}" title="{$image.legend|htmlspecialchars}">
getImageLink($product->link_rewrite, $imageIds, 'medium')}" alt="{$image.legend|htmlspecialchars}" height="{$mediumSize.height}" width="{$mediumSize.width}" />


                   {/foreach}
               {/if}


       {if isset($images) && count($images) > 3}{l s='Next'}{/if}

       {/if}
       {if isset($images) && count($images) > 1}
getProductLink($product)}" onclick="$('span#wrapResetImages').hide('slow');return (false);">{l s='Display all pictures'}{/if}



Je ne sais plus ou donner de la t^te, peut être je passe devant 50 fois et ne le vois plus...pouvez vous m'éclairer ?
Régler ce problème d'alignement vertical au lieu d'horizontal (comme à l'origine quoi), et qui me génère un décalage sous FF par exemple vers le droite.

Merci à vous

Olivier

Share this post


Link to post
Share on other sites

Bonjour Narjis

 

D'après ce que je peux voir sur votre boutique, le problème a été réglé. Pouvez-vous nous indiquer comment vous avez réglé cela ?

Merci

 

Thierry

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More