Jump to content

E-Simplify


Orbitaga
 Share

Recommended Posts

Untitled.thumb.jpg.75a0dc424aa57d40b2a1c8697fb31206.jpg

 

Καλησπέρα σε όλους

Έκανα αίτηση στην Εθνική για πληρωμή στο eshop μου μέσω πιστωτικών καρτών και πριν από μερικές ημέρες μου ήρθαν τα στοιχεία για να κάνω Login στο E-simplify και να ξεκινήσει η διαδικάσία. Κατέβασα και το Module (αφού έφαγα τα μούτρα μου και δεν γινόταν Upload αν δεν άλλαζες το όνομα του αρχείου) και το εγκατέστησα. Διάβασα τις οδηγίες και λέει πρέπει να δημιουργήσεις API κλειδιά σε sandbox mode με το Hosted payments enabled. Επίσης θέλει να ενεργοποιήσεις το show sandbox data.

 

Ωραία τα έκανα όλα αυτά και τρέχω μια πληρωμή με τις dummy Πιστωτικές κάρτες που έχει το documentation αλλά δεν γίνεται τίποτα. Το loading circle δεν σταματάει ποτέ , η συναλλαγή δεν ολοκληρώνεται.

Ο μόνος τρόπος που δούλεψε η συναλλαγή είναι αν αλλάξω το payment mode από "Hosted payments" σε "standard". Νομίζω όμως αυτό δεν είναι σωστό γιατί αν διαβάσετε στο συννημένο που έστειλα γράφει "To use hosted payments you must create a new API Key pair with the 'Enable hosted payments' option selected."

Άρα λογικά θέλει την default επιλογή "hosted payments" με την οποία η πληρωμή δεν ολοκληρώνεται ποτέ!

 

Επίσης ξέρει κανείς πώς βάζω αυτό το reference number, τί είναι , που το βρίσκω, κτλ;

Edited by Orbitaga
forgot image (see edit history)

Share this post


Link to post
Share on other sites

Παιδιά θα εκτιμούσα όποια βοήθεια μπορείτε να δώσετε εσείς που εγκαταστήσατε με επιτυχία το module. Αυτό που δεν μπορώ να καταφέρω είναι να συμπεριλάβω ένα reference code στην δοκιμαστική συναλλαγή. Έχω βάλει στο payment.tpl ( modules -> simplifycommerce) το data reference

Ο κώδικας ήταν αυτός:

<div>
                <button id="simplify-hosted-payment-button"
                        data-sc-key="{$simplify_public_key|escape:'htmlall':'UTF-8'}"
                        data-name="{$hosted_payment_name|escape:'htmlall':'UTF-8'}"
                        data-description="{$hosted_payment_description|escape:'htmlall':'UTF-8'}"
                        data-reference="{$hosted_payment_reference|escape:'htmlall':'UTF-8'}"
                        data-amount="{$hosted_payment_amount}"
                        data-operation="create.token"
                        data-customer-name="{$firstname|escape:'htmlall':'UTF-8'} {$lastname|escape:'htmlall':'UTF-8'}"
                        data-color="{$overlay_color|escape:'htmlall':'UTF-8'}">
                    Pay Now
                </button
            </div>

 

 

και έκανα αλλαγή μόνο στο data-reference:

 

<div>
                <button id="simplify-hosted-payment-button"
                        data-sc-key="{$simplify_public_key|escape:'htmlall':'UTF-8'}"
                        data-name="{$hosted_payment_name|escape:'htmlall':'UTF-8'}"
                        data-description="{$hosted_payment_description|escape:'htmlall':'UTF-8'}"
                        data-reference="19791"
                        data-amount="{$hosted_payment_amount}"
                        data-operation="create.token"
                        data-customer-name="{$firstname|escape:'htmlall':'UTF-8'} {$lastname|escape:'htmlall':'UTF-8'}"
                        data-color="{$overlay_color|escape:'htmlall':'UTF-8'}">
                    Pay Now
                </button
            </div>

 

Αλλά στο διαχειριστικό περιβάλλον της τράπεζας δεν εμφανίζεται το data reference

Share this post


Link to post
Share on other sites

  • 3 months later...

Προσπαθώ να ρυθμίσω το module χωρίς επιτυχία εδώ και 2 μέρες.Ούτε εγώ βλέπω το data-reference που βάζω!  Έχω prestashop 1.6.1.24. Αγαπητέ/ή orbitaga έχεις βγάλει άκρη? Επίσης δε γίνεται να μην τραβάει καθόλου το όνομα ( ούτε ελληνικά ούτε με λατινικούς χαρακτήρες ) και να το γράφει ο πελάτης μόνος του? Σε sanbox δε βγάζει πεδία full name και email address. Έτσι ήταν και σε σένα?

Share this post


Link to post
Share on other sites

On 8/22/2020 at 6:31 PM, dchronis said:

Προσπαθώ να ρυθμίσω το module χωρίς επιτυχία εδώ και 2 μέρες.Ούτε εγώ βλέπω το data-reference που βάζω!  Έχω prestashop 1.6.1.24. Αγαπητέ/ή orbitaga έχεις βγάλει άκρη? Επίσης δε γίνεται να μην τραβάει καθόλου το όνομα ( ούτε ελληνικά ούτε με λατινικούς χαρακτήρες ) και να το γράφει ο πελάτης μόνος του? Σε sanbox δε βγάζει πεδία full name και email address. Έτσι ήταν και σε σένα?

Φίλε μου dchronis

Αφου παιδεύτηκα κανα 10ημερο , επικοινώνησα με την τράπεζα και αφού μου υποσχέθηκαν οτι θα το κοιτάξουν δεν πήρα πίσω απάντηση ποτέ! Ούτε στα τηλέφωνα μπορούσα να τους βρώ.

 

Τελικά έκανα άιτηση στην Alpha bank και αγόρασα το αντίστοιχο presta module και με κανα 2 κλίκ όλα δούλεψαν όπως έπρεπε.

 

ps. Ναι και σε εμένα σε sandbox mode δεν εβγαζε full name και email address.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More