Jump to content

Recommended Posts

Bonjour à tous,

prestashop 1.7.6.4  comment faire pour recevoir un mail (le marchan) lorsqu'un client passe une commande (le client reçois bien pas de probléme) ? Le module Alertes par e-mail semble ne plus fonctionner sur cette version.

Je ne trouve même plus le module en téléchargement dans les ad on.

Est-ce que quelqu'un a une solution ?

merci

Share this post


Link to post
Share on other sites

Merci lagui, est ce que tu sais pourquoi il ne fontionne pas avec la version 1.7.6.4 ?

 

Share this post


Link to post
Share on other sites

Pour ma part je l'ai testé recemment sur un 1.7.6.4 et il fonctionne.

Peut-être ta boite mail qui passe en spam.

Share this post


Link to post
Share on other sites

Ha, bizzare, non pourtant c'est pas dans le spam. Je vais essayer avec la version que tu viens de m'indiquer sur gitub, peut-être que celle que j'ai n'est pas la dernière, c'est la 2.1.1

Share this post


Link to post
Share on other sites

ha, ben je viens d'essayer, il veut pas m'installer le module, il me dit "Ce fichier ne semble pas être un fichier .zip de module valide." Une idée d'où ça peut venir ?

Share this post


Link to post
Share on other sites

La 2.1.1 est la version actuelle.

Share this post


Link to post
Share on other sites

Il faut enlever "-master" du nom de dossier dans l'archive si tu l'as pris Github

Share this post


Link to post
Share on other sites

Bon, ben alors le probléme vient d'ailleur 😕

Share this post


Link to post
Share on other sites

Je viens de renommer le fichier, mais ça refuse toujours de s'installer. Soit je suis une quiche, (ce qui est probable) soit aujourd'hui ça veut vraiment pas 😕

 

Share this post


Link to post
Share on other sites

tu as bien renommé le dossier dans l'archive et non l'archive ?

Share this post


Link to post
Share on other sites

ha non :) j'ai renomer l'archive, merci, je vais essayer ça

Share this post


Link to post
Share on other sites

Bon, l'installation se passe bien, le probléme était bien de renommer le dossier a l'interrieur de l'archive, pas de probléme, paramétrage sans soucis, mais aucun mail ne m'est envoyer lors d'une commande 😕

 

Share this post


Link to post
Share on other sites

Ha ben, en fait je vient de voir dans les log d'envois de mail, les mails partent bien, mais ils n'arrivent jamais !

Share this post


Link to post
Share on other sites

je vais tester ça merci. surtout que là, j'ai plus aucun mail qui ne s'envois depuis que je viens d'installer ce module. Alors que ça marché avant :(

Share this post


Link to post
Share on other sites
il y a 30 minutes, wd26 a dit :

plus aucun mail

C'est à dire ?

Share this post


Link to post
Share on other sites
Posted (edited)

avant quand un client passait une commande, il recevait un mail, là, ça ne marche plus. Je viens de désactiver le module, mais ça semble poser quand même des probléme. D'aprés, le testeur de mail, ça serait parce que j'utilise un gmail. Mais avant ça marchait quand même avec la gmail. J'ai donc testé en modifiant et en mettant une fausse adresse mail d'envois de type contact@nomdedomaine, et là ça envois le mail au client.

😕 c'est un peu la merdasse. Je me demande si gmail me bloque pas un peu pensant que j'utilise le mail pour du spam. Pourtant rien n'arrive dans la boite de spam

/*****************/

Bon finalement, mon probléme d'envois de mails pour les commande au client, n'était pas dû a gmail, mais plutot à mon hebergeur, j'avais changer mon adresse mail de depart, voila pourquoi ça n'envoyait plus les mail au client.

Probablement parce que j'ai un mail différent de celui utiliser pour le nom de domaine ? je sais pas, je vais faire des tests.

 

Edited by wd26 (see edit history)

Share this post


Link to post
Share on other sites

bon, finalement aprés recherche, je viens de trouver sur ce forum que le module alert mail ne fonctionne que jusqu'a la version prestashop 1.7.2 ma version est donc trop récente. Est-ce que quelqu'un connait un autre module pour recevoir une alerte mail lors d'une commande client ?

Merci

Share this post


Link to post
Share on other sites

Non il fonctionne bien sur ma 1.7.6.5, il faut aller dans le BO > Modules catalog > Barre de recherche > Alertes par e-mail 

Sil n’est pas trouvé c’est qu’il est peut être déjà installé, vérifier dans BO > Modules Manager > Barre de recherche > Alertes par e-mail

 

7D600807-EA9D-4845-816A-BB50F48896AA.jpeg

Share this post


Link to post
Share on other sites

Je confirme il fonctionne très bien, je pense qu'il y a confusion avec l'ancien mailalerts

Share this post


Link to post
Share on other sites

Bon ben je ne comprends pas pourquoi ça fonctionne pas chez moi, pourtant tout semble bien parametrè. 

Pourtant je testé avec avec d'autres sites, même problème 🤔

Share this post


Link to post
Share on other sites
Posted (edited)

Le module doit être configuré pour activer les envois de mail.

410986097_Capturedecran2020-05-17a13_03_55.thumb.png.e05faa2c280d648ac2a904ecfb07f633.png

----------------------------------------------------------------------------------------------------------------------------------------

 

Ce sont vos paramètres d'email qui sont incorrects dans BO > Paramètres avancés > Emails

Voici comment obtenir un rapport pour déterminer si votre configuration pour envoyer des emails est correcte :

Dans l'administration de Prestashop : Paramètres avancés > Emails

Envoyer un email de test à l'adresse que vous indique cette page : https://www.mail-tester.com/

Si le service reçoit votre email de test, il vous proposera un rapport pour vous aidez à identifier les problèmes et proposer des solutions comme la mise en place de SPF et DKIM.

Si le service ne reçoit pas votre email de test, c’est que votre hébergeur a désactivé vos envois de mail ou que votre serveur est blacklisté probablement à cause d’une vague de spam réalisée depuis votre site. Par exemple si vous constatez beaucoup de faux comptes clients ou que votre formulaire de contact génère pleins de messages. Prenez alors contact avec votre hébergeur.

Edited by Janett (see edit history)

Share this post


Link to post
Share on other sites

Merci Janet pour ces explications. 

L'envoie de l'email de test se fait bien. Mail tester m'affiche des erreurs parce que c'est un Gmail. Peut être que la solution serait de passer par le smtp au lieu de l'envoie par php, mais ça fait modifié la sécurité de Gmail, ce qui est un peu embêtant. 

Je vais tester avec un mail autre que Gmail, on verra bien. 

Merci en tout cas à tous du temps que vous prenez pour me répondre. 

Share this post


Link to post
Share on other sites
Posted (edited)

Il ne faut pas utiliser gmail, tu dois utiliser une adresse e-mail avec le même domaine que ta boutique sinon tu seras considéré comme spam.

Ton hébergeur doit sûrement te permettre de créer une adresse e-mail avec ton nom de domaine 

Edited by Janett (see edit history)

Share this post


Link to post
Share on other sites

C'est ce que je pensais aussi. Je vais essayer avec ça. Merci 

Share this post


Link to post
Share on other sites

Es recomendable siempre configurar smtp para envíos de correos 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More