Jump to content
Mauvais

Error al actualizar PrestaShop con Click Upgrade

Recommended Posts

Hola, nunca me había pasado hasta ahora, estoy intentado actualizar el PS de 1.7.6.1 a 1.7.6 stable - (1.7.6.5), es una pequeña actualización. Y me da el siguiente error:

 

spacer.png

Leyendo algunos otros errores parecidos he aumentado algunos valores como el memory limit a 512 y he borrado algunos modulos que no usaba y demas, pero persiste el error. A ver si alguien puede echarme una mano, gracias!! 

 

Share this post


Link to post
Share on other sites

Si descartaste todas la posibles opciones de incompatibilidad de módulos externos, debes considerar la posibilidad de incompatibilidad PHP en las diferentes versiones opcionales que se encuentran disponibles en la configuración de tu servidor web. Recientemente encontré incompatibilidad de  Prestashop 1.7.6.5 en un servidor instalado con PHP 7.3.5 que se resolvió con la configuración PHP 7.3.3, si tu servidor no tiene la opción de selección entre las versiones PHP 7.3.XX, deberías descender a la versión 7.2.xx. La perdida de velocidad del 9% en las versiones 7.2.xx no es significativa y con seguridad te resultara mucho mas estable.

Share this post


Link to post
Share on other sites
21 minutes ago, jorgerg said:

Si descartaste todas la posibles opciones de incompatibilidad de módulos externos, debes considerar la posibilidad de incompatibilidad PHP en las diferentes versiones opcionales que se encuentran disponibles en la configuración de tu servidor web. Recientemente encontré incompatibilidad de  Prestashop 1.7.6.5 en un servidor instalado con PHP 7.3.5 que se resolvió con la configuración PHP 7.3.3, si tu servidor no tiene la opción de selección entre las versiones PHP 7.3.XX, deberías descender a la versión 7.2.xx. La perdida de velocidad del 9% en las versiones 7.2.xx no es significativa y con seguridad te resultara mucho mas estable.

Acabo de probar y nada. :S

Share this post


Link to post
Share on other sites

Intenta borrar cache:

1. backoffice > Parámetros Avanzados > Rendimiento > borrar cache

2. backoffice > Parámetros Avanzados > Rendimiento  > Smarty > NO

3. tu ordenador > varia según el navegador:

vaciar la caché por completo:  teclas  Ctrl + ⇧ Mayús + Supr

Recargar una página y limpiar su caché:

Windows y Linux:  Ctrl + F5

Windows y Linux:  Ctrl + Shift + R

 

Si todo ello falla, te espera un largo camino de investigación (configurracion servidor web, modulo incompatible, etc.), en cuyo caso te recomiendo permanerce en la versión 1.6 y actualizarla a la ultima versión estable

Share this post


Link to post
Share on other sites

Olvidaba borrar cache CCC:

2. backoffice > Parámetros Avanzados > Rendimiento  > SCCC > NO - NO - NO

Share this post


Link to post
Share on other sites
24 minutes ago, JavierP said:

Comprueba que de verdad se esta cambiando el parametro de la "memory_limit" del php info,

Si esta correcto prueba, con este modulo de Vekia, para limpiar un poco la BD de conexiones y carritos

https://mypresta.eu/modules/administration-tools/database-optimization.html

Y nos comentas como te a ido... :)

 

spacer.png

 

spacer.png

así aparece la configuración, probé a instalar el modulo y limpiar pero al actualizar persiste el error.

Probé a desinstalar también el modulo click upgrade y al reinstalarlo me aparece esto:

spacer.png

No sé si esto os dice algo, yo no tengo mucha idea 😕 Gracias!

 

Share this post


Link to post
Share on other sites
Posted (edited)
hace 38 minutos, Mauvais dijo:

spacer.png

 

spacer.png

así aparece la configuración, probé a instalar el modulo y limpiar pero al actualizar persiste el error.

Probé a desinstalar también el modulo click upgrade y al reinstalarlo me aparece esto:

spacer.png

No sé si esto os dice algo, yo no tengo mucha idea 😕 Gracias!

 

aquí te dice que un requerimiento de prestashop no lo satisface ajja, dale a "See details" haber que te dice...

Por cierto en la foto de Información de prestahop si te das cuenta en el limite de memoria no te pone los 512M...

 

 

Edited by JavierP (see edit history)

Share this post


Link to post
Share on other sites

Imagino que es simplemente para que lo leas si o si y después ignores.

Share this post


Link to post
Share on other sites

Vale si por eso, puedes bajar a la versión de PHP 7.1? haber si te sucede lo mismo?

As visto lo que te e dicho que en la primera foto, en la pestaña >Parámetros Avanzados>información> no tienes cambiado el Memory_limit, hay sale 128M y no los 512M que habías puesto...

Share this post


Link to post
Share on other sites
4 hours ago, JavierP said:

Vale si por eso, puedes bajar a la versión de PHP 7.1? haber si te sucede lo mismo?

As visto lo que te e dicho que en la primera foto, en la pestaña >Parámetros Avanzados>información> no tienes cambiado el Memory_limit, hay sale 128M y no los 512M que habías puesto...

Nada, modifiqué el archivo config.inc.php y ya sale a 512m, pero el problema persiste, no sé que estará fallando :S

Share this post


Link to post
Share on other sites

Hola, 
voy a dejarle mi opinión personal acerca de las actualizaciones.

Nunca es recomendable actualizar una web con módulos, para solo cambiar la versión del sistema, debido a muchos factores de configuración avanzada.
Siempre que quieras actualizar tu versión de prestashop por las mejoras sustanciales que siempre hay en cada versión, se recomienda una instalación limpia,
y sólo usar módulos en la nueva instalación para cargar o copiar data (información de clientes, productos, categorías, marcas, etc..).

Puedo darte una lista detallada de todos los errores que te encontraras y al diferente funcionamiento que tendrá tu web a partir de ahora (nunca igual como lo pensaste),
y pues tienes dos opciones, o seguir con la corrección de errores o no perder el tiempo y hacer una instalación limpia.

Yo siempre estoy dando recomendaciones, configuraciones y módulos en mi canal de Prestademia, y sin ánimos de confrontarme con cada opinión,
puedo decirte todo esto. 
Estoy muy convencido de sacar algún video sobre actualizaciones, pero por ahora puedo darte este consejo.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More