Jump to content
  • 0

Warenkorb "Marke" falsche Übersetzung


Question

Hallo,

 

mir ist ein Fehler im Warenkorb aufgefallen. Die enthaltene Mehrwertsteuer wird in Version 1.7.6.4 als "Marke" übersetzt.

In den Übersetzungen selbst ist allerdings kein Fehler. Ich vermute, dass hier im Code eine falsche Variable aufgerufen wird:

 

{block name='cart_summary_tax'}
    {if $cart.subtotals.tax}
      <div class="cart-summary-line">
        <span class="label sub">{l s='%label%:' sprintf=['%label%' => $cart.subtotals.tax.label] d='Shop.Theme.Global'}</span>
        <span class="value sub">{$cart.subtotals.tax.value}</span>
      </div>
    {/if}
  {/block}

</div>

Ist es möglich dies selbst zu beheben?

 

Edited by Kötters UG (see edit history)

Share this post


Link to post
Share on other sites

37 answers to this question

Recommended Posts

  • 0

Ja, in beidem ist die Übersetzung korrekt. Ich glaube anhand des Codes der Seite selbst aber, dass hier einfach nicht die Übersetzung von "tax included", sondern "label" aufgerufen wird.

Share this post


Link to post
Share on other sites
  • 0

Welche Übersetzungen hast du geprüft? Presta verwendet hier entweder "Included taxes" oder "Taxes" aus Shop.Theme.Checkout

grafik.png.77b8d5935b2f6178ddb75698854443c6.png

Share this post


Link to post
Share on other sites
  • 0

Wo soll man ansetzen, normal ist das Problem ja offenbar nicht. Verwendest du das classic- oder ein Fremdtheme? Sicherheitshalber (obwohl ich mir da einen Zusammenhang eigentlich nicht vorstellen kann) welche PHP-Version? Hattest du die Übersetzungen schon einmal bearbeitet? Welche Übersetzungen hast du jetzt überprüft (ich kenne mich mit dem neuen Übersetzungssystem jetzt nicht aus, aber auf deinen Screenshots fällt mir auf, dass "ShopThemeCheckout" eher nicht paßt, der Checkout ist das was im Screenshot von JBW zu sehen ist (stimmt da die Übersetzung?).

Share this post


Link to post
Share on other sites
  • 0

Ich hoste Prestashop über 1&1 IONOS

Ich nutze das classic theme ohne Anpassungen durch Drittanbieter oder ähnliches.

PHP Version: 7.2.30

Ja ich habe andere Begriffe bereits über die Funktion "Übersetzungen" aus dem Backend verändert und dort klappt es auch. Ja der Screenshot zeigt nicht direkt den Checkout, aber der Fehler zieht sich vom Warenkorb bis zum Checkout durch.

Ich habe folgende Funktion genutzt:

grafik.thumb.png.dd920c42d2b88696ac3e56f22dd524b6.png

Und zusätzlich folgende Datei überprüft:

./app/Resources/translations/de-DE/ShopThemeCheckout.de-DE.xlf

 

Edited by Kötters UG (see edit history)

Share this post


Link to post
Share on other sites
  • 0

Da muß wohl jemand ran, der sich mit dem seltsamen neuen Übersetzungssystem von Prestashop 1.7 auskennt ...

Hast du mal auf einer Shopkopie auf Festplatte z. B. mit Notepad++ die Übersetzungsdateien nach "Marke" durchsucht? Mal unter Leistung alle Fremdmodule und Overrides deaktiviert?

Share this post


Link to post
Share on other sites
  • 0

Eine Shopkopie genauso wie eine Datenbankkopie sollte man spätestens erstellen, sowie der Shop läuft und vor allem letzteres dann regelmäßig.

Share this post


Link to post
Share on other sites
  • 0

Der Popup gehört zum Warenkorb Module.    Wird also durch .../themes/classic/modules/ps_shoppingcart aufgerufen.  Da sollte der Code (etwas) anders aussehen.

Vielleicht findet sich hier etwas.

Share this post


Link to post
Share on other sites
  • 0

Habe ich mir angeschaut, dort findet sich folgender Code:

{if $cart.subtotals.tax}
                <p class="product-tax">{l s='%label%:' sprintf=['%label%' => $cart.subtotals.tax.label] d='Shop.Theme.Global'}&nbsp;<span class="value">{$cart.subtotals.tax.value}</span></p>
              {/if}

Das hatte ich am Anfang des Beitrags ja schon mal erwähnt, dass mich hier die Variable %label% iritiert. Denn "Label" wurde ja als Übersetzung zu "Marke" passen.

Vermutlich lade ich mir mir am besten mal eine aktuelle Version von Presta separat runter und vergleiche diese Inhalte.

Share this post


Link to post
Share on other sites
  • 0

label ist keine Variable, Variablen fangen mit einem Dollar-Zeichen an.

Nochmal, wenn sich der Fehler an unterschiedlichen Stellen im Shop findet, kann es nicht am Code der Seiten liegen. Aber deaktiviere sicherheitshalber mal das Rechtssicherheitsmodul, nicht daß die entsprechenden Texte alle von diesem kommen. Sinnvoll wäre auch ein Link zum Shop, dann muß man nicht nur raten, wo genau der Fehler denn nun auftritt.

Share this post


Link to post
Share on other sites
  • 0

ah, mal so als Info.   Ist das ne neu Installation, Update ..... ?    Wenn neu - war der Fehler gleich da? nach installieren eines Modules? einer Aenderung?

Share this post


Link to post
Share on other sites
  • 0

Gerade mal im Demo-Shop geschaut, der Zusatz findet sich dort nicht und er paßt auch nicht richtig ins Design, kommt also von einem Modul, entweder vom Rechtssicherheitsmodul oder du hast noch ein anderes. Dann finden sich auch die Übersetzungen in denen für das Modul.

Share this post


Link to post
Share on other sites
  • 0

Nee, ist leider keine modulspezifische CSS-Regel. Da es kein Fremdmodul zu sein scheint, suche mal nach dem Rechtssicherheitsmodul (Legal Compliance) und deaktiviere es, ggf. lösche Caches und schau, ob die Zeile noch da ist. Oder schau gleich in den Modul-Übersetzungen.

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites
  • 0

42 Ware

5 Versand        +

----------------------------

= 47 da steht 47 ist Gesamt inklusive MwSt

aber MwSt wird nicht dazu gerechnet, vermutlich ist "Marke 7,51" verirrter MwSt das nicht dazu gezählt wird, vermutlich liegt es an den MwSt Einstellungen

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites
  • 0

7,51 € ist die in den 47,00 € enthaltene MwSt., das stimmt so schon, ist bei JBW ja auch so (aber nicht mit dieser falschen Übersetzung).

Bei Prestashop ist eigentlich immer nur von Herstellern, nicht von Marken die Rede, deshalb sollte dieser Begriff bei einer Dateisuche (wie von mir vor längerer Zeit bereits vorgeschlagen) eigentlich allenfalls vereinzelt auftauchen. Ich nehme an, daß es sich um eine Übersetzung handelt, die die an anderer Stelle überschreibt.

Share this post


Link to post
Share on other sites
  • 0

Vielen Dank für die ganzen Rückmeldungen. Das Modull Rechtssicherheit (habe es deaktiviert) ist es nicht und ich habe bisher in keinem Modul eine entsprechende Übersetzung gefunden.

Die Einstellung nehme ich hier vor:

grafik.thumb.png.7606a42eab8dc14263567055ae708736.png

Somit sollte es doch eine Standarfunktion sein oder? Rictools meinte ja weiter oben, dass es im Demo Shop nicht enthalten ist und er deswegen auf ein Modul tippen würde.

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, Kötters UG said:

Habe ich mir angeschaut, dort findet sich folgender Code:

{if $cart.subtotals.tax}
                <p class="product-tax">{l s='%label%:' sprintf=['%label%' => $cart.subtotals.tax.label] d='Shop.Theme.Global'}&nbsp;<span class="value">{$cart.subtotals.tax.value}</span></p>
              {/if}

Das hatte ich am Anfang des Beitrags ja schon mal erwähnt, dass mich hier die Variable %label% iritiert. Denn "Label" wurde ja als Übersetzung zu "Marke" passen.

Vermutlich lade ich mir mir am besten mal eine aktuelle Version von Presta separat runter und vergleiche diese Inhalte.

Ich habe die Ursache gefunden. Es war wie vermutet %label%, was hier scheinbar doch eine Variable ist.

grafik.png.8dd3d7250fe7b35997924103a2a8dd99.png

Zu finden unter Übersetzungen -> Theme -> Global

Share this post


Link to post
Share on other sites
  • 0

 

vor 53 Minuten schrieb Kötters UG:

Somit sollte es doch eine Standarfunktion sein oder? Rictools meinte ja weiter oben, dass es im Demo Shop nicht enthalten ist und er deswegen auf ein Modul tippen würde.

Du hast recht, die Einstellung MwSt. im Warenkorb anzeigen (die es so in meinem 1.6 auch gibt) war mir jetzt nicht bekannt und im Demoshop ist sie deaktiviert. Aber das Übersetzungssystem hat sich in 1.7 grundlegend geändert, damit kenne ich mich nicht aus. Irgendwo muß das Wort "Marke" aber herkommen und das müßte man halt mit einer Textsuche über alle Shopdateien herausfinden können.

Alternativ könntest du natürlich die Anzeige der MwSt. im Warenkorb einfach abschalten, erforderlich ist sie m. E. nicht.

Share this post


Link to post
Share on other sites
  • 0

Wenn das das 'leere' label ist, - die erste Übersetzung unter Theme - Global - dann läuft da was richtig schief.

Wenn das ne neu Installation ist und das gleich so war ist das ein mega grosses Stop Schild.

Die "jetzt und hier" Übersetzung kommt aus einer cache Datei - die nimmt sich die Übersetzung aus dem BO (die richtige Stelle - nicht das %label%), nicht aus der ..../ShopThemeCheckout.de-DE.....

Die cache Datei zeigt in Richtung catalogue.de-DE........php

 

Share this post


Link to post
Share on other sites
  • 0
vor 15 Minuten schrieb Kötters UG:

Die Anzeige der enthaltenen MwSt. ist in Deutschland gesetzlich vorgeschrieben.

Das wäre mir neu, du mußt im Shop den Hinweis auf die enthaltene MwSt. anzeigen, meines Wissens aber weder den Prozentsatz noch den Betrag.

Share this post


Link to post
Share on other sites
  • 0

Wie weiter oben schon erwähnt, hoste ich meinen Shop über 1&1 IONOS. Es gibt da eine offizielle Kooperation mit Presta.

Man installiert den Shop dort nicht selbst, sondern bekommt ein fertiges Template von 1&1 gestellt. Dabei handelt es sich dann vermutlich um eine Sonderversion, in der sich dieser Fehler eingeschlichen hat. Ich habe den Shop schon mehrfach neu aufgesetzt und dieses Problem bestand dann immer wieder.

Ja du hast Recht, den genauen Betrag muss man tatsächlich nicht ausweisen.

Share this post


Link to post
Share on other sites
  • 0
vor 9 Minuten schrieb Kötters UG:

Wie weiter oben schon erwähnt, hoste ich meinen Shop über 1&1 IONOS. Es gibt da eine offizielle Kooperation mit Presta.

Nicht alle Hoster bieten die CMS Kostenlos an obwohl das CMS kostenlos ist, man muss genauer hinschauen oder das kleingedruckte lesen,

deshalb ich Lade und  installiere immer selber

Share this post


Link to post
Share on other sites
  • 0
19 hours ago, Kötters UG said:

Ich habe die Ursache gefunden. Es war wie vermutet %label%, was hier scheinbar doch eine Variable ist.

Ja natürlich ist es eine Variable, wie diese durch die entsprechende Übersetzung gefüllt wird habe ich ja oben bereits gepostet. D.h. für die Vaiable an sich darf keine Übersetzung gespeichert sein, stand da bei dir "Marke". Wenn ja ist das sehr seltsam, so wir Prestashop auf keinen Fall ausgeliefert.

Also nochmal, dies hier sind die richtigen Übersetzungen:

Das %label% leer

grafik.png.c6f21550276df6bae42e875ab472a3ae.png

Und die entsprechende Übersetzung mit der es gefüllt wird:

grafik.png.578fceb22b469bb5082da7b02814a5c4.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More