Jump to content
rs-prestadev

Erreur 500 en local sur Xampp - Link to database cannot be established

Recommended Posts

Posted (edited)

Bonjour à tous,

Je développe un thème Prestashop (1.7.6) en local via Xampp (Windows), tout fonctionnait bien jusqu'à hier quand j'ai redémarré le serveur. Je ne peux plus accéder au site (front ou admin), j'obtiens l'erreur 500 suivante:

Link to database cannot be established: SQLSTATE[HY000] [1044] Access denied for user 'prestashop'@'%' to database 'prestashop'
at line 127 in file classes/db/DbPDO.php

La seule chose que j'avais modifié la veille était de configurer des produits dans l'admin. Jusqu'à cette erreur, tout fonctionnait correctement. J'ai néanmoins vérifié mes paramètres de base de donnée dans parameters.php, tout semble normal. J'ai également fait pas mal de recherches Google, sans succès. 

Quelqu'un aurait-il une idée ?

Merci

 

Edited by rs-prestadev (see edit history)

Share this post


Link to post
Share on other sites

Donc je ne sais pas en même temps cela ne semble pas être un soucis PrestaShop mais un soucis XAMPP, donc peut être trouverez vous plus de support sur leur forum.

PS:  avis personnel, je ne comprendrais jamais le choix de développer en local ???

Share this post


Link to post
Share on other sites
Citation

Link to database cannot be established: SQLSTATE[HY000] [1044] Access denied for user 'prestashop'@'%' to database 'prestashop'

Donc a priori ta base de données ou ton utilisateur prestashop n'existe pas (ou plus) ou bien encore le mot de passe n'est pas le bon

Share this post


Link to post
Share on other sites

J'ai vérifié les logins, tout concorde (+ je n'ai rien changé entre le moment où ça marchait et maintenant), je pencherais plutôt pour "la bdd est cassée", mais je ne vois pas trop commun le diagnostiquer

image.png.ecf1390ac21b21b8bd5c9150738b0e7b.png

image.thumb.png.b26bb379306e13d0306f9ed2d54596c1.png

Share this post


Link to post
Share on other sites

au lieu de tester avec ton user root sur ton phpmyadmin tente avec ton utilisateur prestashop

 

Share this post


Link to post
Share on other sites
4 minutes ago, doekia said:

au lieu de tester avec ton user root sur ton phpmyadmin tente avec ton utilisateur prestashop

 

Je ne suis pas sûr de comprendre, que me conseilles-tu de faire exactement ?

Merci!

 

Share this post


Link to post
Share on other sites

OK j'ai testé en paramétrant le user root à la place de prestashop et ça marche...

Quand je vérifie les privilèges du user prestashop dans phpmyadmin, je tombe sur cette erreur MySQL, est-ce la source de mon problème ? D'où est-ce que ça peut venir ? Comment le régler ?

Merci

image.thumb.png.9c342d94d06996772a49f8e5b8e17014.png

Share this post


Link to post
Share on other sites

Que ta base de données est corrompu.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More