Jump to content
EQLAT

perte totale de mon site apres tentative de mise à jour

Recommended Posts

Bonjour à tous

J'ai acheté un module CM-CIC module pour paiement CB

Au moment de le télécharger, on me demande la version de mon site.

Mon site est très vieux, car j'ai toujours eu peur justement de perdre des notions lors des upgrade.

Cette fois ci je m'execute, n'ayant semble t'il pas le choix.

Je fais une sauvegarde auparavant comme conseillé.

A la fin du processus de mise à jour, presta me signale une erreur mais me propose de télécharger une version .

Je m'execute et ...

je suis renvoyée sur la page de connexion de panneau d'admin.

mon identifiant n'est plus reconnu, et mon site est fermé.

J'ai vraiment , vraiment besoin de votre aide SVP

 

Share this post


Link to post
Share on other sites

Bonjour,

vous ne donnez pas assez de précision pour que l'on puisse vous aider.

restaurez l'ancienne version avec la sauvegarde effectué avant toute mise à jour comme cela est préciser partout tout le temps.

Puis faite votre mise à jour en vous appuyant sur des test probant et surtout faite tout cela sur une copie de votre site.

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, EQLAT said:

Bonjour à tous

J'ai acheté un module CM-CIC module pour paiement CB

Au moment de le télécharger, on me demande la version de mon site.

Mon site est très vieux, car j'ai toujours eu peur justement de perdre des notions lors des upgrade.

Cette fois ci je m'execute, n'ayant semble t'il pas le choix.

Je fais une sauvegarde auparavant comme conseillé.

A la fin du processus de mise à jour, presta me signale une erreur mais me propose de télécharger une version .

Je m'execute et ...

je suis renvoyée sur la page de connexion de panneau d'admin.

mon identifiant n'est plus reconnu, et mon site est fermé.

J'ai vraiment , vraiment besoin de votre aide SVP

 

Bonjour,

 

En effet il nous faut l'erreur pour connaître précisément les détails : si votre site est vieux cela peut être absolument tout : modules qui ne sont plus compatibles,  version de mySQL trop vieille, version de PHP trop ancienne par rapport au pré-requis, etc...

Il nous faudrait : votre version presta actuelle après mise à jour, et votre version d'avant, ainsi qu'au minimum l'erreur qui était apparue

Comme dit par @Mediacom87, avant de faire de grosses mises à jour comme celle-ci, le mieux serait de tester ça sur un environnement de "preprod" (= un autre hébergeur avec la même configuration que celui que vous avez), car c'est toujours sensible.

Autre chose, si vous ne pouvez pas restaurer un backup de votre ancienne version : sur FileZilla, trouvez et activez le mode debug de Prestashop (vous cherchez cela sur Google "debug mode prestashop v1.*votre version*", videz le cache généré par prestashop (trouvable aussi sur Google).

https://www.prestasafe.com/mettre-prestashop-1-7-1-3-mode-debug

Malheureusement je ne peux vous aider sans votre version, mais si vous êtes passé en dernière, cf 1.7.6, alors c'est du Symfony. Donc :

- Vous pouvez en plus voir les erreurs qui ont été générées dans le fichier log ici : {racine}/var/logs/prod.log et nous les poster.


Vous pouvez toujours aussi essayer de debug à la main en commençant par mettre ceci au début de : {racine}/www/app/AppKernel.php (c'est le fichier principal par où tout passe) :


ini_set('display_errors', 1);

ini_set('display_startup_errors', 1);

error_reporting(E_ALL);


Puis ensuite continuer dans l'autoload etc.. mais c'est plus compliqué, il faut des connaissances. Je ne peux donc vous garantir un résultat. En gros, les 3 lignes ci-dessus sont la même chose que ce qui se passe lorsqu'on active le mode debug de Presta.

 

Enfin, dernière chose que vous pouvez tester : vous pouvez renommer les modules que vous avez installés en {nommodule}.old. Cela se situe ici :

{racine}/modules

Si le site marche, c'est que c'est un module qui plante, et dans ce cas vous les réactivez 1 par 1 jusqu'à ce que ça plante et vous aurez votre réponse.

Si le site ne marche pas avec 0 module, ou s'il n'y a pas d'amélioration, ou si l'erreur ne change pas, ça peut peut être aussi venir du serveur en lui-même (problème de pré-requis, surtout si votre site est vieux).


J'espère que cela vous aura aidé. Je ne poste pas beaucoup mais j'aide bien volontiers ;)

 

Edited by Immolare (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More