Jump to content

Recommended Posts

Posted (edited)

Bonjour,

Après mes recherches, je ne trouve pas solution à mon problème :

J'ai un produit que j'ai bien travaillé dans le backoffice, pour pouvoir le dupliquer ensuite.

Je n'ai pas fait de modifs ces derniers jours, et hier je veux retourner dans ce produit, et dès que je clique dessus pour aller dans la fiche produit = page blanche...

D'après mes recherches, j'ai fait :

-mode Debug activé : pas de message d'erreur

-réinitialisation de htacces

-nettoyage de prod.log

-nettoyage de cache/prod

Je continue mes recherches mais si vous avez des pistes, j'suis preneuse ! :)

Merci !

Edited by Nyfa68 (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

J'ai maintenant ce message :

image.thumb.png.e3bcfcaf478b2c9038e83c5abb5ce4db.png

Mais je ne trouve pas cette ligne rahhh !

Edited by Nyfa68 (see edit history)

Share this post


Link to post
Share on other sites

bonjour,

ce n'est pas dans un fichier Prestashop mais au niveau de la config PHP du serveur. Quel est l'hébergeur ? 

Share this post


Link to post
Share on other sites

en mutu ? alors il faut créer un fichier .ovhconfig à la racine du site (donc un point avant le nom du fichier et sans extension). Dedans il faut mettre

app.engine=php
app.engine.version=7.2 (par exemple, selon ta version de PS)
http.firewall=none
environment=production
container.image=stable
memory_limit = 600

et tester

Share this post


Link to post
Share on other sites

Merci pour ta réponse.

Je ne sais pas si c'est mutualisé, c'est une hébergement Perso tout simple. Comment puis-je savoir ?

J'avais déjà ce fichier .ovhconfig à la racine, et j'ai remplacé par le texte que tu m'as donné mais cela ne donne rien. Toujours page blanche.

J'avais eu un soucis au début avec ce produit. Il me demandait d'augmenter une valeur (je ne sais plus laquelle) et OVH ne pouvait pas le faire.

Donc j'ai rajouté un fichier .user.ini avec ça dedans :

max_input_vars = 19000

J'ai essayé d'augmenter la valeur pour voir mai rien n'y fait non plus...

Share this post


Link to post
Share on other sites

c'est mutualisé

le max_input_var a une valeur normalement suffisamment haute comme ça. Mais mettez-le dans le fichier .ovhconfig

Share this post


Link to post
Share on other sites

Je l'ai rajouté sur le .ovhconfig, en supprimant et en ne pas supprimant le fichier .user.ini dans admin...

Toujours page blanche 😕

 

Share this post


Link to post
Share on other sites

Dans le BO, page Informations, quelle est la limite de mémoire ?

Share this post


Link to post
Share on other sites

c'est quelle version de Prestashop ?

et la page Informations est dans l'admin de Prestashop 😉 dans Paramètres avancés

Share this post


Link to post
Share on other sites
Posted (edited)

Merci pour le GPS prestashop 😌

 

Version de PrestaShop : 1.7.5.1

Version du logiciel serveur : Apache

Version de PHP : 7.3.16

Limite de mémoire : 512M

Temps maximal d'exécution : 300

Taille max. pour envoi de fichiers : 128M

Edited by Nyfa68 (see edit history)

Share this post


Link to post
Share on other sites

de rien 😉

le fichier .ovhconfig est toujours tel que je l'avais envoyé ? avec PHP 7.2 ?

PS 1.7.5 n'est pas compatible 7.3.
Sur l' interface OVH, il faut mettre 7.2. Mais si c'était ainsi dans le .ovhconfig envoyé, on dirait qu'il n'est pas pris en compte. Ni d'ailleurs le memory_limit, ce qui explique que l'erreur est toujours là

Share this post


Link to post
Share on other sites

mon .ovhconfig

app.engine=php
app.engine.version=7.3
http.firewall=none
environment=development
container.image=stable

Share this post


Link to post
Share on other sites

J'ai modifié sur ovh en 7.2 et sur .ovhconfig, cela s'est modifié automatiquement...

Je n'ai pas de ligne memory_limit.

J'avais justement fait le test en le rajoutant etc mais ça n'avait rien changer.. et j'avais essayé avec plusieurs valeurs mais non plus 😕

Share this post


Link to post
Share on other sites

bonjour

dans le fichier .ovhconfig, essayez en ajoutant M à la valeur memory_limit (j'ai oublié de le taper)

par exemple :

memory_limit = 768M

Share this post


Link to post
Share on other sites

ça ne fonctionne pas 😕

J'ai essayé de rajouter dans le .user.ini que j'avais créé mais non plus.

J'avais créé un ticket chez ovh avant hier mais je n'ai toujours pas de réponse...

Ca commence à me rendre folle ^^'

Share this post


Link to post
Share on other sites

C'est étrange parce que selon les changements que je fais, parfois la page est blanche en erreur, parfois j'ai le message d'erreur que j'avais posté dans un de mes premiers posts...

Share this post


Link to post
Share on other sites

normalement, chez OVH, il suffit d'utiliser le .ovhconfig. 

Dans Préférences => Informations, est-ce que la nouvelle valeur de memory_limit est prise en compte ?

 

Pour OVH, pour le moment, c'est quasiment assistance 0 ! ils ne doivent pas pouvoir faire du dépannage en télétravail !!

Restons zen 😉 si vous voulez, je peux vous aider de façon plus concrète, si vous voulez bien me donner un accès FTP et au BO (en MP bien sûr).

Share this post


Link to post
Share on other sites

Pour le cas où d'autres rencontreraient ce souci :

Un seul produit était incriminé. En fait il avait 726 déclinaisons, ce qui était beaucoup trop pour la config OVH (hébergement perso). En augmentant les valeurs de memory_limit à 1024M, de max_input_vars à 30000, et en essayant avec max_execution_time à 900, la fiche produit est de nouveau visible.

Il y avait également des fichiers manquants dans l'installation (faite par OVH ... no comment) et un bug sur le vidage du cache, qui semble avoir été résolu également par l'augmentation des valeurs PHP.

Mais ce n'est qu'une solution provisoire, il faut penser à prendre un hébergement plus costaud ou à changer d'hébergeur ... (j'aime bien O2Switch qui ne se casse pas la tête avec de multiples offres, qui n'en a qu'une mais suffisamment dimensionnée pour Prestashop ... je n'ai pas d'actions chez eux !!)

Voilà, si c'est réglé, le sujet peut être passé en [RESOLU] (éditer le premier message et changer le titre)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More