Jump to content
PEGGY1233456

Fatal error: Uncaught exception 'Adapter_Exception'

Recommended Posts

Salut la compagnie,😀

Divers problÚmes avec OVh depuis un mois et j'ai du faire une réinstall d'une sauvegarde de mon site sur un nouveau serveur mais impossible d'entrer dans le backoffice j'ai cette erreur et j'avoue que je ne vois pas comment faire pour corriger, ni de quoi cela peut venir.

Fatal error: Uncaught exception 'Adapter_Exception' with message 'Service container is not set.' in /var/www/vhosts/pearlaccess.com/httpdocs/Adapter/Adapter_ServiceLocator.php:49 Stack trace: #0 /var/www/vhosts/pearlaccess.com/httpdocs/classes/ObjectModel.php(232): Adapter_ServiceLocator::get('Adapter_EntityM...') #1 /var/www/vhosts/pearlaccess.com/httpdocs/classes/shop/Shop.php(131): ObjectModelCore->__construct('1', NULL, NULL) #2 /var/www/vhosts/pearlaccess.com/httpdocs/classes/shop/Shop.php(400): ShopCore->__construct('1') #3 /var/www/vhosts/pearlaccess.com/httpdocs/config/config.inc.php(114): ShopCore::initialize() #4 /var/www/vhosts/pearlaccess.com/httpdocs/index.php(27): require('/var/www/vhosts...') #5 {main} thrown in /var/www/vhosts/pearlaccess.com/httpdocs/Adapter/Adapter_ServiceLocator.php on line 49

 

FeuđŸ˜Ș www.pearlaccess.com

version prestashop 1.6.1.19 php 5.6

Merci par avance de votre aide j'en ai vraiment besoin suis perdue et fatiguĂ©e! Prenez bien soin de vous en ces temps difficiles!! Good vibes!🙏

 

Share this post


Link to post
Share on other sites

Si vous avez accĂšs au ftp commencez par supprimer le fichier /cache/class_index.php

Share this post


Link to post
Share on other sites

Bonjour Eolia

Merci d'avoir pris du temps pour me rĂ©pondre. Malheureusement ça n'a rien changĂ© au message d'erreur . Si tu as une autre idĂ©e tu te doutes que je suis preneuses😊

Share this post


Link to post
Share on other sites

Perso dans ce cas là je commencerai par récupérer l'archive de Prestashop 1.6.1.19 et j'écraserais les fichiers core sur le ftp histoire de repartir sur des bases saines.

Share this post


Link to post
Share on other sites

Merci en retard Eolia! J'ai bien essayé et ça n'a rien j'ai changé la version pour une plus ancienne ce qui m'a permis de récupérer ce dont j'avais besoin et repartir sur un nouveau site tout propre et tout neuf est toujours pÎ fini!! Rires! Merci beaucoup (bis repetita) en tout cas d'avoir pris du temps pour me venir en aide et me donner des pistes!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More