Jump to content

PS17 - Problem ze slajderem w css w theme classic


przemko
 Share

Recommended Posts

Cześć,

Mam nadzieję, że ktoś będzie mi w stanie szybko pomóc, bo problem chyba nie jest trudny do rozwiązania, a jest irytujący dla osoby nie znającej się mocno na css.

Założyłem czystą prestę 1.7.6.3 i theme classic. Przepiąłem standardowy Slider do displayBanner, żeby był w pełnej długości ekranu. Są jednak pewne problemy, bo strona się trochę rozjeżdża. Pomożecie?

Problem 1: kiedy strona w przeglądarce jest węższa niż 1200px (a obrazek w slajderze jest nie większy niż 1182px), to nie ma problemu. Przy zmianie rozmiaru dobrze się skaluje i wszysto widać. Natomiast kiedy poszerzam przeglądarkę i obrazek w slajderze poszerza się na 1183px lub powyżej, to obrazek ze slajdera zaczyna chować się pod elementy menu, które są w poniżej (elementy z displayNav). Załączam obrazek przedstawiający "mały ekran" i "poszerzony ekran".

Problem 2: u dołu strony pojawił się pasek przewijania, który przewija tak naprawdę tylko kilka pikseli. To też jakiś efekt uboczny po wsadzeniu tego slidera do displayBanner.

Pomożecie mi proszę naprawić problem?

Co już robiłem:
- wyłączyłem cache, żeby mieć zawsze świeży widok, natomiast i tak czyszczę cache z poziomu admina w presta, na wszelki wypadek
- zmieniałem w theme.css height dla elementu carousel item z 340px na 440px, ale nie pomogło.

Będę wdzięczny za wszelką pomoc.

slider.thumb.jpg.e166cf9c27b400a4b5860da1552f6528.jpg

Edited by przemko (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More