Jump to content

Recommended Posts

Bonjour à tous, 🖐️ j'espère que vous vous portez bien en cette période difficile. ☺️

 

Voilà je vous expose mon problème, ça fait quelques jours que je remarque de plus ou moins grosses lenteurs sur le TTFB.

Pour ne rien vous cacher, le caractère aléatoire de ce problème me fait soupçonner une mise en cause de mon hébergeur Infomaniak...

Cependant, j'ai fais de nombreuses recherches pour m'assurer que ça ne venait pas de mon coté :

- J'ai regardé mes logs BO et apache, rien de spécial à signaler;

- J'ai désactivé tous les modules à l'origine de nombreux bugs et ralentissements;

- J'ai lancé un débug profiling et c'est la que les problèmes commences voilà mes résultats :

7253505_Capture8.thumb.PNG.56bd87736b595f9a6ea6022634e591bc.PNG

 

Je vois de mon œil novice deux gros problèmes, La taille et le timing de Initcontent et le nombre hallucinant de requêtes SQL.

Les requêtes sont toute des SELECT SQL_NO_CACHE. 

Il est à noter que j'utilise le module Page Cache Ultimate et que j'ai bien activé le cache natif de presta ainsi que CCC.

Je sollicite donc votre aide afin de savoir si je peux faire quelque chose pour régler les problèmes de lenteur.  

Site : https://heritage-design.fr/ sous presta 1.7.5

 

Un gros merci d'avance à ceux qui sauront m'aider 🙏

 

Xordixx.

Edited by xordixx
Ajout domaine site et version presta (see edit history)

Share this post


Link to post
Share on other sites

Ahhhh d'accord donc les 900 requètes sont des améliorations potentielles ? ça fait peur 😱!

Et sinon à tu vu quelque chose que je pourrai faire pour améliorer mon TTFB?

Merci pour ta réponse 😊

Share this post


Link to post
Share on other sites

Ok super ça me rassure, merci pour votre aide ! 

Je sais que j'abuse un peu mais du coup de quoi pourrai venir ma latence de TTFB  si ce n'était éventuellement pas le serveur ? 

J'ai vérifié tous les logs RAS,

Modules RAS

Tâches CRONS RAS

Le site est relativement rapide hors TTFB

Mon JS est peut être un peu lourd selon Pagespeed mais bon ça n'explique pas le caractère aléatoire des lenteurs...

Merci encore !!!! 😃 

Share this post


Link to post
Share on other sites

Voilà ce que j'ai de temps en temps :

1761668635_Capture5.thumb.PNG.b20110244f8e5c4ff5179efe64f40896.PNG

ça c'était cette nuit par exemple alors que actuellement tout va bien. 

ça se produit de manière totalement aléatoire et ça revient à la normale. 

Je n'ai pas essayé de désactiver le module de cache mais je l'ai depuis 1 an et je n'ai jamais eu de soucis.. à voir.

Edited by xordixx
Fautes (see edit history)

Share this post


Link to post
Share on other sites

Lors de la purge des caches, tout doit être regénéré (ceci est visible pour le 1er qui se connecte ensuite tout est une fusée)

Selon ton hébergement il peut survenir des lenteurs intermittentes

Et en ces temps de confinement, il arrive aussi qu'il y ai des lenteurs "réseau"

 

Share this post


Link to post
Share on other sites

Pour ce qui est du cache, lorsque je le purge j'utilise Wget pour faire un cache warmer histoire de facilité la vie de mes visiteurs.

J'ai un hébergement mutualisé chez infomaniak, je leur ai demandé d'investiguer 👀.

Bon j'imagine donc que mes problèmes de TTBF sont effectivement dues au serveur qui à des lenteurs mais bon en ce moment c'est vraiment récurent et ça devient pesant !

Donc pour vous j'ai juste à attendre que ça passe ? 

Je ne peu rien faire ? 

Share this post


Link to post
Share on other sites

Bonjour,

Je ne sais pas quel type de formule vous avez avec Infomaniak, mais étant moi-même consultant en support technique de plusieurs hébergeurs, je vous recommande, si vous y avez accès, d'activer le slow log de PHP-FPM : https://robertbasic.com/blog/php-fpm-slow-log/

C'est ainsi que moi, je débogue des dizaines de sites lents par jour.

Ceci affichera directement quelles fonctions PHP sont appelés par votre script et qui causent cette lenteur. Ainsi, on pourra distinguer facilement les parties du site, modules, ... concernés.

De mon point de vue, s'il n'y a pas de surcharge sur le serveur de l'hébergeur, il n'y a généralement aucune raison que la lenteur provient de ce côté.

Share this post


Link to post
Share on other sites

Bonsoir et merci de votre réponse, 

 

Le problème c'est que mon site n'est lent qu'a certaine période de la journée. D'ailleurs, dans mes logs d'erreurs apache, j'ai constaté ceci lors des lenteurs :

[Thu Apr 16 01:10:10.607894 2020] [:error] [pid 75869:tid 140636320171776] [client XX.XX.XXX.XXX:XXXX] FastCGI: server "/home/clients/XXXXXXXXXidclientXXXXXXXXXX/.config/apache/heritage-design.fr/.fpm/php5.external" stderr: PHP message: PHP Warning: PDO::query(): Error reading result set's header in /home/clients/XXXXXXXXXidclientXXXXXXXXXX/web/classes/db/DbPDO.php on line 156, referer: https://heritage-design.fr/

j'ai anonymisé l'ip et l'id client, je sais pas si c'est nécessaire mais dans le doute... 

Si je ne me trompe pas, ce genre d'erreurs PHP proviennent du coté serveur et pas du coté site..

Je serais bien plus inquiet si les lenteurs étaient constantes mais pas du tout, j'en ai quelques unes et elles dures quelques minutes au max une heure (sauf dimanche c'était toute la journée)... D'où mes doutes sur le serveur ! D'ailleurs au vu des différents posts sur internet je ne serais pas le seul..

QU'en pensez vous ? 

 

Merci encore,

xordixx

Share this post


Link to post
Share on other sites

  • 2 weeks later...
On 4/16/2020 at 7:04 PM, xordixx said:

D'acc, merci et ça induit quoi ? La vous m'avez traduit du russe en chinois 😅

Bonjour, je rencontre de gros soucis aussi ces derniers temps, comme vous. Avec un TTFB à plus de 30s parfois. Je n'arrive pas à comprendre pourquoi. Avez-vous eu des news concernant votre problème ?

Share this post


Link to post
Share on other sites

@OuiLudo ce serait bien d'ouvrir ton propre topic en fournissant les information pertinentes de ton site/problème

Par contre si tu es chez OVH, depuis 2 jours ils ont de serieux problème sur leurs filer. Ceci induit de fort ralentissement des sites mutus impactés

Share this post


Link to post
Share on other sites

Bonjour Doekia, merci pour ta réponse.

J'avoue que j'hésite toujours à ouvrir mon propre topic pour ne pas polluer par des topics similaires. J'en prends bien note.

Chez OVH, ils me soutiennent que ça ne vient pas de chez eux. Je crois que c'est un peu une habitude chez eux.

Share this post


Link to post
Share on other sites

Bonjour @OuiLudo,

Alors pour ma part, après avoir tout essayé j'ai mis un bon coup de pression à mon Hébergeur (Infomaniak).

Dès le lendemain j'étais au top... 

Ils ont investigué et on trouvé "de nombreuses connexions chinoises sur mon site". 

J'ai un peu de mal à y croire étant donné que j'ai décortiqué touuuuuus mes logs et que je n'ai rien vu de tout ça.

Je pense en réalité que comme tout les hébergeurs ils se cachent derrière des infos bidons.

Quoi qu'il en soit, "les connexions on été bloquées par notre équipe" m'ont ils dit. 

Voilà voilà malheureusement je n'ai pas vraiment de solution... Je vous conseil quand même de checker les logs, avec le corona il y a une grosse recrudescence de bots toutes origines confondues.

Ah oui et pourquoi pas changer d’hébergeur 😅 OVH c'est po terrible...

Bon courage ! 

xordixx

Share this post


Link to post
Share on other sites

Salut xordixx !

Oui, effectivement, les hébergeurs et la transparence de leurs infos, c'est vraiment pas terrible. Jusqu'à présent, je n'avais jamais été trop ennuyé avec OVH, je gérais peu de site, c'est sûr aussi. Mais là, je suis assez déçu par leur manière de faire. J'ai, comme vous, passé énormément de temps à décortiquer les infos, isoler les problèmes pour finalement avoir passé 2 jours à ne rien trouver. Juste avant de répondre à Doekia, j'étais en train de faire un petit test comme ça, juste pour voir : J'ai envoyé ma boutique complète sur un autre cluster de chez OVH, d'un autre hébergement chez eux, ça marchait impec ! Comme quoi…

Sinon, vous avez un hébergeur à me conseiller éventuellement ?

A bientôt et merci pour vos réponses. Ça me fait avancer.

 

Share this post


Link to post
Share on other sites

OVH c'est les spécialistes de non ça vient pas de chez nous ... et ... tout a coup ça remarche comme avant ... mais bien sur c'était pas eux

Là en l’occurrence sur les 3 qui m'ont appelé sur les dernières 48h, les filer etait en apoplexie ... mais c'était pas eux bien sûr ... puis finalement c'est redevenu fluide

  • Thanks 1

Share this post


Link to post
Share on other sites

Le problème, c’est qu’on passe un temps fou à chercher et à perdre un temps précieux pour le client. Pendant qu’on fait ça, sa boutique n’avance pas. 
Ça ne leur crèverait quand même pas les yeux de nous dire ; “On a un souci, on est en train de résoudre le problème, on fait au plus vite. Merci de votre compréhension. “ Du coup, j’aurais tout copié en local, continué d’avancer et basta. C’est vraiment rageant. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More