Jump to content

Recommended Posts

Bonjour à tous,

j'ai une petite question technique.

J'ai une boutique qui tourne depuis un moment et qui fonctionne pas mal. Mais je ne suis pas du tout satisfait du TTFB . J'ai vu que le passage en HTTP2 et sur la derniere version d'apache pouvait améliorer les choses.  Et comme je me suis rendu compte que mon serveur n'était pas a jour pour permettre cela j'envisage de tout remettre a jour.

Je suis en PHP 5.6.4, apache 2.4.1 mysql 5.5.6.2 et prestashop   1.6.1.24 (debian 😎

En théorie, il faudrait que je migre pour etre a jour vers du respectivement  7.4.3 2.4.41 8.0.19, 1.7.6.4 et debian 10 si j'ai bien tout trouvé pour les dernieres versions.

Sauf que mon serveur héberge plusieurs sites qui ne pourront pas passer sur ces nouvelles versions.

La seule solution que je vois est donc de migrer sur un nouveau serveur a jour pour apache mysql php et debian. Mais est  ce qu'il vaut mieux que je passe prestashop en 1.7 avant ou apres la migration? Car je ne suis pas certain que la config actuelle du serveur me permette d'arriver a la derniere version. et je ne suis pas sur que la version actuelle puisse migrer directement sur les nouveaux mysql/php.

 

Comment s'est passé le portage de vos sites  meme hors prestashop du php 5.5/5.6 vers 7 et mysql 5.5 vers 7/8 ? refonte quasi complete a cause des obsoletes, ou ca se fait dans un temps raisonnable?

Merci pour vos commentaires/suggestions et remarques, 

je cherche a galérer le moins possible! 😛

 

 

 

Share this post


Link to post
Share on other sites

Tu peux parfaitement passer en http/2 avec apache2.4.1 (même si le gain est à la marge)

 

Share this post


Link to post
Share on other sites

bonjour, et merci pour la réponse.

Ca serait effectivement compatible a partir de la 2.4.17 donc une mise a jour minime a mettre en place. je vais donc déja tester cette amélioration, upgrade php en 2.4.17, et http2 uniquement pour mon site prestashop. il me semblait avoir lu que http2 imposait le https (ou les navigateurs l'imposaient), ce qui est le cas de ma boutique, mais pas de l'ensemble des sites sur mon serveur. Il faudra donc que je l'applique au cas par cas.

 

Je verrais la différence de performance avec uniquement cette amélioration,HTTP2, et je prendrai le temps de la grosse upgrade sur un nouveau serveur plus tard.

Est ce que tu penses pour la migration qu'il vaille mieux que je fasse le passage en ps 1.7 sur l'ancien serveur, ou bien migration sur le nouveau serveur puis tentative d'upgrade?

J'ai vu que tu avais posté ici https://www.prestashop.com/forums/topic/801692-prestashop-16-et-php-72/ a propos de la 1.7. Est ce que ton avis a évolué depuis 2018 ou tu la déconseilles toujours?

Bonne soirée

 

Share this post


Link to post
Share on other sites

Ne passez pas sur 1.7 et php 7.4 n’est pas supporté.

Share this post


Link to post
Share on other sites

Apparemment , il vaudrait mieux que je migre en php 7.1 pour pouvoir migrer sans trop de degats la boutique en 1.6.1.24 puisque c'est la limite de comptabilité. Par contre je ne sais pas si l'upgrade de mysql 5.5.6.2 vers mariadb 10 ou mysql 8 poserait un souci.

 

 

Share this post


Link to post
Share on other sites

Mariadb

sinon il existe des version de PrestaShop compatible php 7.3 ... c’est ce que j’utilise

Share this post


Link to post
Share on other sites
Just now, Mediacom87 said:

Ne passez pas sur 1.7 et php 7.4 n’est pas supporter.

Ok donc 1.6.1.24 et 7.1 , comme indiquer dans mon post, probablement simultané au tien ! Le resultat de mes recherches est donc confirmé. Merci !

Share this post


Link to post
Share on other sites
Just now, Mediacom87 said:

Mariadb

sinon il existe des version de PrestaShop compatible php 7.3 ... c’est ce que j’utilise

Des versions modifiées de 1.6 ?

Share this post


Link to post
Share on other sites

Après je suis pas obligé de passer sur la 1.7 ni sur des versions modifiées de la 1.6 qui pourraient poser probleme pour le one click upgrade, aucune obligation pour moi tant qu'il y a les mises a jour de sécurité, je suis content de ma boutique actuelle. je suis un peu deçu par les perfs pour un dédié mais si je prends un serveur un peu plus costaud, en debian 10, php 7,  http2, etc. ca devrait s'améliorer.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More