Jump to content
Gummiwutzel

Besonders beliebt: Ooops! "500 Internal Server Error"

Recommended Posts

Hallo zusammen,

ich habe hier einen neu aufgesetzten PS 1.7.6.3, Windows NT build 18363 (Windows 10) AMD64, Apache/2.4.41 (Win64) OpenSSL/1.1.1c PHP/7.2.28 mit Zend-OPcache, MySQL 8.0.19.

Der Shop arbeitet soweit einwandfrei, nur das Problem ist, dass der Aufruf eingegangener Bestellungen im Backend reproduzierbar mit 500er-Fehlern endet:

ooops.jpg.0b900145b4f4930bfbefd097320e9251.jpg

In der error.log des Apache findet sich dann folgendes (anonymisiert):

"[Tue Mar 31 15:27:50.207335 2020] [php7:notice] [pid 5076:tid 1132] [client 11.22.33.44:22849] PHP Notice:  Trying to get property 'date_add' of non-object in C:\\Apache24\\htdocs\\domain\\var\\cache\\prod\\smarty\\compile\\ae\\d9\\9c\\aed99c7d87e699751081766144bc10cc38982832_0.file.tableLogs.tpl.php on line 48, referer: https://www.domain.de/adminxxxxxxxxx/index.php?controller=AdminOrders&token=85f309433d516948cc873600a9b8f436"

Den Cache über das PS-Backend zu löschen brachte keine Besserung. Erstaunlicherweise passiert das nur bei den nach der Installation eingegangenen Bestellungen. Die mit dem Shop ausgelieferten Beispielbestellungen lassen sich ohne Schwierigkeiten öffnen. Ich bräuchte jetzt mal einen Schubser in die richtige Richtung...

Vielen Dank und liebe Grüße, Tom

Share this post


Link to post
Share on other sites

Das ist nur eine Notice und sollte nicht den 500er auslösen. Akiviere mal den Debug Modus und schaue ob du dann eine andere Fehlermeldung oder mehr Details siehst.

Evtl. hilft löschen des Caches über den Server (/var/cache zu /var/cache_old umbenennen)

Share this post


Link to post
Share on other sites
Posted (edited)

Gelöst! 🙂

Der Schubser war genau richtig: Den Debug-Mode hatte ich völlig vergessen. Er ergab eine Fehlermeldung wegen nicht vorhandener Datenbank-Tabellen. Offenbar wurden bei der Installation des Paypal-Moduls nicht alle erforderlichen Tabellen angelegt. Die Deinstallation und Neuinstallation des Paypal-Moduls löste dann das Problem.

Vielen Dank, Ihr habt mir seehr weitergeholfen. 😍

Grüße, Tom

Edited by Gummiwutzel (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More