Jump to content

Recommended Posts

Hola

A ver si alguien puede ayudarme porque ya no se que hacer. La cuestión es que en Prestashop 1.7.5.2 siempre ha funcionado bien pero desde hace unos días siempre que instalo algún módulo, al crear un nuevo cliente sale el error 500, aunque desinstale el módulo no funciona, tengo que restaurar la copia. Los módulos que he instalado son oficiales, básicamente el de Packlink y de Recaptcha. Aleatoriamente aunque no instale ningún modulo vuelve a salir el mismo error en el mismo sitio. He intentado resolver los problemas que se indican pero no he sido capaz.

¿Alguna idea?

 

Gracias!

Error 500.png

Share this post


Link to post
Share on other sites

hOLA, creo que te lo pone claramente alli, no puedes crear una contraseña de mas de 32 caracteres

Share this post


Link to post
Share on other sites

Si, eso es lo que entiendo, la contraseña no tiene 32 caracteres, he probado varias combinaciones de letras, números, símbolos,.... Porque entiendo que se refiere a la contraseña del cliente.

Share this post


Link to post
Share on other sites

tienes algun modulo de transportista que no sea nativo?

Share this post


Link to post
Share on other sites

puede que sea algun modulo de transporte o prueba lo siguiente

en la clase Customer (Classes/Customer.php) localizad la línea donde se asigna la variable $definition y comprobad el valor asignado a 'size', seguramente estará establecido a 32, cambiadlo a 60

'passwd' => array('type' => self::TYPE_STRING, 'validate' => 'isPasswd', 'required' => true, 'size' => 60),

Un saludo

Share this post


Link to post
Share on other sites

Esa línea la verifiqué y el valor que indica es 255, he probado con 32, 60,... sin éxito. Acabo de hacer la prueba. Todo funciona correctamente, instalo el módulo de Packlink y sin configurar nada más ya me sale el error al crear el cliente.

Share this post


Link to post
Share on other sites

He avanzado en algo (creo) La cuestión es que cuando instalo el módulo de packlink, se creo un customer.php en la ruta override/Classes. En este customer si está especificado lo de longitud de 32, pero si modifico cualquier campo, el cliente lo crea pero en vez enviar el mensaje de bienvenida y aparecer en la página principal logado, tira este error:

image.thumb.png.791accbd4c663befd3fbc28f32ba25cf.png

¿Alguna idea?

Gracias

Share this post


Link to post
Share on other sites

creo que no lo entendi muy bien, sin el modulo de packlink funciona bien?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More