Jump to content
gaelo

MySql depasse quota

Recommended Posts

Bonjour, 

J'ai remarque en moins de 2 semaines la taille de mon mysql a dépasse plus de 18 Go. AU même moment le phpmyadmin m'affiche 7Go.

pourquoi cette différence? comment résoudre ce probleme?

merci

 

Share this post


Link to post
Share on other sites
Il y a 16 heures, gaelo a dit :

mon mysql a dépasse plus de 18 Go

Avez vous verifier quel table occupe autant de place ? N'avez vous pas un module qui en est la cause ?

Share this post


Link to post
Share on other sites

Oui j'ai verifié. Y a que la table de recherche qui fait 7GB. le cumul des tables n'atteint pas 9GB.

Share this post


Link to post
Share on other sites
il y a 49 minutes, gaelo a dit :

Oui j'ai verifié. Y a que la table de recherche qui fait 7GB

Je ne sais pas comment la vidé mais il serait peut etre bon de le faire.

Share this post


Link to post
Share on other sites

il y a aussi cette table layered_filter_block qui fait 17GB. C'est une table necessaire? je peux la vider?

Share this post


Link to post
Share on other sites
il y a 7 minutes, gaelo a dit :

il y a aussi cette table layered_filter_block qui fait 17GB. C'est une table necessaire? je peux la vider?

C'est la table du module de navigation à facette donc soit vous désinstallez le module, soit vous refaite l'index, soit vous améliorez la qualité des données de votre catalogue.

Share this post


Link to post
Share on other sites

Merci cette opération va donc retablir cette taille enorme? J'ai essai de supprimer le cache au niveau de ce module mais il refuse.

en reconstruisant l'index rien n'a changé.

Share this post


Link to post
Share on other sites

Si vous désinstallez le module normalement il désinstalle cette table, mais à faire seulement si vous n'utilisez pas cette fonctionnalité.

 

Share this post


Link to post
Share on other sites

J'ai réinitialisé le module. je remarque que la table est supprimé. malheureusement ceci n'as pas diminuer la taille d'occupation sur le serveur. je ne sais pas si cela crée un autre fichier volumineux

 

Share this post


Link to post
Share on other sites

Bonjour,

Je rencontre exactement le même problème avec le module de navigation à facette et ce, depuis que j'ai fait une mise à jour en 1.7.6.3 (je crois) . J'étais en 1.7.3.1 avant sans problèmes. J'ai tenté la 1.7.6.4 mais j'ai eu d'autres problèmes plus embêtants en plus de celui-ci. Je ne peux pas repasser en 1.7.3.1 car ma sauvegarde est trop ancienne et il y a eu pas mal de mouvements, nouveaux clients,commandes,..  sur mon site.

Ma table layered_filter_block augmente de 60Mb/jour et m'a fait dépasser le quota de ma base mySQL.

Je suis obligé de reconstruire l'index depuis le back-office tous les jours pour réinitialiser la table (je l'ai aussi vidée à la main avec un truncate table car je n'avais plus accès à mon back office à cause du dépassement de Quota).

J'ai besoin de ce module pour mon site. Je l'ai désinstallé, réinstallé mais le problème persiste. Je précise que je n'ai pas créé ou modifier d'articles et caractéristiques.

Si quelqu'un a une solution...

Share this post


Link to post
Share on other sites

Bonjour,

Avez-vous trouver une solution ? J'ai exactement le même problème. Cette table se rempli à chaque seconde...

Une idée?

Share this post


Link to post
Share on other sites

Bonour

J'ai du désinstaller le module et le réinstaller.  ceci a réinitialisé la base. 

J'ai peur de réactiver le module pour voir la base se remplisse encore. 

Share this post


Link to post
Share on other sites
Posted (edited)

bonjour,

Je n'ai pas trouvé de solution interne à Prestashop mais une solution automatique qui fonctionne très bien.

En fait, il faut vider le cache du module. On peut le faire tous les jours en cliquant sur le bouton "Vider le cache" du module mais c'est un peu fastidieux...

J'ai créé une tâche CRON via ce site gratuit : https://cron-job.org/en/ . Il suffit de se créer un compte et de créer une tâche journalière qui va appeler l'URL pour vider le cache. Pour récupérer l'URL, il suffit de faire un clic droit sur le bouton "vider le cache" et de "Copier l'adresse du lien".

ça fonctionne depuis une semaine et je n'ai plus de soucis.

 

image.png

image.png

Edited by 3dland-shop (see edit history)

Share this post


Link to post
Share on other sites

J'ai migré le site vers 1.7.6, désinstallé et réinstallé le module, rien ne marche.

J'aime pas trop cette tache Cron car ça veut simplement dire qu'il y a quelque chose qui ne fonctionne pas comme prévu...

 

 

Share this post


Link to post
Share on other sites

Exact, mais j’ai moi aussi le problème depuis ma migration en 1.7.6 et c’est la seule solution que j’ai trouvé. C’est clair qu’il y a un bug avec cette version que prestashop devrait corriger. En attendant, je ne peux pas me passer de la navigation à facettes et je regrette bien d’avoir fait cette mise à jour.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More