Jump to content

After upgrade can't view orders, always opens first order


ArnasL
 Share

Recommended Posts

Hello, I have a problem after upgrade from 1.6 to 1.7. Whatever order I want to open from Orders it opens a first order. Why it is so? All orders links to open are

https://domain.com/admin3vzc1sj/index.php?controller=AdminOrders&id_order=1&token=0495d0d0f7da91a2b529fde1612847c0&vieworder=1

If I try to open for example any order manually with changing it's ID, I can see order normally, but why view order button is not linked to my order ID? How to fix it?

Share this post


Link to post
Share on other sites

  • 11 months later...

Hi, I don't remember very good but the problem was with languages and currencies. Some orders had history with currency which was not added to store, analogically same with languages. Try to readd currencies and languages you use.

Share this post


Link to post
Share on other sites

Check your all orders history in databse and check do they all use same currency_id, and language_id, if not check currency_id and language_id in currency and language databases.

Share this post


Link to post
Share on other sites

  • 8 months later...

Hello,

Maybe you have fixed this already and can share your approach. My problem is the same: opening orders list in back office I see all orders, but I can't open the order from the list directly, because the url to order is wrong. e.g. order id is "33", but link under view button always holds "id_order = 1":

<a href="index.php?controller=AdminOrders&amp;id_order=1&amp;token=610a689e5f00004dc1e94000de899700&amp;vieworder=1" class="btn btn-default" title="View">
    <i class="icon-search-plus"></i> View
</a>

I still can open the order by changing the order id in the link manually and as you can see in the list, the order id in the row and in PDF button are the right ones ("33" in this case).

PS 1.7.6.1

image.thumb.png.218b0facea6486969591366efab5daa8.png

 

Thank you,

Vadim

Share this post


Link to post
Share on other sites

15 minutes ago, Pioupial said:

Hello

 

I updated prestashop to version 1.7.2 and the problem disappeared.

Regards

Fabrice

Hello,

did you update from 1.7.0 or earlier? How was your experience?

 

I have made few changes in code and fixed few bugs already, so a bit concerned about the upgrade itself.

Share this post


Link to post
Share on other sites

Yes 1.7.0

The update went well for me.

If you have used the override folder and have a child theme, this makes updating easier.

As with any update, you have to take the time to test and have made backups to be able to restore your site and database if necessary.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More