Jump to content
PrestaNils

Checkout Fehlermeldung: "Keine Versandmethode verfügbar." // trotz konfig. Versandmethode(n)

Recommended Posts

Moin, moin!

Setup:
PrestaShop 1.6.1.24 mit PHP 7.1

Seit Freitag kommen im Online-Shop keine Bestellungen mehr rein. Die konfigurierten Versandmethoden werden nicht mehr angezeigt.
Im Checkout wird die Fehlermeldung "Keine Versandmethode verfügbar." angezeigt.

An den Einstellungen der Versandmethoden hat sich nichts geändert.
Ich habe trotzdem alle gelöscht und neu angelegt - leider ohne Erfolg. Auch ein kostenloser Versand lässt sich nicht konfigurieren.

Ich habe testweise das default-bootstrap Theme aktiviert - dort tritt der gleiche Fehler auf.
Es hat am Freitag "eigentlich" niemand am Shop gearbeitet.

Was könnte hierfür die Ursache sein?
Wie gehe ich vor?

Auffällig ist außerdem, dass in den Bestellungen, die über ebay reinkommen (ebay Modul v1.15.2) die Meldung erscheint, dass die Bestellungen angeblich doppelt bezahlt wurden.
Das ist auch erst seit Freitag der Fall.

Wir stehen kurz vor dem Relaunch des neuen Shops und benötigen dringend eine temporäre Lösung.
Daher bitte keine Kritik am Update-Stau und dem aktuellen Setup. Das bringt uns nicht weiter bzw. haben wir das erkannt und arbeiten an der Lösung.

 

Viele Grüße

Nils

 

Share this post


Link to post
Share on other sites

Hallo Nils,

wenn keiner dran gearbeitet hat und auch kein neues Modul installiert wurde, das möglicherweise eine unerwünschte Nebenwirkung hat, (das gilt besonders für Paypal) dann bleibt nur der Server. Ist es wirklich noch PHP 7.1? Oder habt ihr vielleicht das Paypal-Modul upgedatet und jetzt fehlen wichtige Einstellungen? 

Share this post


Link to post
Share on other sites

Moin Wuschel,

das Update auf PHP7.1 habe ich erst gemacht, nachdem der Fehler aufgetreten ist. Ich dachte, wenn ich alles auf den aktuellsten 1.6er-Stand bringe, beseitigt das eventuell das Problem. Angeblich hat sich auch am Server nichts geändert.

Gibt es zentrale Einstellungen, die die Einstellungen der Versandart überschreiben?
Vielleicht übersehe ich, dass man Deutschland generell als Lieferland freigeben muss und dort ist es nicht mehr als Lieferland definiert?

 

Viele Grüße

Nils

Share this post


Link to post
Share on other sites

Hey!

Problem gelöst... es lag an Problemen mit der Lagerkonfiguration - dort war die Versandart nicht zugewiesen.

Wie es dazu kam, kann ich leider nicht mehr nachvollziehen.

 

Viele Grüße und herzlichen Dank für deinen Einsatz!

Nils

Share this post


Link to post
Share on other sites

Markiere doch den Thread bitte als gelöst (Titel im ersten Post bearbeiten).

Prestashop 1.6 funktioniert ohne Anpassungen nicht einwandfrei mit PHP 7.1.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More