Jump to content
laura64

Message d'erreur

Recommended Posts

Bonjour, 

Les images sur son site ne s'affichent pas et lorsque je veux "regénérer les miniatures" dans la catégorie "images" un message d'erreur apparaît.

Savez vous d'où cela vient et comment le réparer svp ? 

Merci d'avance

 

Capture 4.JPG

Share this post


Link to post
Share on other sites

quel configuration avez vous ? url..version php etc ....

Share this post


Link to post
Share on other sites

Bonjour,

Merci de faire des recherche sur le forum ou par votre moteur de recherche préféré.

Une erreur 500 sur PrestaShop fut traitée plusieurs milliers de fois et des centaines de tuto vous aiderons pour arriver à résoudre le début du problème.

 

Share this post


Link to post
Share on other sites

La regénération de miniature peut créer ce genre d'erreur normale en fonction de votre serveur.

Recommencez l'operation sur certaines miniatures (et non toutes en même temps) SANS EFFACER les anciennes

Normalement après plusieurs lancement, le processus devrait arriver à la fin

Share this post


Link to post
Share on other sites
On 2/29/2020 at 1:09 PM, doekia said:

La regénération de miniature peut créer ce genre d'erreur normale en fonction de votre serveur.

Recommencez l'operation sur certaines miniatures (et non toutes en même temps) SANS EFFACER les anciennes

Normalement après plusieurs lancement, le processus devrait arriver à la fin

Bonjour, 

Merci pour votre aide.

Pour faire suite à vos indications, j'ai bien réussi à regénérer les miniatures des catégories, sauf celles de produits où le même message d'erreur apparaît… 

J'ai oublié de vous préciser que ma boutique a été migré de Prestashop Ready à Prestashop étant donné que Prestashop Ready n'existe plus...

Share this post


Link to post
Share on other sites
Il y a 2 heures, laura64 a dit :

étant donné que Prestashop Ready n'existe plus...

cela était prédit dès avant la mise en place

PrestaBox fermé

PrestaCloud fermé

PrestaReady fermé

 

Ne vous inquiétez pas ils ressortirons un service en ligne pour capturer de nouveaux "débutants"  et fermeront ce service après quelque temps

Il y a 2 heures, laura64 a dit :

sauf celles de produits où le même message d'erreur apparaît… 

Tu peux prendre chaque type de miniature produit une par une, selon ton nombre d'image il est normal de devoir relancer plusieurs fois. Avec l'option SANS EFFACER ça doit finir par aboutir.

En moyenne compter 1s par miniature, donc si le max_execution_time est de 300s et que tu as 1000 images, il faut compter refaire la génération 3 à 4 fois pour arriver à la fin

Share this post


Link to post
Share on other sites

Bonjour, 

Merci à tous pour votre aide.

J'ai (enfin) réussi à regénérer toutes les miniatures j'ai donc redimensionné mes images (en 262 x 262 px) pour les remettre dans ma fiche produit dans le back office, cependant aucune images apparaît sur mon site. Je ne comprends pas pourquoi… 770034670_Capture8.thumb.JPG.c10d939550e0c1ceb75fe7111fe18ef8.JPG

 

 

 

59150107_Capture9.thumb.JPG.dbc9a486fb7adae34a14a1ea9b6e0186.JPG

Share this post


Link to post
Share on other sites

si vous désirez de l'aide, l'url de votre site, la version de prestashop

Share this post


Link to post
Share on other sites
14 hours ago, Manu-shop said:

si vous désirez de l'aide, l'url de votre site, la version de prestashop

Mon site : www.malodeco.fr 

Share this post


Link to post
Share on other sites
Posted (edited)

Cette image https://www.malodeco.fr/img/p/1/3/3/2/1332-home_default.jpg étant valide, alors que celle-ci non https://www.malodeco.fr/1332-home_default/coton-frais-jarre-voiture.jpg, regénère ton .htaccess (désactiver les url simplifiées, enregistrer, réactiver les urls simplifiées, enregistrer)

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

Merci à tous, j'ai réussi à faire réapparaître les images en désactivant l'URL simplifiée (impossible de réactiver cette option, les images disparaissaient à nouveau…). Je ne sais pas exactement à quoi sert cette option que j'ai désactivé donc si vous pouvez juste m'éclairer sur ça...

Share this post


Link to post
Share on other sites

cette option permet d'avoir des urls lisibles plutôt qu'un code abscons.

avoir

https://www.malodeco.fr/691-gourde-leopard.html

plutôt que

https://www.malodeco.fr/index.php?id_product=691&rewrite=gourde-leopard&controller=product

ce qui est mieux pour le clients qui lisent ces liens et aussi, peut être, pour les moteurs de recherche.

Share this post


Link to post
Share on other sites

D'accord merci, savez vous pourquoi je ne peux pas réactiver cette option ? 

Share this post


Link to post
Share on other sites

Problème de permissions du fichier .htaccess ?

Doublons dans la table ps_configuration PS_REWRITING_SETTINGS ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More