Jump to content

Recommended Posts

Bonjour à tous,

Tout d'abord merci à ceux qui prendront le temps de lire ce post.

Depuis ma MAJ vers 1.7.6.3 ma boutique n'était plus accessible (nombreuses ligne de bugs en mode débug)

Je décide donc de faire restauration via le 1-click upgrade de presta : et là c'est encore pire : Le BO et le FO (erreur 500) sont désormais innaccessible :

PrestaShopDatabaseException]

Table 'db745684290.ld_shop_url' doesn't exist
 

SELECT s.id_shop, CONCAT(su.physical_uri, su.virtual_uri) AS uri, su.domain, su.main FROM ld_shop_url su LEFT JOIN ld_shop s ON (s.id_shop = su.id_shop) WHERE (su.domain = 'lestrucsdelaura.com' OR su.domain_ssl = 'lestrucsdelaura.com') AND s.active = 1 AND s.deleted = 0 ORDER BY LENGTH(CONCAT(su.physical_uri, su.virtual_uri)) DESC


at line 746 in file classes/db/Db.php

741. if ($webservice_call && $errno) { 742. $dbg = debug_backtrace(); 743. WebserviceRequest::getInstance()->setError(500, '

 '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97); 744. } elseif (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) { 745. if ($sql) { 746. throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>'); 747. } 748. 749. throw new PrestaShopDatabaseException($this->getMsgError()); 750. } 751. }


DbCore->displayError - [line 378 - classes/db/Db.php] - [1 Arguments]

DbCore->query - [line 597 - classes/db/Db.php] - [1 Arguments]

DbCore->executeS - [line 344 - classes/shop/Shop.php] - [1 Arguments]

ShopCore::initialize - [line 119 - config/config.inc.php]

require - [line 27 - index.php] - [1 Arguments]

 

Merci pour votre aide

J'ai tenté une restauration via mon serveur d'ancienne version mais rien de semble fonctionner.

 

 

Screenshot_2020-02-28 https lestrucsdelaura com.png

Share this post


Link to post
Share on other sites

OVH ?

on dirait qu'il vous manque des tables dans votre base de données.

Share this post


Link to post
Share on other sites

Bonjour Eolia,

 

Non 1&1 Ionos

Oui c'est la conclusion que j'en ai tiré aussi. Lors de la restauration, ça a planté.

Maintenant c'est comme si la BDD ne communiquait plus avec le site

Est-ce que la MAJ 1.7 modifie la BDD (je veux dire structurellement) ?

 

Une solution pour ajouter les tables manquantes ? ou repassé peut-être en 1.7.6.3 sans avoir accès au BO ?

Share this post


Link to post
Share on other sites

Pas mieux...

Il faut récupérer la dernière sauvegarde de votre base (chez l'hébergeur avant la maj) et la réinjecter.

Pour savoir si la maj a modifié la structure il faut regarder les fichiers d'upgrade sql dans l'archive.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More