Jump to content
Zeusdsa

Installation Prestashop Fehler Fileinfo-Erweiterung ist nicht aktiviert

Recommended Posts

Hallo,

ich wollte uns einen neuen Prestashop Installieren.

Vorher lief ein alter Prestashop V1.2 der lange nicht mehr aktiv war.

Bei dem ersten Versuch hab ich den neuen Shop auf unseren Webhost installiert, was auch gut ging nur leider hab ich nach der Installation immer einen 500er Fehler im Back Office erhalten.

Nach der Prüfung hab ich festgestellt das auf unserem Webhost noch PHP 5.6 gelaufen ist und das nicht das beste ist für den neuen Shop.

Nun hab ich den Webhost auf PHP 7.3 und Apache auf 2.4 updaten lassen.

Jetzt versuche ich den Shop wieder zu Installieren nur leider bekomme ich bei der Installation schon den Fehler: Fileinfo-Erweiterung ist nicht aktiviert

Hab nachgelesen und gesehen das man dazu in der php.ini etwas umstellen soll und dort extension=php_fileinfo.dll eintragen sollte.

Habe leider keine Zugriff auf die php.ini bei unserem Webhost hab unseren Webhost angeschrieben und das Problem beschrieben.

Laut Support ist der Wert in der php.ini eingetragen und aktiv aber ich könnte selbst über ini_set: selbst ändern.

Ich hab nun Google von oben bis unten befragt wo und wie ich irgendwas mit dem Befehl machen kann fand aber absolut nichts was einen Leihen wie mich weiter helfen könnte.

 

Hat jemand eine Idee wie ich dem Problem Herr werden könnte oder ich über FTP oder sonstwie die Einstellung ändern könnte damit ich den Webshop fertig installieren könnte?

Auch sagt der Support das nach dem Update von 5.6 auf 7.3 keine Einstellungen geändert worden sind und wenn es vorher gegangen ist es nun auch gehen müsste und ich mich an den Webshop wenden sollte.

 

Vielen dank für die Hilfe.

 

Chirs

 

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb Zeusdsa:

Nun hab ich den Webhost auf PHP 7.3 und Apache auf 2.4 updaten lassen.

Es gibt bisher keine Prestashopversion die "offiziell" mit php 7.3 reibungslos läuft.

Welche Version versuchst du denn zu installieren u. welche Meldungen werden in der error.log des Servers angezeigt?

Grüsse
Whiley

Share this post


Link to post
Share on other sites

Ich versuche die Version 1.7.6.3 zu installieren.

Angezeigt wird mir:

Erforderliche PHP-Einstellungen

Fileinfo-Erweiterung ist nicht aktiviert

To get the latest internationalization data upgrade the ICU system package and the intl PHP extension.

Set short_open_tag to off in php.ini*.

 

Error bekomme ich überhaupt keinen angezeigt.

 

Ich habe zur Sicherheit auch versucht eine php.ini am root mit der extention anzulegen brachte auch keine Besserung.

 

PS: ich sehe gerade das die Version mit 7.3 nicht läuft lasse den Webhost auf 7.2 umstellen damit sollte er laufen.

Sobald das gemacht ist Teste ich es mit 7.2 nochmal.

 

 

Edited by Zeusdsa (see edit history)

Share this post


Link to post
Share on other sites

Genau, PHP7.3 ist schonmal schlecht. Wenn das umgestellt ist und der Fehler trotzdem noch gezeigt wird, kannst du ja mal wie angezeigt,

short_open_tag = off

in die php.ini eintragen.

Share this post


Link to post
Share on other sites

Hallo,

 

hab jetzt auf PHP 7.0 machen lassen.

Die Installation hat nun Funktioniert.

Aber leider ist es so das nun das Backoffice einen 500er Fehler bringt. Front geht mit der Demo Shop.

Install Ordner wurde gelöscht und der Admin Ordner wurde umbenannt.

Fehler bleibt bestehen Backoffice nur ein 500er fehler.

Edited by Zeusdsa (see edit history)

Share this post


Link to post
Share on other sites

Ändere in der Datei /config/defines.inc.php die Zeile

define('_PS_MODE_DEV_', false);

auf

define('_PS_MODE_DEV_', true);

um den Debug Modus zu aktivieren, dann solltest du die Details des Fehlers sehen können.

Share this post


Link to post
Share on other sites

hab ich geändert.

Nur wo sollte ich nun den Fehler sehen?

Wenn ich das Backoffice aufrufe bekomme ich nach wie vor den 500er Fehler.

 

Share this post


Link to post
Share on other sites

Da sollten nun Details zum 500er zu sehen sein - mache mal einen Screenshot

Share this post


Link to post
Share on other sites

Evtl. Cache löschen? In dem Falle sogar vom Browser.

Share this post


Link to post
Share on other sites

Cache ist gelöscht. Anderer Browser bzw. anderer Computer.

Front ist ganz normal erreichbar. (zum Testen chromregal.at)

Backoffice 500er fehler.

Share this post


Link to post
Share on other sites

Eigentlich, wenn du den Debug Modus erfolgreich aktiviert hast, sollte keine 500er Meldung kommen sondern eine mehr oder weniger lange Fehlermeldung, in der genau steht welche Datei welche Probleme verursacht. Daran kann man dann abschätzen was das Problem sein könnte.

Share this post


Link to post
Share on other sites

Sieht für mich erstmal richtig aus...

Share this post


Link to post
Share on other sites

Cache ist laut der Anleitung geleert.

 

Error Logs sind sauber. Webhost hat keine Fehler oder ist irgendwie ausgelastet oder Speicher voll.

 

Share this post


Link to post
Share on other sites

Das sieht nach Hosting-Spezifischer 500er Error Page aus - kann sein dass die es so umleiten dass du den Fehler nicht sehen kannst. Schau mal ob du das bei deinem Hoster ausschalten kannst.  Alternativ sollte der Fehler aber auch im php error log abgelegt sein

Share this post


Link to post
Share on other sites

Wo werden die error logs beim Prestashop abgelegt?

Oder meinst du beim Webhost nachfragen?

Share this post


Link to post
Share on other sites

Die PHP error logs legt dein Hoster auf deinem Server ab - solltest du per FTP oder in deinem Kundenbereich sehen können.

Presta schreibt noch zusätzliche log unter /var/logs - kann aber sein dass da nix drin steht weil der Fehler schon vor dem Logger entsteht

Share this post


Link to post
Share on other sites

Ich habe das Problem gefunden.

Ich weiß nur nicht ob der Shop mit der Änderung nun läuft oder Fehler macht.

im Admin**** Ordner die .htaccess steht ein Eintrag:

<IfModule mod_negotiation.c>
   Options -MultiViews
</IfModule>

Wenn ich diesen # Ausschalte dann kann ich auf das Backoffice zugreifen!

Ich weiß nur nicht was dieser Eintrag macht und um dieser Benötigt wird zum Betrieb.

 

Share this post


Link to post
Share on other sites

Im englischsprachigen Forumsbereich hab ich das hier gefunden:

Keine Ahnung obs geholfen hat.

Share this post


Link to post
Share on other sites

So,

 

mit MultiViews aus scheint alles zu Laufen.

Am Apache hab ich noch nichts machen lassen.

Backoffice scheint zu gehen wobei wenn ich Artikel anlegen passiert es aber nicht immer wenn ich Speichere das er sagt: Einstellungen konnten nicht übernommen werden.

Meist geht es aber und wird auch im Front Office angezeigt.

Was genau das MultiView macht hab ich noch nicht rausgefunden.

Aber danke oben für den Tip.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More