Jump to content
artistik

intérêts de la 1.7 ??

Recommended Posts

Coucou, 

je suis en 1.6 derniere version ou presque 1.6.1.18

 

Quel est la véritable utilité a passer en 1.7? 

Le temps pour réaliser ce changement me semble assez important notamment : la compatibilité module (ouille), les importations de données (ne rien oublier :-)), et tout le CSS a "refaire"...

Ainsi que stress de la mise en place de la nouvelle version live, les possibles oublis divers..

 

Donc concrètement, je gagne quoi? une dernière version toute neuve? un prestashop plus rapide? 

ou alors une grosse perte de temps à faire la MAJ et aucun intéret a la fin si ce n'est "être a jour".... 

 

Bon voila, je pose la question car je suis ecommercant couteau suisse ninja jedi s'occupant de la logistique, du service client, du graphisme, du SEO, et de l'optimisation boutique et experience utilisateur,  la gestion du stock, et la livraison, ainsi que de la cuisson des oeufs au plat et de la préparation de multiples plats bio et fait maison, et mon temps étant quelque peu disloqué parmi ces innombrables activités auxquels je ne viens de citer à peine le 1/10 de ce que je fais véritablement , la question de la mise à jour me taraude car je suis un brin perfectionniste ou un peu fou allier ou plutôt maso qui cherche les embrouilles, et je me suis dit que la était le moment et l'endroit pour enfin savoir si la 1.7 est la solution à tous les problèmes de tous les temps ou si bien comme j'ai pu le lire à plusieurs reprises, la question de l'utilité intrinsèque de cette version mercantile du service marketing de prestashop n'est qu'un complot opéré par donald trump en personne avec la complicité de basshr al assad destiné à occuper les masses pour les empêcher de faire la révolution inter planétaire du grand accomplissement mondial d'internet ! 

 

a bon entendeur, 

au plaisir de vous lire :) 

Share this post


Link to post
Share on other sites

La réponse à cette question est donnée sur ce même forum 8x par semaine !!!

Share this post


Link to post
Share on other sites

Perso je suis passé à la version 1.6.1.25 qui est une version compatible PHP 7.2 et 7.3, même si après il faut contrôler tous les modules pour être certains qu'ils le sont aussi.

Share this post


Link to post
Share on other sites

super, 

merci mediacom87

 

pour info, je suis en 1.6.1.18

je ne sais pas comment mettre a jour sans risque vers la version finale. 

J'aimerai eviter le one click qui me semble incontrolable.. Est ce qu'il y a quelques fichiers uniquement à modifier? 

dans ce cas, je pourrai le faire manuellement et replacer les fichiers si problème il y aurait 

 

PS : sur la version 1.6.1.18 est ce que je peux passer en mysql 5.7 sans souci ? 

 

Merci

 

 

Edited by artistik (see edit history)

Share this post


Link to post
Share on other sites

Perso je maitrise assez PrestaShop pour passer sans le moindre soucis par le module 1 click upgrade, ce que j'ai fait pour passer de la version 1.6.0.9 à la 1.6.1.24, mais j'ai du intervenir sur le code de plusieurs modules pour que tout fonctionne bien.

Une mise à jour n'est jamais anecdotique et tout cela se prépare, se test et donc demande du temps.

Après pour basculer sur la version 1.6.1.25 c'est un autre soucis car il faut mettre en place les nouveau fichiers disponible sur Github puis passer l'hébergement en PHP 7.3 et tester tous les modules pour corriger ceux qui rencontrent des soucis.

En gros pour un site normal il faut compter 1 à 2 semaines de boulot pour faire cela proprement.

Share this post


Link to post
Share on other sites

ca marche merci 

donc pour l'instant je vais m'abstenir, j'ai assez de quoi m'ocuper 🙂 

 

sinon pour 5.7 mysql , aucun souci pour la base de données sur 1.6?

 

merci 

Share this post


Link to post
Share on other sites

si ton mysql est configuré en mode legacy alors aucun problème, sinon possible

Je ne comprends pas cette course effrénées aux dernières versions...

Share this post


Link to post
Share on other sites

mediacom87 , 

 

module 1click upgrade  = foutre en l'air sa boutique en un seul clic 

 

 

🙂 

 

c'est du vécu, quand j'ai débuté avec prestashop, j'ai eu des périodes euphoriques ou j'apprenais pas mal de choses facilement, un soir a 23h, la délicieuse idée de mettre a jour la boutique "histoire de" .. catastrophe générale 

 

 

Share this post


Link to post
Share on other sites

En faisant cela en prod à 23h, vous croyez vraiment que vous alliez réussir ?

franchement, le module fonctionne pas trop mal, si on retire déjà la sauvegarde et si on effectue des test sur une copie du site.

Share this post


Link to post
Share on other sites

La mise à jour d'une boutique ne s'improvise pas.

Le module "1 click upgrade" fonctionne bien sur les boutiques qui ont été créer en respectant les règles de PrestaShop. 

Share this post


Link to post
Share on other sites

Faudrait quand même lire correctement les réponses. Si on parle de mysql, on ne parle pas de php et vice et versa.

Je ne connais aucun vrai gain de performance avec mysql 5.7

Share this post


Link to post
Share on other sites
il y a 1 minute, doekia a dit :

Faudrait quand même lire correctement les réponses. Si on parle de mysql, on ne parle pas de php et vice et versa.

J'ai lu et je n'ai aucune preuve à 100% qu'il veulent avoir des informations sur les performances concernant mysql car il n'a rien précisé.

Donc si tu veux absolument te plaindre tu peux le faire contre lui qui ne donne pas assez d'information ou simplement lui répondre concernant mysql comme je l'ai fait pour PHP.

Share this post


Link to post
Share on other sites
Il y a 22 heures, artistik a dit :

sinon pour 5.7 mysql , aucun souci pour la base de données sur 1.6?

 

Il y a 22 heures, doekia a dit :

si ton mysql est configuré en mode legacy alors aucun problème, sinon possible

Je ne comprends pas cette course effrénées aux dernières versions...

 

Le 2/20/2020 à 2:00 AM, artistik a dit :

je suis en 1.6 derniere version ou presque 1.6.1.18

Il y a 21 heures, Mediacom87 a dit :

par rapport à PHP 5.6, tout à fait.

 

Il y a 21 heures, artistik a dit :

Impatient d'equiper le bouzin alors :)

Moi je vois un dialogue de sourd, mais c'est sûrement que moi

Share this post


Link to post
Share on other sites
On 2/22/2020 at 12:03 PM, Mediacom87 said:

Perso je suis passé à la version 1.6.1.25 qui est une version compatible PHP 7.2 et 7.3, même si après il faut contrôler tous les modules pour être certains qu'ils le sont aussi.

bonjour,

 

pourriez-vous me donner le lien pour télécharger la 1.6.1.25 ?

 

merci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More