Jump to content
  • 0

1.6.1.24 (und 1.7?) Anhänge nicht in Windows 10 Mail


Question

Hallo Zusammen,

beim Upgrade eines Prestashop 1.6.1.4 auf 1.6.1.24 habe ich einen Override der Mail.php wie folgt angepasst:

1.6.1.4:

  public static function Send($id_lang, $template, $subject, $template_vars, $to,
        $to_name = null, $from = null, $from_name = null, $file_attachment = null, $mode_smtp = null,
        $template_path = _PS_MAIL_DIR_, $die = false, $id_shop = null, $bcc = null, $reply_to = null)
  {
    if(strpos($template,'order_conf') !== false && file_exists(_PS_THEME_DIR_.'mailtexte/agb.pdf')){      
          $file_attachment[] = 
          array(
            'content' =>  new Swift_File(_PS_THEME_DIR_.'mailtexte/agb.pdf'),
            'mime'    =>  'application/pdf',
            'name'    =>  'Agb.pdf'
          );
    };

1.6.1.24:

    public static function Send($id_lang, $template, $subject, $template_vars, $to,
        $to_name = null, $from = null, $from_name = null, $file_attachment = null, $mode_smtp = null,
        $template_path = _PS_MAIL_DIR_, $die = false, $id_shop = null, $bcc = null, $reply_to = null)
    {
    if(strpos($template,'order_conf') !== false && file_exists(_PS_THEME_DIR_.'mailtexte/agb.pdf')){
          $file_attachment[] = 
          array(
            'content' =>  file_get_contents(_PS_THEME_DIR_.'mailtexte/agb.pdf'),
            'mime'    =>  'application/pdf',
            'name'    =>  'Agb.pdf'
          );
    };


Die Anpassung funktioniert soweit auch ganz gut. Ich finde den Anhang in meiner Bestellbestätigung wieder.
Jedoch zeigt das (Standard-)Mail von Windows 10 keinen Anhang an ! (Outlook, Webmailer, ... funktionieren) !?

Es scheint so, als würde das mit der Aktualisierung des Swiftmailer zusammenhängen.
(Im Alten 1.6.1.4er Shop mit dem obigen Override zeigt Windows 10 Mail den Anhang jedoch ohne Probleme).
Kann jemand prüfen, ob das Problem auch in der 1.7 auftritt?

Weis jemand Rat?

Grüsse,
Karsten
 

Edited by karstenboldt (see edit history)

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Mit dem "Outlook" meinte ich das Outlook aus einem Office 2019 Paket.
Dieses zeigt die Anhänge an.
Das mitgelieferte Mail-Programm von Windows nicht.

In diesem finde ich keine Einstellung, zumal der bestehende Shop v1.6.1.4 mit dem  ersten (alten) Override funktioniert.
In allen Mailrpogrammen - inklusive dem von Windows mitgelieferten - werden Anhänge angezeigt.

Das spricht dafür, dass der die neuere Version des Swiftmailer andere Mails (mit Anhängen) generiert als die Version die inv1.6.1.4 enthalten war, oder?

Grüsse,
Karsten

Share this post


Link to post
Share on other sites
  • 0

Wenn der Anhang nur in dem einen Mailprogramm nicht angezeigt wird, würde ich erst einmal probieren, ob das Problem auf anderen Computern mit dem Programm auch auftritt, vielleicht liegt es an einer Einstellung z. B. zum Spamschutz oder einem Zusatzprogramm. Du kannst auch einmal den Quelltext der Mail anschauen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More