Jump to content
mikeconcept

[Résolu] Migration BDD - Erreur 500

Recommended Posts

Bonjour,

Ayant besoin d'une base de donnée avec une plus grande capacité, j'ai tenté d'effectuer cet après midi une migration vers une nouvelle BDD.

J'ai donc effectué les étapes suivantes :

1. J'ai exporté ma BDD en sélectionnant toutes les tables depuis OVH ->  Phymyadmin

2. J'ai importé le ficher de cette BDD sur ma nouvelle BDD.

3. J'ai actualisé les informations de ma nouvelle BDD via mon FTP : app/config/parameters.php

 

PROBLÈME : le site affiche alors sur le Front-office et Back-office "Erreur 500", j'ai donc tenté de régénérer mon fichier htaccess en le supprimant de mon FTP, mais ça n'a rien changé.

J'ai ensuite passé le mode debug via mon FTP et voici le message d'erreur qui s'affichait en allant sur le site :

pbpresta2.thumb.jpg.53043dfd86351e405e4c3b75a6272110.jpg

J'ai donc ré-actualisé les anciennes informations, celle de mon ancienne BDD via mon FTP : app/config/parameters.php

Le site se ré affiche correctement mais j'aimerai donc lier ma nouvelle BDD.

 

Je suis sous Prestashop version 1.7.5 avec l'hébergeur OVH.

PS : Je ne sais pas si ça peut avoir un rapport mais j'étais sous version PHP 5.6, j'ai modifié ce matin la version depuis l'interface OVH, passant à PHP 7.2

 

Merci d'avance

Bonne journée

Edited by mikeconcept (see edit history)

Share this post


Link to post
Share on other sites

Ta copie de base de données n'a pas été correcte, il te manque des tables.

Recommence ton backup, vérifie le, et recommance la restauration dans la nouvelle bdd

Share this post


Link to post
Share on other sites
4 hours ago, doekia said:

Ta copie de base de données n'a pas été correcte, il te manque des tables.

Recommence ton backup, vérifie le, et recommance la restauration dans la nouvelle bdd

Bonjour, merci pour votre réponse

J'ai recommencé le backup après avoir supprimé et recréé la BDD depuis OVH

J'ai désormais ce message d'erreur en allant sur le site, en mode debug.

pb2.thumb.jpg.afb9544c30d8bd5b4b0bd080319d634d.jpg

Share this post


Link to post
Share on other sites

Cette fois tu oublié de réajuster tes login bdd dans parameters.php

Share this post


Link to post
Share on other sites
4 hours ago, doekia said:

Cette fois tu oublié de réajuster tes login bdd dans parameters.php

Merci beaucoup,

J'avais actualité mais en effet j'ai du faire une faute de frappe, ça marche désormais parfaitement.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More