Jump to content
CrazyMangas

OVH HEBERGEMENT Redirection vers ip locale[Résolu]

Recommended Posts

Bonjour à toutes et à tous,

J'essaye de mettre ma boutique en ligne sur mon herbergeur OVH
Lorsque que j'essaye d’accéder à mon site, je suis rediriger sur ip locale 127.0.0.1
pour exemple lorsque je veux accéder à mon index :cela me rediriger sur url http://127.0.0.1

-Mon site est à la racine de hébergeur ovh (www)
-Tout mes fichiers ont en droit 755(le maximun pour ovh)
La configuration de la base de donnée est bonne
(define('__PS_BASE_URI__', '/');
etc...)
-ma page www.crazymangas.com/produit.php s'affiche

Et comble du comble, ma boutique en locale(xampp) ne fonctionne plus en locale alors que je n'ai rien touché j'ai même essayer une backUp que j'avais...
Je suis un peu désespéré...
Merci de votre aide!!

Voici le contenu de mon ht access( qui est .htaccess). J'en ai essayer des dizaines :(


# URL rewriting module activation
RewriteEngine on
Rewritebase /

# URL rewriting rules
RewriteRule ^([a-z0-9]+)\-([a-z0-9]+)(\-[a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ img/p/$1-$2$3.jpg [L,E]
RewriteRule ^([0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ img/c/$1$2.jpg [L,E]
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]

# Catch 404 errors
ErrorDocument 404 /404.php

SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0

Share this post


Link to post
Share on other sites

Merci de la réponse rapide,
Déja fait, la base est exporter sur ovh et les fichiers sur le ftp aussi..

Share this post


Link to post
Share on other sites

Bonsoir,

Si vous avez fait toute la procédure de migration et que cela ne fonctionne pas, je suppose que vous êtes en version Prestashop 1.4.x

Il faut vous connecter à votre BO d'administration, aller sur l'onglet "Préférences" et renseigner correctement les premiers champs demandés concernant l'URL et le répertoire d'installation.

Cordialement.

Share this post


Link to post
Share on other sites

Bonsoir, en effet je suis en 1.4.0.17,
Merci beaucoup!! le problème sera vite réglé, cependant je n'ai plus accès à mon panel administration, en local
(si j'y avais l'accès je pourrais transférer de nouveau ma boutique sur le ftp)
Je vais essayer de reinstaller xampp, je suis preneur si vous avez d'autres suggestions à ce sujet !
Edit : réinstallation sans effet , toujours le Objet non trouvé! de l'adresse http://127.0.0.1/xampp/prestashop
extrêmement bizarre, sachant que je n'ai absolument rien touché...

Share this post


Link to post
Share on other sites

Oui en effet il me semble aussi que c'est http://127.0.0.1/prestashop/fr/ , mais çela ne fonctionne pas non plus.

Comment je peux accéder à la partie administration? J'ai essayer www.monsite.com/repertoireadmin/index.php et
www.monsite.com/repertoireadmin/
ça me redirige aussi sur le local.

Share this post


Link to post
Share on other sites

Bonjour,
dans la table [préfix]_configuration il y a 3 champs qui contiennent le nom de domaine :
- CANONICAL_URL,
- PS_SHOP_DOMAIN,
- PS_SHOP_DOMAIN_SSL.

En prenant soin de sauvegarder votre base au préalable, vous pourriez essayer en modifiant ces 3 champs qui sont certainement resté à 127.0.0.1 dans votre cas.
Avec PhpMyAdmin vous devriez pouvoir faire votre sauvegarde (Exporter) et modifier ces 3 valeurs avec votre nom de domaine.

En espérant que cela vous aidera.

Share this post


Link to post
Share on other sites

Même problèle chez moi. Merci pour la solution !

Share this post


Link to post
Share on other sites

bonjour a tous.

J'ai le meme probleme et apres avoir rectifier les tables de la base de données sauf CANONICAL_URL car je ne la trouve pas mon site est toujours rediriger vers le serveur local 127.0.0.1. Y aurait-il d'autres valeurs a modifier au cas ou ???

Merci.

Steph.

Share this post


Link to post
Share on other sites

Bonjour,

J'ai le même problème pour la migration de Prestashop 1.4.1 de wamp vers ovh. Dans ma table ps_configuration je n'ai pas le champs CANONICAL_URL.

Merci de votre aide.

Share this post


Link to post
Share on other sites

Moi j'ai changer : PS_CANONICAL_REDIRECT (1 à 0) maintenant, au lieu d'avoir la redirection vers localhost, j'ai ma page qui s'affiche

 

Maintenant, je dois retrouver un moyen d’accéder a l'admin >.<

Ce qui est bête c'est qu'en local j'avais mis mail@mail.com haha =)

Share this post


Link to post
Share on other sites

J'ai finalement réussi faire une copie de l'hébergeur en local...

C'est la croix et la bannière !

Je comprends pas que ce soit aussi compliqué, j'avais systématiquement

des redirections forcés vers le site hébergé.

(deux prestashop)

 

Outre le fichier config/settings.inc.php qu'il fallait bien configuré,

j'ai modifié la base de donné comme indiqué par Xavier. Merci

 

Il n'y a pas de CANONICAL_URL chez moi (prestashop 1.4.1.0 et 1.5.3.1), j'ai donc mis PS_CANONICAL_REDIRECT à 0

et

- PS_SHOP_DOMAIN,

- PS_SHOP_DOMAIN_SSL en localhost

 

Cela permet ensuite uniquement d'accéder uniquement au back office,

puis j'ai modifié Configuration des URLs

 

J'ai aussi viré les fichiers .haccess (à voir si c'est nécessaire, pas

sûr) et remis un coup de droit apache à la racine, chez moi

 

sudo chown -R www-data:www-data /var/www

 

 

J'espère que ça pourra en aider d'autre. ;)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More