Jump to content
ASB-Tackle

PS 1.6 Gutschrift - Shop Adresse fehlt

Recommended Posts

Ich habe noch ein Problemchen mit der Prestashop Version 1.6.1.24

Wenn ich eine Gutschrift erstelle, fehlt einfach die Shopadresse. Die Rechnungs- und Lieferadresse des Kunden sind da.

Ich habe mir die OrderSlip Dateien mal angesehen und mit dem Rechnungs- und Lieferscheindateien verglichen. Diese sind aber komplett unterschiedlich aufgebaut. Daher kann ich daraus nichts kopieren.

Weiß jemand, wie ich die Shopadresse auf die Gutschrift kriege?

Share this post


Link to post
Share on other sites

Rabatt ist was anderes, würde ich sagen.

Z.B. ein Artikel ist nicht lieferbar. Dann klicke ich auf "Artikel erstatten", wähle entsprechend aus und kreuze unten

"Rückvergütung generieren" an.

Dann bekomme ich unter "Dokumente" eine PDF Datei mit der Gutschrift erstellt. Nur auf dieser fehlt eben die Shopadresse.

Ich habe den Standard - Shop, ein paar Module - nichts weltbewegendes geändert. Ist die Frage, hat sonst noch jemand das Problem oder ist es doch nur bei mir so? Leider komme ich nicht in den Demo Shop, der hier im Forum verlinkt ist, da wohl im Moment das Passwort dort nicht geht.

Share this post


Link to post
Share on other sites
vor 13 Minuten schrieb ASB-Tackle:

Leider komme ich nicht in den Demo Shop, der hier im Forum verlinkt ist, da wohl im Moment das Passwort dort nicht geht.

Repariert!

Share this post


Link to post
Share on other sites

Ich habe gerade im Demo Shop gesehen, das dort auch die Shop Adresse fehlt.

Wenn man sich dort im Back Office die 2. Bestellung anschaut,  dort auf Dokumente geht,

ist eine Rückvergütung vorhanden, bei der auch die Shop Adresse fehlt.

Ich habe auch noch mal den Presta Shop neu herunter geladen, die Dateien sind mit meinen identisch.

Also scheint es wohl ein von Haus aus Bug der 1.6. Version zu sein?

demo.jpg

Edited by ASB-Tackle (see edit history)

Share this post


Link to post
Share on other sites
vor 32 Minuten schrieb ASB-Tackle:

Also scheint es wohl ein von Haus aus Bug der 1.6. Version zu sein?

Nein, im Testshop waren ja keine Daten des Unternehmens eingetragen, ich habe das ergänzt, wenn du dir jetzt die Rückvergütung anschaust, siehst du auch unten auf der Seite die Adresse.

Gesteuert wird dir PDF - Ausgabe über

/pdf/footer.tpl

oder - je nach template -

/deintheme/pdf/footer.tpl

Grüsse
Whiley

Share this post


Link to post
Share on other sites
vor 9 Minuten schrieb Whiley:

Nein, im Testshop waren ja keine Daten des Unternehmens eingetragen, ich habe das ergänzt,

vielleicht hat er die Daten auch bei sich noch nicht eingetragen, von wo wird es eingetragen ?

Share this post


Link to post
Share on other sites

Ne.... ich meine nicht unten im Footer, sondern oben unter dem Firmenlogo,

so wie es auf den Rechnungen ja auch ist.

Bei Rechnungen und Lieferscheinen gibt es 3 Blöcke:

Shop Adresse - Rechnungsadresse - Lieferadresse

So sollte es eigentlich bei den Rückvergütungen auch sein, sonst ist da oben einfach ein riesen großes weißes Loch....?

Share this post


Link to post
Share on other sites

Es sollte aber eigentlich kein Problem sein, die PDF-Vorlage entsprechend zu ergänzen (dann halt wohl statt footer.tpl header.tpl). Generell sind die PDF-Vorlagen von Prestashop keine Highlights ...

Share this post


Link to post
Share on other sites

ok, ich weiß ja nicht, ob an der 1.6er Version noch gearbeitet wird. Ich wollte nur meine Beobachtung schildern, vielleicht greift es ja noch mal jemand auf.

Ich kenne mich leider nicht mit Smarty und so aus, daher kriege ich keine professionelle Lösung hin.

Ich werde wohl einfach meine Adresse "hart" an entsprechender Stelle einfügen.

Aber damit ist das Thema dann auch gelöst.

 

Share this post


Link to post
Share on other sites
1 hour ago, ASB-Tackle said:

Ich werde wohl einfach meine Adresse "hart" an entsprechender Stelle einfügen

Dazu hätte ich dir auch geraten, weil es am einfachsten ist.

9 hours ago, rictools said:

Es sollte aber eigentlich kein Problem sein, die PDF-Vorlage entsprechend zu ergänzen (dann halt wohl statt footer.tpl header.tpl)

Schön wär's, funktioniert aber nicht.

1 hour ago, ASB-Tackle said:

ok, ich weiß ja nicht, ob an der 1.6er Version noch gearbeitet wird

Nicht von Prestashop, nur von Usern oder im bekanntesten Fork thirtybees.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More