Jump to content
Ruriksson

PayPal - In few seconds, you will be redirected to PayPal. Please wait.

Recommended Posts

Hallo, 

ich bin gerade tierisch genervt. Ich habe einen PrestaShop 1.7.4.2 und das PayPal v5.1.1 - von PrestaShop. 
Seit der Upgrade Forderung lässt sich PayPal aktiv schalten, beim Bezahlvorgang nach Schritt vier kommt ein kleines PopUp mit "In few seconds, you will be redirected to PayPal. Please wait."
Es passiert aber nichts mehr. Bevor dieses Upgrade geforert wurde, funktionierte die Zahlung normal. Ich seh auch so keine Fehlermeldungen im Browser. Auch der Debug Mode warf nichts aus. 

Ich habe mich durch zahlreiche Themen gelesen und die Lösungen versucht - ohne Erfolg. 
Alle Einstellungen sind korrekt soweit und auf Gründ, auch im Produktionsmodus. 
Ich hab unter var/cache/prod auch den cache schon geleert usw. 

Woran kann es liegen?
Auch andere Browser genutzt. 

Natürlich im Produktionsmodus - Sandbox hab ich aktuell nur auf aktiv gestellt. 

paypal2.JPG

paypal.JPG

Share this post


Link to post
Share on other sites

schau mal auf der rechten seite unter Umgebungseinstellungen kannst du auf Reale Zahlungen Live einstellen,

außerdem steht es oben im Gelb auffallend das du in Testmodus in Testumgebung bist.

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites

Hallo Sliderflash,

letzter Satz heißt doch, dass ich aktuell nur in den Sandbox Modus wieder umgestellt habe. Natürlich hatte ich vorher den Produktionsmodus eingestellt. ;)

Edited by Ruriksson (see edit history)

Share this post


Link to post
Share on other sites

Danke Sliderflash, aber soll ich dir vom Google Link einen Screen machen, dann siehst Du, dass alle links violett sind - gelesen und Lösungen getestet. 

Share this post


Link to post
Share on other sites

Was bitte ist eine "Upgrade Forderung"?

Deine Prestashop-Version ist ja schon etwas älter, spricht etwas gegen eine Aktualisierung?

Share this post


Link to post
Share on other sites

Vielleicht eine unterschiedliche PHP version zur optimal verlangten?

Hast du ein Addblocker oder der gleichen eingeschaltet?

Ist mit PayPal 5.x die offizielle Version gemeint, schon mal eine Mail an die geschrieben?

Die sollten relative aktive und kompetente DEVs haben, bei so kleineren Support bedarf ist es teils möglich sogar direkt mit dem Entwickler zu schreiben, die können die kompetenteste Auskunft geben oder sogar Veränderungen vornehmen ;)

Share this post


Link to post
Share on other sites

Du hast das PayPal Modul aktualisiert? Dann schau mal bei "Zahlungsarten -> Voreinstellungen" ob unter "Währungsbeschränkungen" bei der Zahlart PayPal etwas aktiviert ist.

Share this post


Link to post
Share on other sites

Guten Morgen Netagent,
seit gestern geht es plötzlich wieder. Ich hatte lediglich nochmal den PrestaShop Cache gelöscht und das Modul nochmal resettet.

btw war am Wochenende bei PayPal unter Währungsbeschränkungen tatsächlich EUR angeklickt. Ich habe das am Samstag auf Standard umgeschalten.
Jetzt wo Du es sagst ...

Sollte das Problem nochmal auftauchen - melde ich mich wieder.

Edited by Ruriksson (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Ich hatte das gleiche Problem. Mir hat folgendes geholfen:

  • Backoffice -> International -> Lokalisierung-> Land des Shops umstellen auf "United States"

Das kann man sich im PayPal-Modul wie gewohnt mit den normalen Login-Daten die Api-Daten automatisch eintragen lassen.

Es scheint ein Bug zu sein. Leider reagiert der PayPal-Support aktuell sehr träge und hilft nicht weiter, so dass ich erst nach Stundenlangem Ausprobieren auf diesen Workaround gekommen bin.

Share this post


Link to post
Share on other sites
Posted (edited)
On 2/13/2020 at 4:22 PM, torbho said:

Ich hatte das gleiche Problem. Mir hat folgendes geholfen:

  • Backoffice -> International -> Lokalisierung-> Land des Shops umstellen auf "United States"

Hab ich versucht, dann ging es zwar, aber es wurde plötzlich keine MwSt. mehr ausgewiesen. -.-

 

Ich schließe mich also dem Problem an und habe auch schon alle Punkte, wie oben beschrieben geprüft, getestet etc.. Alles ohne Erfolg. Gibt es noch ein paar andere Ansetze?

Edited by NextLevelNation (see edit history)

Share this post


Link to post
Share on other sites

Du hast also die gleiche (ziemlich alte) Prestashop-Version? Welche PHP-Version?

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, NextLevelNation said:

Alles ohne Erfolg. Gibt es noch ein paar andere Ansetze?

Wurde hier schon oft diskutiert: Bei den meisten ist PayPal Plus nicht richtig aktiviert und es hilft ein kurzer Anruf beim Paypal Kundenservice. Erkennen kannst du das an Fehlermeldungen in der Javascript Konsole.

Edited by JBW (see edit history)

Share this post


Link to post
Share on other sites

Nein natürlich nicht, alles auf dem aktuellen Stand. Aber das Problem scheint gelöst wurden sein, indem ich aus dem PP-Konto ein Geschäftskonto gemacht habe. ;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More