Jump to content
Sign in to follow this  
lilia-22

[RESOLU] Erreur dans l'onglet Module

Recommended Posts

Bonjour,

Dans le panneau d'administration l'onglet "Modules" s'affiche avec une erreur:

Parse error: parse error, unexpected ';' in C:\wamp\www\****\classes\Tools.php(1691) : eval()'d code on line 1

Je travaille en local avec la version 1.4.0.17

S'il vous plait comment résoudre ce problème.

Merci d'avance

Share this post


Link to post
Share on other sites

Bonsoir,

Et votre fichier C:\wamp\www\****\classes\Tools.php est le bon ? il n'est pas tronqué ?
Qu'avez-vous à cette ligne 1691 ?

Bien cordialement

Share this post


Link to post
Share on other sites

Bonjour,

Pouvez-vous me copier le code de la fonction jsonDecode() de votre fichier classes/Tools.php (ligne 1666 à 1694) ?

Merci

Share this post


Link to post
Share on other sites

Bonjour Laurent,

Voilà le code :

public static function jsonDecode($json)
{
if (function_exists('json_decode'))
return json_decode($json);
else
{
$comment = false;
$out = '$x=';

for ($i=0; $i {
if (!$comment)
{
if (($json[$i] == '{') || ($json[$i] == '['))
$out .= ' array(';
else if (($json[$i] == '}') || ($json[$i] == ']'))
$out .= ')';
else if ($json[$i] == ':')
$out .= '=>';
else
$out .= $json[$i];
}
else $out .= $json[$i];
if ($json[$i] == '"' && $json[($i-1)]!="\\") $comment = !$comment;
}
eval($out . ';');
return $x;
}
}



merci d'avance























видеорегистратор с монитором

























лучший видеорегистратор

Share this post


Link to post
Share on other sites

Bonjour,

J'ai le même genre de problème... quand je clique sur l'onglet "Modules" j'ai une belle page blanche ! Ma version de PHP est la 5.2.14 et j'ai :
json support enabled
json version 1.2.1

Une idée du problème ?

[EDIT 6 avril 19h00] Je viens de modifier localement le php_value memory_limit en le passant à 64 Mo et ça passe.

Share this post


Link to post
Share on other sites

Bonjour,

@idjinn : Bien joué :)

@lilia-22 : Votre version de PHP ne peut pas être la 2.8.1, Prestashop ne pourrait pas s'exécuter.
Pouvez-vous exécuter un phpinfo() afin d'observer la version de PHP ?

Merci,

Share this post


Link to post
Share on other sites

Bonjour

J'ai le même problème une page blanche lors de l'affichage des modules
J' ai la version PHP Version 5.2.0-8+etch16 de php

Que doit on faire ?

Merci

Share this post


Link to post
Share on other sites

Bonjour,

La version de PHP est la 5.1.4

La version de PECL est la 1.0.1 (voir l'image)


42335_4MzW2WcWdgFExR0UI0TV_t

Share this post


Link to post
Share on other sites

Bonjour,

Pouvez-vous mettre à jour vos versions de PHP et PECL ?
Il faudrait que votre version de PHP soit au moins égale ou supérieure à la 5.2.0 et que votre version de JSON soit au minimum égale ou supérieure à la 1.2.0.

Share this post


Link to post
Share on other sites
Bonjour

J'ai le même problème une page blanche lors de l'affichage des modules
J' ai la version PHP Version 5.2.0-8+etch16 de php

Que doit on faire ?


Tu as essayé de modifier la Ram allouée à PHP ?

Share this post


Link to post
Share on other sites

Bonjour

Merci pour ce message
Oui effectivement on a modifie la taille allouée et cela marche ....
Merci

Share this post


Link to post
Share on other sites

Bonjour,

J'ai installé une autre version pour PHP la 5.3.0 et json la version 1.2.1.

Mon problème est résolu.

Merci

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More