Jump to content
AMSPO24-Online

Umzug zum neuen Provider

Recommended Posts

Hallo,

was muss ich beachten, wenn ich zu einem neuen Provider umziehe?

Datenbank ?
FTP ?
Rechteverwaltung?

Share this post


Link to post
Share on other sites

Dieses Forum ist u.a. auch als Nachschlagewek zu verstehen, eine Frage wie diese wurde hier schon gefühlte hundert mal behandelt.

Also Suchfunktion oder Google benutzen:

https://www.google.com/search?client=firefox-b-d&q=prestashop+Serverumzug

Das Wichtigste ist aber die richtige Auswahl des neuen Servers, auch hierzu gibt es ausfühliche threads.

Grüsse
Whiley

Share this post


Link to post
Share on other sites

Danke, habe trotzdem noch Probleme:

 

https://www.amspo24-online.de/

unter

/app/config/parameters.php

habe ich die Daten eingetragen.

Jetzt bleibt die Webseite WEISS!

Provider: IONOS

Ich denke das meine Probleme noch in der Domain -> FTP sind.

Deaktiviere ich: x_index.php und gebe eine neue Datei ein: index.html
 

<html lang="de">
<head>
<meta charset="UTE-8">
<titel></titel>
</html>
<body>
<H1>WEBSEITE NICHT ERREICHBAR!</H1>
<p></p>
</html>

das funktioniert. Irgendwo habe passt was nicht!

Muss hier die Website rein? < ps_configuration >  MB_CANCEL_URL >

Edited by AMSPO24-Online (see edit history)

Share this post


Link to post
Share on other sites

Ist denn der Name der Site gleichgeblieben oder hat er sich geändert?

Wenn gleich, zeigt der DNS auf die neue IP (momentan 217.160.0.148)?

 

Share this post


Link to post
Share on other sites

Zeigt an: DNS = A / www / 217.160.0.148

 

Ich denke, der shop läuft noch unter " amspo24-online.de/presta/index.php" und dürfte nur unter "amspo24-online.de/index.php" laufen. Wo finde ich diese Einstellung?

 

Share this post


Link to post
Share on other sites

in PS_SHOP_DOMAIN

und

PS_SHOP_DOMAIN_SSL

 

In beiden Feldern müsste

amspo24-online.de

eingetragen sein

Share this post


Link to post
Share on other sites

ok, danke. Die sollte jetzt passen, trotzdem der Fehler.

Der IONOS Support meint, die .htaccess stimmt nicht. Ich sollte das Prüfen und ggf. richtig stellen.

Kann jemand helfen? Wie wird die richtig eingerichtet. Momentan ist die .htaccess von "dem alten Shop" eingerichtet.

Share this post


Link to post
Share on other sites

Die .htaccess einfach umbenennen in z.B. xxx.txt und dann schauen ob der Shop kommt.

Kommst du ins Backoffice?

 

Share this post


Link to post
Share on other sites

Nein, ich habe im Frontend und im Backend einen weißen Bildschirm "wird nur die Domain" angezeigt als ssl.

Ich sehe auch nirgendwo einen Fehler. Der Shop wird nicht korrekt aufgerufen. Ich nehme auch an das die .htaccess nicht passt.

 

Share this post


Link to post
Share on other sites

Ok, aber hast du die .htaccess  inzwischen umbenannt?

Share this post


Link to post
Share on other sites

ja und wieder zurück.

.htaccess

# ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again
# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
# http://www.prestashop.com - http://www.prestashop.com/forums

<IfModule mod_rewrite.c>
<IfModule mod_env.c>
SetEnv HTTP_MOD_REWRITE On
</IfModule>

RewriteEngine on


#Domain: www.amspo24-online.de
RewriteRule . - [E=REWRITEBASE:/]
RewriteRule ^api(?:/(.*))?$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]

# AlphaImageLoader for IE and fancybox
RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L]
</IfModule>

AddType application/vnd.ms-fontobject .eot
AddType font/ttf .ttf
AddType font/otf .otf
AddType application/font-woff .woff
AddType font/woff2 .woff2
<IfModule mod_headers.c>
	<FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|svg)$">
		Header set Access-Control-Allow-Origin "*"
	</FilesMatch>
</IfModule>

#If rewrite mod isn't enabled
ErrorDocument 404 /index.php?controller=404

# ~~end~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again

 

Share this post


Link to post
Share on other sites

Danke ich habs. Hatte ich schon mal. Verstehe nicht, warum das umbenannt ist.

if (!defined('_PS_MODE_DEV_')) {
define('_PS_MODE_DEV_', true);

Geht wieder!

Share this post


Link to post
Share on other sites

In welchem Zustang geht es wieder

wenn dort true oder false eingetragen ist?

Share this post


Link to post
Share on other sites

Die Einstellung schaltet nur die Fehleranzeige aus bzw. ein. Der Shop müßte - wenn alles stimmen würde - mit beiden Einstellungen gleich laufen.

Im Normalbetrieb muß hier false eingetragen sein!

 

Share this post


Link to post
Share on other sites

Dann weiß ich auch nicht weiter! Mit diesem Shop binn ich noch nie zurecht gekommen. Bin immer wieder zurück auf Gambio. Da werde ich wieder zurück gehen. Die Features was Presta bietet, sind für die Möglichkeiten sehr gut.

Alles gut.

Share this post


Link to post
Share on other sites

Gambio ist ja auch nicht die schlechteste Shopsoftware, aber du wirst Gründe gehabt haben warum du zu Prestashop wechseln wolltest?

Möglicherweise wäre die 1.6er Prestashop-Version oder der PS Fork die geeignetere Software.

 

Share this post


Link to post
Share on other sites

Klar habe ich Gründe gehabt. Im Prestashop gibt es eine Menge interessanten Module, mit denen man den Shop gut hochbringen kann. In Gambio ist die Auswahl nicht so hoch. Ich war schon Kunde bei Presta vor über 15 Jahren. Ich habe zwischenzeitlich auch unter verschiedenen Softwaren gewechselt und musste sagen, das für mich "shopware.com" die beste Software war.

Gambio auch nicht schlecht, aber auch immer mal Problem. Der Support bei Gambio ist sehr gut. Immer dieser Wechsel, um das Beste zu finden. Dazu kommt, dass ein Shop nicht meine Existenz ist.

Perfekt wäre, wenn es bei Presta einen bezahlbaren Support in mehreren Sprachen geben würde. Die Fehler, die man Feststellt, zu bereinigen über das Forum ist zwar gut und wichtig, aber da Fehlt, das einer "Datenschutzkonform" darauf zugreifen kann und Daten korrigiert.

War soll iich jetzt mit meinem Problem machen?

Edited by AMSPO24-Online (see edit history)

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb AMSPO24-Online:

Ich war schon Kunde bei Presta vor über 15 Jahren.

Naja, vor 15 Jahren vielleicht nicht ganz😉

vor einer Stunde schrieb AMSPO24-Online:

War soll iich jetzt mit meinem Problem machen?

Es gibt zum einen Agenturen, die gegen Bezahlung Support bieten (wir sind leider mit Bestandskunden völlig ausgebucht) zum anderen, ich habe es ja bereits angedeutet, hast du dir eine Prestashop Version ausgesucht, die nun mal noch nicht so rund läuft.

Eine Prestashop Installation dauert ja keine Viertelstunde probier doch einfach mal die 1.6.1.24 oder den Prestashop Fork. Ich denke damit kämst du deutlich besser zurecht.

Share this post


Link to post
Share on other sites

Wahrscheinlich hast du vergessen nach dem Umzug den cache zu löschen (/var/cache/ auf dem Server zu /var/cache_old umbennen). Dass die .htacccess neu generiert werden sollte hast du ja schon bemerkt ( z.b. durch Friendly URL ab-/und anschalten)

Share this post


Link to post
Share on other sites

@Whiley

Gut, aber ich muss bei der 1.7.6.2 bleiben, da ich nicht nochmal alles neu Eintragen will (Artikel, und so weiter).

@JBW

z.b. durch Friendly URL ab-/und anschalten ???

Ist das nich der normale Cache Zugang?

Share this post


Link to post
Share on other sites
Just now, AMSPO24-Online said:

z.b. durch Friendly URL ab-/und anschalten ???

Das ist für die .htaccess re-generieren.

42 minutes ago, JBW said:

/var/cache/ auf dem Server zu /var/cache_old umbennen

Das ist für den Cache - die Funktion im Backoffice löscht nicht alles was nach einem Serverumzug aber erforderlich ist.

Share this post


Link to post
Share on other sites
Just now, AMSPO24-Online said:

Wie re-generiere ich .htaccess?

 

58 minutes ago, JBW said:

Dass die .htacccess neu generiert werden sollte hast du ja schon bemerkt ( z.b. durch Friendly URL ab-/und anschalten)

So :) Siehe Traffic&SEO->URL Einstellungen->Benutzerfreundliche URL

Share this post


Link to post
Share on other sites

Aus- und einschalten der Friendly URLs heißt erst auf NEIN, dann speichern, dann auf JA, dabei wird die .htaccess neu generiert.

Die Meldung mit evtl. nicht aktiviertem mod_rewrite ist sehr verbreitet, wenn die Friendly URLs funktionieren ist auch mod_rewrite aktiv.

Infos und Warnungen wegen fehlender Übersetzungen sind keine Fehler.

  • Thanks 1

Share this post


Link to post
Share on other sites

Ich würde es so stehen lassen, natürlich sollten dann auch auf dem Server beide Optionen verfügbar und aktiv sein.

Derr Multiview sollte normalerwesise dazu dienen, dass je nach Herkunft des Besuchers dessen Ländereintellungen im Browser berücksichtigt werden und eine möglichst passende Sprachversion präsentiert wird. Beispielsweise kann ein Chinese eher weniger deutsch als englisch verstehen, also sollte ihm gar nicht erst die deutsche Ausgabe sondern gleich die englische gezeigt werden. Inwieweit Prestashop das kann, vermag ich nicht zu beurteilen.

Das mod_security ist hier an der Stelle eigentlich bei einem Server immer noch eine der wichtigsten Basics, das soll den Hackern den Zugriff erschweren, allerdings nur im Zusammenhang mit weitergehenden Sicherheitsfunktionen wird das dann wirklich zur effektiven Schutzfunktion. Kommt z.B. ein Hacker rein und versucht, sich einen Zugang im Adminbereich zu verschaffen, löst das im Allgemeinen einen Regelverstoß in mod_security aus. Solange aber dann nicht geregelt ist, was damit passiert, kann der Hacker munter weiter machen (in der Regel wird er eine Bruteforce-Atacke laufen haben, die das automatisiert). Setzt man dann z.B. Fail2Ban ein, kann man dort sinnvollerweise gleich festlegen, dass nach einer bestimmten Anzahl von Verstößen eine Zeitsperre ausgelöst wird und die entsprechende IP dann für die festgelegte Zeit ausgesperrt wird. Das tut mod_security zwar auch, aber dort wird es eben nur abgefangen und in einem Access-Denied (http 403) enden, aber man kann sofort weitermachen, was eben verhindert werden soll. Landet es dann nach ein paar Versuchen bei Fail2Ban in einem Jail, kann der Hacker seine Versuche ben erst nach der dort eingestellten Zeit fortsetzen. In Fail2Ban kann man dann weider festlegen, was passiert, wenn dieselbe IP nach Ablauf der Zeit wieder auffällig wird und sie da weitermacht, wo sie vor der Sperre war, kann man einstellen dass sie in einem sogenannten recidive Jail landet und dort beispielsweise eine Woche lang keinen Zugang mehr zum Server bekommt.

Also ist das erste Fragezeichen eine Einstellung, wie nutzerfreundlich die Seite daherkommt, die zweite sollte eigentlich immer auf NEIN stehen, und wenn der Shop bei Nein nicht funktioniert, sollte dieses Problem serverseitig gelöst werden, ein Abschalten würde ich allenfalls in einer geesperrten Testumgebung (z.B. auf einem nicht von aussen zugänglichen Rechner vornehmen, im produktiven Betrieb im www ist es eigentlich eine MUSS-Einstellung.

  • Thanks 1

Share this post


Link to post
Share on other sites
17 minutes ago, AMSPO24-Online said:

"[Debug] This page has moved
Please use the following URL instead: https://www.amspo24-online.de/20-view

In allen Bereichten!

Was mache ich da?

Debug Modus abschalten - das ist nur ein Hinweis falls du alte URLs aufrufst, kannst du ignorieren

  • Thanks 1

Share this post


Link to post
Share on other sites

Ich würde erst einmal die .htaccess umbenennen, ansonsten den Debug Modus in der config-Datei aktivieren oder in den Fehler-Logs nachschauen.

  • Thanks 1

Share this post


Link to post
Share on other sites

Der Debug-Modus (zumindest in der config-Datei) bewirkt, daß Fehlermeldungen ausgegeben werden, bei der entsprechenden Einstellung im BackOffice (die es bei Prestashop 1.6 noch nicht gibt) bin ich mir nicht sicher ob der nicht noch etwas anderes bewirkt. Eigentlich sollte der Shop mit und ohne Debug-Modus gleichermaßen funktionieren oder nicht funktionieren.

Zumindest läßt sich dein Shop jetzt aufrufen. Ich würde zunächst per Einstellung alle Fremdmodule und Overrides deaktivieren und dann den Debug-Modus in der config-Datei wieder abstellen, ggf. den Cache-Ordner (ich glaube cache/var) löschen.

PS: Bist du Türke? Oder warum heißt es "Üner uns"?

  • Thanks 1

Share this post


Link to post
Share on other sites

Danke, "Üner" ist geändert. Sollte das auf "Ja" gesetzt werden um mehr Leisung zu erhalten? Und wenn da ein Fehler dazu auftritt, welcher Bereich wäre das per FTP um das wieder Rückgängig zu machen?

grafik.thumb.png.28db9167c3812222fbd4a565b9a37e89.png

Share this post


Link to post
Share on other sites

Ja die sollten auf Ja gestellt werden außer du entwickelst oder designest gerade in JS oder CSS. Da sollten keine Probleme mit auftreten, ansonsten kannst du das im Backend oder im Notfall über die Datenbank wieder deaktivieren.

  • Thanks 1

Share this post


Link to post
Share on other sites

@JBW

Danke.

@rictools @idnovate.com

Zitat

Der Debug-Modus (zumindest in der config-Datei) ....

Seit dem ich das wieder gängig gemacht habe, merke ich, dass die Cookies nicht mehr angesteuert werden "Cookies - DSGVO Cookie-Gesetz (Block vor Zustimmung)", im Backend wurde nix verändert.

Was kann das sein?

Share this post


Link to post
Share on other sites
5 minutes ago, AMSPO24-Online said:

@JBW

Danke.

@rictools @idnovate.com

Seit dem ich das wieder gängig gemacht habe, merke ich, dass die Cookies nicht mehr angesteuert werden "Cookies - DSGVO Cookie-Gesetz (Block vor Zustimmung)", im Backend wurde nix verändert.

Was kann das sein?

Entschuldigung, wegen der Sprache verstehe ich nicht ganz, was das Problem ist.

Können Sie uns eine Nachricht über Addons (https://addons.prestashop.com/contact-form.php?id_product=21644) senden?

Vielen Dank

Share this post


Link to post
Share on other sites

Ich wollte es senden, obwohl ich Eingelogt bin, kommt der Fehler vom Prestashop:

grafik.png.b8d17dd7ecda3cd2c9f509ab19d51cdb.png

 

Langsam hat man keine lust mehr.

Wenn ich die FTP etc. nicht weg bring, da kann ich nicht helfen.

Share this post


Link to post
Share on other sites

Ich schilder des nochmal kurz:

Es geht um Cookie, die nicht immer angezeigt werden. In Microsoft Edge geht es. In Google Chrome wird das Cookie oft angezeigt, aber nicht immer. In Firefox wir es nicht angezeigt. Normal muss das Cookie bei jedem neu Einstig angezeigt werden. So will ich es haben.

Was soll ich da machen?

 

Webseite: https://www.amspo24-online.de / zur Zeit nicht Wartungsmodus, weil die Cookies nich richtig funktionieren

 

IMG_20200212_160653.jpg

Edited by AMSPO24-Online (see edit history)

Share this post


Link to post
Share on other sites

Warum machst du es dir Extra schwer...? du bist doch bei it-recht-Kanzlei und die Bieten Kostenlosen EU Cookie 

 

Edited by SliderFlash (see edit history)
  • Thanks 1

Share this post


Link to post
Share on other sites

Du hast ja Recht, ich habe sogar den Zugang für Cookies und mehr von PRIVE. Da brauche ich aber auch die Anleitung wie und wo das im Shop eingetragen wird. Ich habe die Module von IT-Recht-Kanzlei und Shopvote, aber von Prive nicht.

Ich müsste wissen wie das im Shop integriert wird!?

Share this post


Link to post
Share on other sites

oben unter dem Link habe ich Beschreibung dazu geschrieben, klicke mal drauf und geh zum Thema dann siehst du es.

Hier nochmal die Anleitung:

Anleitung : 😊

-Bei IT-Recht einloggen und unten Rechts unter SERVICE LEISTUNGEN gibts jetzt den Link Cookie-Consent Tools (neu), dort gibt es in der beschreibung einen Link zur anmeldung bei Prive dort anklicken.

- Nach der Anmeldung bei PRIVE  bekommt ihr einen Javasript Code schnipsel, Kopieren

- Jetzt bei It-Recht unter Datenschutz Cookie aktivieren und Datenschutz neu übertragen

- Templates euer Template/_partials/head.tpl mit editor öffnen und den Javascript zwischen {literal} und {/literal} eintragen

Cache löschen Fertig...!

Edited by SliderFlash (see edit history)
  • Thanks 1

Share this post


Link to post
Share on other sites

@SliderFlash

Also, ich habe ja Mitglied bei der IT-Recht-Kanzlei und habr auch schon beim vorherigen Shop Prive genommen. Es ist mir nicht unbekannt, ich finde Prive gut. Aber ich glaube, dass man nur eine bestimmte Anzahl an Aufrufen schalten kann.

Die zusatz Leistungen (kostenplichtig) sind natürlich auch Top.

Ich schlafe noch mal 2 Tage drüber und entscheide mich dann.

Danke an allen, man ist nicht alleine in dem Chaos!

 

 

Share this post


Link to post
Share on other sites
vor 9 Stunden schrieb AMSPO24-Online:

Es geht um Cookie, die nicht immer angezeigt werden. In Microsoft Edge geht es. In Google Chrome wird das Cookie oft angezeigt, aber nicht immer. In Firefox wir es nicht angezeigt. Normal muss das Cookie bei jedem neu Einstig angezeigt werden. So will ich es haben.

Leider schreibst du manchmal recht rätselhaft, so werden ja Cookies nicht angezeigt, sondern das Cookie-Overlay, so etwas führt zu Mißverständnissen. Mit dem Satz "Wenn ich die FTP etc. nicht weg bring, da kann ich nicht helfen." kann ich überhaupt nichts anfangen, "FTP" (das File Transfer Protokoll) oder ein FTP-Programm kann man nicht wegbringen ...

Wenn das Overlay in bestimmten Browsern angezeigt wird, in anderen nicht oder nur manchmal, liegt es wohl entweder am Cache oder es ist vielleicht auch eine absichtliche Einstellung, daß das Cookie-Overlay nicht angezeigt wird, solange es schon einmal angezeigt wurde und sich die IP nicht geändert hat.

  • Thanks 1

Share this post


Link to post
Share on other sites

Welche PHP-Version läuft denn eigentlich bei dir? Soweit ich weiß, setzt IONOS standardmäßig immer die aktuelle ein, also 7.3.14. Darunter bekommst du aber einen Prestashop 1.6 nur mit Anpassungen richtig zum Laufen, einen Prestashop 1.7 gar nicht. Oder ist das bei VPS frei wählbar?

Share this post


Link to post
Share on other sites

VPS sollte alles so einstellbar, wie man es will, entweder selber machen oder beim Managed kriegen die gesagt, was zu tun ist. Das ist einer der Vorteile des eigenen VPS und bei einem vernünftigen Provider kann man da relaitv frei auswählen, was läuft, selbstverständlich ohne Aufpreise dafür.

  • Thanks 1

Share this post


Link to post
Share on other sites
9 hours ago, rictools said:

Leider schreibst du manchmal recht rätselhaft, so werden ja Cookies nicht angezeigt, sondern das Cookie-Overlay, so etwas führt zu Mißverständnissen. Mit dem Satz "Wenn ich die FTP etc. nicht weg bring, da kann ich nicht helfen." kann ich überhaupt nichts anfangen, "FTP" (das File Transfer Protokoll) oder ein FTP-Programm kann man nicht wegbringen ...

Wenn das Overlay in bestimmten Browsern angezeigt wird, in anderen nicht oder nur manchmal, liegt es wohl entweder am Cache oder es ist vielleicht auch eine absichtliche Einstellung, daß das Cookie-Overlay nicht angezeigt wird, solange es schon einmal angezeigt wurde und sich die IP nicht geändert hat.

Das Cookie-Akzeptanzfenster sollte nur angezeigt werden, wenn der Kunde Cookies noch nicht akzeptiert / abgelehnt hat.

Sobald der Kunde Cookies akzeptiert / abgelehnt hat, wird diese erst wieder angezeigt, wenn der Kunde die Cookies löscht.

Wenn es nicht so funktioniert, gibt es offensichtlich einen Fehler, den wir uns ansehen sollten.

@AMSPO24-Online ist das das problem?

  • Thanks 1

Share this post


Link to post
Share on other sites

 

@rictools

Zitat

Wenn das Overlay in bestimmten Browsern angezeigt wird, in anderen nicht oder nur manchmal, liegt es wohl entweder am Cache oder es ist vielleicht auch eine absichtliche Einstellung, daß das Cookie-Overlay nicht angezeigt wird, solange es schon einmal angezeigt wurde und sich die IP nicht geändert hat.

Ok danke, so kann man es richtig benennen. Es kann mit dem Cache bzw. der IP zusammenhängen. IP glaube ich nicht, weil wenn ich den Rechner runterfahre und später wieder hochfahre wird das Cookie-Overlay nicht angezeigt.

Was bedeutet die Cookie-Laufzeit?  Sorry Steht ja da!

grafik.png.bed443c26d756c8ba8f549a9f752c4b9.png

* Cookie-Laufzeit ... bis der Kunde Cookies löscht: Kann das nicht automatisiert werden, wenn einer den Shop beendet, dass die Cookies gelöscht werden.

 

@Wuschel

Ich habe die PHP Version 7.2.x ! Die Versionen 7.3 und 7.4 könnte ich auch nutzen.

 

 

Edited by AMSPO24-Online (see edit history)

Share this post


Link to post
Share on other sites

@idnovate.com

Dann ist es klar, wobei besser wäre meiner Meinung nach, wenn die Cookie-Laufzeit richtig laufen würde. Ich habe auch keine Ahnung in den technischen Sachen. Ich kenn das nur von Prive, dass der Cookie-Overlay angezeigt wird oder werden kann, wenn man auf den Shop geht.

 

Share this post


Link to post
Share on other sites

Das Beenden wir, ja es liegt an der Laufzeit. Wenn man über den Tag geht, wird der Cookie auch wieder angezeigt.

Nur noch eine Frage, wenn man den Shop wieder aufruft, geht die Cookie-Laufzeit erneut auf einen Tag? Wenn ich mehrerer Male am Tag auf den Shop gehen, dann würde die Laufzeit nie zu Ende gehen, oder?

Edited by AMSPO24-Online (see edit history)

Share this post


Link to post
Share on other sites

Die Ablaufzeit des Cookies wird nicht erneuert.

Wenn ich heute ein Cookie erstelle und eine Ablaufzeit von 2 Tagen einstelle, wird es morgen NICHT um weitere 2 Tage verlängert, wenn ich morgen zurückkomme.

  • Thanks 1

Share this post


Link to post
Share on other sites
vor 1 Stunde schrieb AMSPO24-Online:

IP glaube ich nicht, weil wenn ich den Rechner runterfahre und später wieder hochfahre wird das Cookie-Overlay nicht angezeigt.

Eine neue IP bekommst du normalerweise nur, wenn die Internetverbindung neu aufgebaut wird, das ist bei einem Rechnerneustart nicht unbedingt der Fall.

Verstehe ich dich richtig, wenn ein Besucher Cookies akzeptiert, soll er nicht nur bereits am nächsten Tag, sondern möglichst noch öfter wieder diesen lästigen Banner angezeigt werden können? Das grenzt ja an Menschenquälerei ...

Share this post


Link to post
Share on other sites

Ja, du verstehst mich richtig. Auch wenn die Cookies maßiv nerven, sind sie halt notwendig. Bei anderen Shops bzw. Providern werde teilweise auch die Cookies nach jedem neuen ersten Aufruf angezeigt. Ich dachte, ich habe darüber was gelesen.

Das ist erledigt!

Share this post


Link to post
Share on other sites

Das verstehe ich nicht, wenn ich einmal in den Erhalt von Cookies eingewilligt habe dann sollte das per Cookie auf Dauer gespeichert werden, warum soll denn eine ständig wiederholte Einwilligung notwendig sein? Anders ist es, wenn ich Cookies ablehne, dann kann man das ja schlecht per Cookie speichern ...

Share this post


Link to post
Share on other sites

Anders gesagt, eine Familie mit nur einem PC schauen auf die Webseite, nicht zusammen, aber einer früh, der andere abens. Der erste setzt den Hagen, beim zweiten ist der Haken schon gesetzt. Und schon ist es ein Verstoß.

Ich hak das jetzt entgültig ab.

Share this post


Link to post
Share on other sites

Na, wenn sich diese Sichtweise durchsetzen sollte, wird das Internet quasi unbenutzbar ...

Share this post


Link to post
Share on other sites

Hier käme dann die Verantwortung des einzelnen Besuchers ind Spiel keine anderen Leute an seinen Rechner zu lassen :)

 

Share this post


Link to post
Share on other sites
vor 4 Minuten schrieb Claudiocool:

Hier käme dann die Verantwortung des einzelnen Besuchers ind Spiel keine anderen Leute an seinen Rechner zu lassen

Das wäre ja aber auch ganz gemein gegenüber den Tracking-Tools, die speichern dann falsches Surfverhalten eines vermeintlichen Benutzers. Das geht natürlich garnicht!

Share this post


Link to post
Share on other sites

Das gerät hier zwar allmählich off Topic, aber ganz ehrlich: Um Webseiten oder Shops, die mich immer wieder aufs Neue mit Cookie-Disclaimern nerven, mache ich normalerweise einen großen Bogen. Das einmalige Klicken beim ersten Besuch jeder beliebigen Homepage geht mir schon genug auf den Keks. Aber Dauerfeuer mit Disclaiming, wie von @AMSPO24-Online anscheinend bevorzugt?

Geht euch das nicht auch so? Das ist doch weder kundenfreundlich noch verkaufsfördernd!

Share this post


Link to post
Share on other sites

Nun, ich denke, daß die Cookie-Diskussion hier nicht ernst zu nehmen ist, zumal der TE - zumindest bisher - ja gar keine Cookies verwendet!😉

Wahrscheinlich täte der TE besser daran mal die anderen echten rechtlich relevanten Schwachstellen in seinem Shop zu beseitigen.

Share this post


Link to post
Share on other sites

Letzte Cookie-Frage...

Wo ändere ich diesen Bereich, unter

modules/cookiesplus/de.php ist es nicht. Wenn in der Datenbank, wo genau?

 

A025.png

A026.png

Share this post


Link to post
Share on other sites

wen du das Modul im Backoffice öfnest ist oben Übersetzen, drauf klicken. da kannst du es übersetzen und speichern

Edited by SliderFlash (see edit history)
  • Thanks 1

Share this post


Link to post
Share on other sites

@SliderFlash

Warum kann ich in allen Bereichen die Anpassung neuer Übersetzungen (endlisch -> deutsch) nicht speichern? Was soll das, oder fehlen Rechte, wenn ja, wie müssen die Rechte lauten (X X X?

grafik.thumb.png.1ba7b37e9c1c9f64dbb4eccd58ea2ca3.png

Share this post


Link to post
Share on other sites

Du musst in den Roten Feldern die Übersetzung reinschreiben, links siehst du die original Sprache, danach speichern, und eventuell wieder Cache löschen.

 

Share this post


Link to post
Share on other sites

haha, hundert mal reingetippt, gespeichert (wird sogar angezeigt), wenn man wieder reingeht, sind die deutsche Übersetzungen weg, als ob ich nie was reingetippt habe.

Keine Ahnung an was das liegt (vielleicht sind es die Rechte), wo bei in nicht weiß, wo der Bereich ist, dass ich die Rechte prüfen kann.

Share this post


Link to post
Share on other sites

Klingt irgendwie nach PHP 7.3 ...

Caches hast du gelöscht?

Share this post


Link to post
Share on other sites

@AMSPO24-Online

Ich habe Ihnen per Privatnachricht geantwortet. Konnten Sie schon alle Ihre Probleme lösen?

Tut mir leid, aber ich kann dem Thema nicht richtig folgen :)

Share this post


Link to post
Share on other sites

@idnovate.com

Ja, ich konnte die Probleme Ihres Moduls lösen. Aner ich hätte noch eine Bitte, was möglicherweise auch anderen Usern interessieren könnte.

Der Bereich, sie Bild, wird auf einem PC Optimal dargestellt. Auf einem Handy könnte die Anzeige besser gelöst werden, in dem man die Ansicht wie folgt macht:

grafik.png.7234b2614fc20d9078fc0e5655857858.png

 

besser wäre (für Handys)

 

Diese Seite nutzt ........
............. etc.

JA, ICH AKZEPTIERE
MEIN INFORMATIONEN

Datenschutz etc.

Nicht nebeneinander sondern untereinander.

So kann man das auf einem PC und auf einem Handy gut erkennen!!

Vielleicht ist das eine Überlegung wert!

 

 

 

Share this post


Link to post
Share on other sites

Vielen Dank für den Kommentar!

Manchmal deaktivieren die Themen der Shops die Cookie-Warnung.

Keine Sorge, wir passen die Cookie-Warnung an jedes Thema an.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More