Jump to content
Maxime Lysadis

Ajouter la page "magasins" au menu horizontal

Recommended Posts

Bonjour, 

Je suis un nouvel utilisateur de Prestashop, et je suis en train de mettre en place un site avec cette solution.

J'aimerais faire apparaître la liste de nos magasins dans le menu horizontal, mais je ne le trouve pas dans la liste de élements disponible.
Je le trouve dans "Link Widget" pour le faire apparaître dans le footer, mais pas pour le menu horizontal.

J'ai également tenté de créer un lien, mais je n'arrive pas à faire un lien relatif

Créer des pages statiques et une catégorie "magasins" fonctionnerait, mais d'une, ça fait doublon, et de deux le listing des pages dans la catégorie est particulièrement moche.

Est-ce que quelqu'un a déjà essayé ça ?
merci d'avance

Maxime

Share this post


Link to post
Share on other sites

Bonjour,

la page magasins est accessible avec une url connue ?

Si oui, ajoutez un simple lien dans le menu en utilisant cette url connue.

Share this post


Link to post
Share on other sites

Il s'agit de la page "magasins" qui se configure via le BO: Paramètres boutique > Contacts > magasins
Le lien vers la page magasin apparaît ensuite par défaut dans le footer via le link widget

Pour l'instant le lien absolu est http://localhost/magasins mais j'aurais préféré indiquer un lien relatif pour quand je passerais le site en production

Share this post


Link to post
Share on other sites
il y a 2 minutes, Maxime Lysadis a dit :

mais j'aurais préféré indiquer un lien relatif pour quand je passerais le site en production

/magasins (si vous installez votre PrestaShop à la raine de votre non de domaine)

sous-répertoire/magasins (si vous installez PrestaShop dans un sous répertoire)

sous-répertoire/sous-sous-répertoire/magasins (si vous installez PrestaShop dans un sous sous répertoire)

...

Share this post


Link to post
Share on other sites

Je comprends la logique :)
Cela dit, j'avais déjà essayé ça, mais le lien renvoie vers > http://magasins/ (donc introuvable)

Quand j'enregistre le lien, ça rajoute automatiquement http:// (donc, en l'occurence http:///magasins (oui avec 3 slashes))
J'ai tenté de désactiver l'option "html purifier" dans les options, mais le http:// se rajoute toujours.

C'est surprenant que ce soit aussi compliqué de faire des lien relatifs 😕

Edit : désolé pour la réponse tardive, je ne parvenais plus à accéder au fil

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More